Yoann DEGOT LONGHI

Problêmes de flats....avis aux cadors _PAS RESOLU !_

Recommended Posts

Salut

 

J'ai encore et toujours des soucis de halos disgracieux sur mes images, certainement dû aux flats.

 

Voici la sortie de prétraitement avec Siril:

5c7a658e27906_haloimage.JPG.448aa26160e0ced3a9d7c34518c399ba.JPG

 

Le prétraitement sans les flats, en mode histo pour bien voir:

5c7a661aa758e_sansflats.JPG.74806f4ad083486578f74a5ef1c5dd25.JPG

 

J'ai refait des flats tip top sur les conseils d'un connaisseur:

 

 

 

m12000.JPG.e07b67a3c45c576659bfe13740cfec77.JPG

 

avec une moyenne vers 12000, ce flat est à priori ideal.

 

J'ai bien sûr fait d"autres essais avec différents flats plus ou moins exposés, résultats identiques.

 

J'en appelle aux pros du flat, vous avez une idée du soucis?

 

 

Yoann

Edited by dynt
  • Like 1

Share this post


Link to post
Share on other sites
Advertising
By registering on Astrosurf,
this type of ad will no longer be displayed.
Planetary Astronomy
Observing, imaging and studying the planets
A comprehensive book about observing, imaging, and studying planets. It has been written by seven authors, all being skillful amateur observers in their respective domains.
More information on www.planetary-astronomy.com

ARW c'est du A7S ça non ?

 

Tes flats tu les as fait au même ISO que les images ?

Share this post


Link to post
Share on other sites

Alors le problème peut venir de là.

Si tu utilises mes scripts, je précise bien qu'ils ne sont pas capables à l'heure actuelle de traiter des images avec des ISO différents, notamment les flats.

Il faut impérativement que tes flats soient au même ISO que les brutes, sinon tu soustrais des offsets qui ne sont pas au même ISO que les flats et ça va foutre la grouille.

 

Je dis pas que le problème vient de là, mais il peut venir de là.

Share this post


Link to post
Share on other sites

Perso j'ai été obligé de monter un potentiomètre sur mon écran à flat parce qu'à 3200 ISO les images étaient cramées à 1/8000s :D:D

Je mets donc maintenant le potentiomètre au minimum, mais l'écran scintille et on voit une trame sur les images si le temps de pose est trop court (un peu comme les lignes d'un téléviseur).

L'astuce c'est alors de poser très longtemps pour bien lisser cette trame. Je pose entre 2 et 4 secondes avec le potentiomètre au minimum. A 3200 ISO.

  • Like 1

Share this post


Link to post
Share on other sites
Il y a 2 heures, dynt a dit :

avec une moyenne vers 12000, ce flat est à priori ideal.

 

ca ne veut pas dire grand chose la moyenne. encore moins avec une matrice de bayer (un capteur couleur).

 

- il faut que les coins ne soient pas trop sombres, mini 1/3 du max possible. Et ce pour chaque couleur en non débayérisée.

 

- il ne faut pas que le centre soit trop clair. là c'est vital : il faut rester dans la zone de linéarité du capteur, soit 2/3 du max typiquement. Sinon les flat ne corrigent pas bien. La encore il faut vérifier chaque couleur avant débayerisation. Donc zoomer à fond sur le raw et vérifier chaque pixel. Il est courant que la moyenne soit bonne mais que les pixels verts soient trop lumineux et sortis de la zone de linéarité, voir saturent.

 

Évidemment ce point est aussi valable pour les images.

 

De là la moyenne peut être assez variable, suivant le vignettage du télescope.

 

 

Edited by olivdeso
bayer
  • Like 1

Share this post


Link to post
Share on other sites

@Colmic : il est facile de creer un script qui gère des flats a differents iso  ;) je m'en suis meme fait pour ma propre utilisation, avec optimisation des darks.

  • Like 2
  • Love 1

Share this post


Link to post
Share on other sites
Il y a 4 heures, lock042_CyrilRichard a dit :

il est facile de créer un script qui gère des flats a différents iso  ;) je m'en suis meme fait pour ma propre utilisation, avec optimisation des darks.

 

Si tu pouvais le partager sur le forum de siril  :) je m'en irai de se pas le téléchargé :P

 

Merci  

Share this post


Link to post
Share on other sites
il y a 57 minutes, Sauveur a dit :

Si tu pouvais le partager sur le forum de siril  :) je m'en irai de se pas le téléchargé :P

Fait

  • Thanks 1

Share this post


Link to post
Share on other sites
Il y a 9 heures, Colmic a dit :

Il faut impérativement que tes flats soient au même ISO que les brutes, sinon tu soustrais des offsets qui ne sont pas au même ISO que les flats et ça va foutre la grouille.

 

sur le 7S (comme sur la plupart des appareils, sinon tous) le niveau d'offset ne varie pas en fonction des iso, donc pourquoi diable faire des offsets à n'importe quel iso poserait-il un problème ? De même, un flat peut être fait à n'importe quel iso. Le mieux évidemment étant de faire des flats et des offset à 100 iso, on aura besoin d'en faire d'autant moins (1 flat à 100 iso équivaut à 8 flats à 800 iso !). Et pour l'offset, puisqu'il est plat, le plus simple et rapide est d'utiliser une image synthétique constante dont l'avantage est de ne contenir aucun bruit

 

:)

Edited by Thierry Legault
  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
Il y a 6 heures, olivdeso a dit :

il ne faut pas que le centre soit trop clair. là c'est vital : il faut rester dans la zone de linéarité du capteur, soit 2/3 du max typiquement

 

sur les APN la réponse est linéaire jusqu'au bout, donc pas de risque tant qu'on n'atteint pas la saturation

 

:)

  • Like 2

Share this post


Link to post
Share on other sites
il y a 4 minutes, Thierry Legault a dit :

sur le 7S (comme sur la plupart des appareils, sinon tous) le niveau d'offset ne varie pas en fonction des iso, donc pourquoi diable faire des offsets à l'importe quel iso poserait-il un problème ?

 

Tu me confirmes qu'un offset à 100 ISO est strictement identique à un offset à 3200 ? Même avec l'ampli qui déclenche à 2000 ?

Ah ben ça va me faciliter la vie ça !

Share this post


Link to post
Share on other sites
Il y a 9 heures, Colmic a dit :

Perso j'ai été obligé de monter un potentiomètre sur mon écran à flat parce qu'à 3200 ISO les images étaient cramées à 1/8000s :D:D

 

ça me rappelle l'histoire du gars qui met des boules Quies parce qu'il a réglé le son de sa télé trop fort xD xD xD

Edited by Thierry Legault
  • Like 1

Share this post


Link to post
Share on other sites
il y a 6 minutes, Colmic a dit :

Tu me confirmes qu'un offset à 100 ISO est strictement identique à un offset à 3200 ? Même avec l'ampli qui déclenche à 2000 ?

 

faut faire simple : tu prends comme offset une image constante au niveau d'offset moyen (je crois que c'est 128 sur le 7S) et puis voilà !!!

 

Quant à ton offset à 100 iso, il est moins bruité (en ADU) que celui à 3200 !

 

 

Edited by Thierry Legault
  • Like 1

Share this post


Link to post
Share on other sites
Il y a 16 heures, Thierry Legault a dit :

 

sur les APN la réponse est linéaire jusqu'au bout, donc pas de risque tant qu'on n'atteint pas la saturation

 

merci pour l'info, je m'en doutais un peu, mais pas testé récemment, du coup je reste sur mes vielles habitudes sans risque.

 

Mais effectivement, jai remarqué que les capteurs récents semblent avoir une linéarité plus étendue que les anciens. En CCD et probablement en CMOS, mais pas mesuré ces derniers.

 

Et c'est utile quand on a un gros vignettage, on peut tirer un peu plus au centre.

 

Attention de ne pas saturer une des couleurs au centre (habituellement le vert, voir le bleu avec les leds blanches). On se fait vite piégé si on ne regarde que l'histogramme en luminance ou la moyenne au centre.

 

 

Edited by olivdeso

Share this post


Link to post
Share on other sites
Il y a 10 heures, dynt a dit :

J'en appelle aux pros du flat, vous avez une idée du soucis?

 

et tu as essayé de prétraiter avec un autre soft, genre Iris ? 

Share this post


Link to post
Share on other sites
à l’instant, olivdeso a dit :

Attention de ne pas saturer une des couleurs au centre (habituellement le vert, voir le bleu avec les leds blanches). On se fait vite piégé si on ne regarde que l'histogramme en luminance ou la moyenne au centre.

 

oui, il faut être vigilant sur le vert, cela dit les APN affichent les histos du jpeg intégré au raw, or il y a pas mal de marge par rapport à la capacité des photosites exploitable dans toute la plage de codage des raw. Par exemple quand je fais mes transits solaires, le centre du soleil semble légèrement saturé (ça clignote à l'écran) mais il reste pas mal de marge dans le raw, en fait on est pas à la saturation.

  • Like 1

Share this post


Link to post
Share on other sites

Sur les caméra couleur, c'est un vrai piège, surtout celles [ gain réglable comme quelques CCD QHY et les CMOS.

On ne sait pas toujours ou est la saturation à gain minimum.

On a intérêt à vérifier le nombre d'ADU atteint à la saturation.

Même sur quelques APN Canon, on arrive à la saturation avant d'être au max du convertisseur. (sur le 60da par exemple c'est le cas).

 

Aussi si l'offset est un peu élevé, il faut en tenir compte afin que le niveau des coins de l'image ne soient pas trop près du.niveau d'offset. Toujours sur le 60da, l'offset qui est autour de 1000 ADU, il faut se méfier.

 

En résumé : il faut connaître le min ADU (= le niveau d'offset), le max ADU (=le niveau de saturation) et se caler entre les 2 sur toute l'image (vérifier coins et centre) et pour chaque couleur (bien vérifier les pixels RGB avant débayérisation, au centre et dans les couns)

Pour un APN dont le capteur est linéaire jusqu'à la saturation, on pourra avoir un max ADU assez proche de la saturation (80 90% au centre dans la couleur qui a le niveau le plus élevé).

 

(C'est aussi ce qu'on fait en.photo planétaire d'ailleurs pour exploiter au max la dynamique du capteur, qui est assez réduite à gai' élevé)

Share this post


Link to post
Share on other sites

Merci pour vos réponses. 

J'ai refait mes flats à 3200 isos selon les premiers onisations de Michel et relancé le pretraitement.

 

Yoann

Edited by dynt
  • Love 1

Share this post


Link to post
Share on other sites
il y a 9 minutes, dynt a dit :

J'ai refait mes flats à 3200 isos selon les premiers onisations de Michel et relancé le pretraitement

 

enfin ça n'est quand même pas normal : je répète que le changement d'iso des flats et de l'offset ne devrait pas avoir une telle influence sur le résultat. Donc il y a un problème quelque part, et il faudrait le comprendre ! O.o

  • Like 2

Share this post


Link to post
Share on other sites
Il y a 20 heures, dynt a dit :

J'ai encore et toujours des soucis de halos disgracieux sur mes images, certainement dû aux flats.

 

Voici la sortie de prétraitement avec Siril:

5c7a658e27906_haloimage.JPG.448aa26160e0ced3a9d7c34518c399ba.JPG

 

 

Donc, ce qu'on aperçoit sur cette image, c'est une non linéarité crée par l'ampli qui déclenche à 2000iso ?

Edited by PIX-astro

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now