Yoann DEGOT LONGHI

Problêmes de flats....avis aux cadors _PAS RESOLU !_

Recommended Posts

Thierry disait plus haut que les photographes obtiennent de meilleures images à bas ISO.

 

Oui  mais ils n'additionnent pas les images !

Donc comparer une à 100 ISO et une à 1000,  les temps de pose sont dans un rapport de 10 !

 

Lucien

Share this post


Link to post
Share on other sites
Publicité
En vous inscrivant sur Astrosurf,
ce type d'annonce ne sera plus affiché.
Astronomie solaire : la bible est arrivée !
400 pages, plus de 800 illustrations !
Les commandes sont ouvertes sur www.astronomiesolaire.com

Pour aller dans le sens de @Thierry Legault au niveau des offsets d'APN. Je me suis amusé a faire un superbias à partir d'un master-bias d'un canon EOS 200D.

 master-bias.png.5bfbd45a5e9a276e291996e0f4978f7b.pngsuperbias.png.3a95b19f03872d21b02e710f6628ae93.png

 

Ce qu'on peut voir, c'est que le superbias a une médiane identique au master-bias (heureusement !!) et qu'on retrouve bien la puissance de 2 indiquée par @Thierry Legault (512).

A noter que les niveaux sont extrêmement resserré pour qu'on puisse visualiser quelque-chose, car l'écart entre la valeur minimale et la valeur maximale est très très faible.

 

On peut donc en conclure qu'on peut très facilement remplacer ce super-bias, (si on n'a pas moyen d'en faire) par une image totalement plate d'une valeur de 512 (la médiane), et dénuée de tout bruit (comme le superbias).

  • Like 1

Share this post


Link to post
Share on other sites
Il y a 2 heures, lock042_CyrilRichard a dit :

On peut donc en conclure qu'on peut très facilement remplacer ce super-bias,

 

Bon ben tu sais quoi faire pour la semaine qui vient Cyril :D

Share this post


Link to post
Share on other sites
il y a 1 minute, Colmic a dit :

Bon ben tu sais quoi faire pour la semaine qui vient Cyril :D

Boarf non, voir mon dernier post :). C'est franchement chercher à tuer des mouches au lance flamme. En ce qui concerne les APN en tout cas.

Share this post


Link to post
Share on other sites
il y a 6 minutes, lock042_CyrilRichard a dit :

Boarf non, voir mon dernier post :)

 

Oui j'ai bien vu. Mais imagine que tu ajoutes une fonction qui crée automatiquement un superbias, et que tu puisses scripter cette fonction : plus besoin de faire d'offset (sous condition qu'on ne fasse pas d'optimisation des darks)

T'as plus qu'à faire des flats et des darks.

Bon en même temps c'est pas ce qu'il y a de plus compliqué à faire les offsets :)

Share this post


Link to post
Share on other sites
il y a 3 minutes, Colmic a dit :

Bon en même temps c'est pas ce qu'il y a de plus compliqué à faire les offsets

Ben tu vas dans siril. Tu regarde le niveau median de ton master offset. Imaginons qu'elle est de 512, comme moi.

Tu tapes :

fill 512

dans la ligne de commande de siril et tu enregistres le fichiers comme super-bias. T'as plus qu'a modifier ton script pour qu'il utilise ce bias la. Et voila.

Share this post


Link to post
Share on other sites
Il y a 14 heures, lock042_CyrilRichard a dit :

Pour aller dans le sens de @Thierry Legault au niveau des offsets d'APN. Je me suis amusé a faire un superbias à partir d'un master-bias d'un canon EOS 200D

 

prêté par un musée ? xD

 

Heureusement que l'offset est plat sur les APN...sinon ça poserait pas mal de problèmes aux logiciels type Photoshop ou DPP, quand ils doivent développer les raw.  Il leur faut bien soustraire l'offset tout comme nous, mais il n'y a pas d'image d'offset cachée quelque part dans le fichier raw. En fait le niveau d'offset (par exemple 1024 sur un appareil donné) est enregistré dans les métadonnées du fichier, et le logiciel fait un "sub 1024" sur tous les pixels avant de continuer le développement de l'image. C'est aussi simple que ça ! ;)

 

 

Edited by Thierry Legault

Share this post


Link to post
Share on other sites
Il y a 10 heures, Thierry Legault a dit :

En fait le niveau d'offset (par exemple 1024 sur un appareil donné) est enregistré dans les métadonnées du fichier, et le logiciel fait un "sub 1024" sur tous les pixels avant de continuer le développement de l'image. C'est aussi simple que ça ! ;)

 

Bien vu. J'ai tout compris maintenant :)

Share this post


Link to post
Share on other sites
Posted (edited)
Le 03/03/2019 à 13:50, Thierry Legault a dit :

Ca fait pas loin de 20 ans que je ne fais que des flats et des offsets à 100 iso, et je n'ai jamais perçu la "simplicité" que ça m'apporterait des les faire à plus haut iso.

 

Bonjour @Thierry Legault, si je comprends bien, quand je prends des photos (lights) à 1600 ISO, pour les DOFs, je peux alors faire :
- des darks à 1600 ISO (même t°, même temps de pose, en prendre entre 20 et 30)
- des offsets à 100 ISO (en prendre entre 20 et 30, à soustraire au dark pour pouvoir normaliser les darks)

- des flats à 100 ISO (et soustraire juste le niveau moyen d'offset, en prendre quelques uns)

 

Est-ce bien cela ?

 

A+

 

Fred

Edited by Fred_76

Share this post


Link to post
Share on other sites
Le ‎18‎/‎04‎/‎2020 à 15:44, Fred_76 a dit :

Bonjour @Thierry Legault, si je comprends bien, quand je prends des photos (lights) à 1600 ISO, pour les DOFs, je peux alors faire :
- des darks à 1600 ISO (même t°, même temps de pose, en prendre entre 20 et 30)
- des offsets à 100 ISO (en prendre entre 20 et 30, à soustraire au dark pour pouvoir normaliser les darks)

- des flats à 100 ISO (et soustraire juste le niveau moyen d'offset, en prendre quelques uns)

 

Est-ce bien cela ?

 

oups pas vu la question :$

 

Oui c'est ça. Pour l'offset, s'il est bien plat et sans bandes (comme habituellement sur les APN), tu peux en faire un seul, mesurer son niveau moyen, fabriquer une image synthétique à ce niveau, et l'utiliser ad vitam aeternam :)

Share this post


Link to post
Share on other sites
Posted (edited)

J'ai aussi des soucis de halos plus ou moins colorés, plus ou moins marqués en sortie de Siril. Ces soucis sont bien plus présents lorsque j'utilise mon newton que ma lunette. Je les ai toujours assimilés à un problème de gestion d'un vignettage assez marqué de mon tube avec son correcteur de wynne.

 

Thierry, une chose m'interpelle, probablement du fait d'une mauvaise compréhension du processus.
Les offsets servent à supprimer le bruit de lecture de l'apn. Sur un a7s, on conseille d'imager à 1600 ou 3200 iso car c'est à ces niveaux que le bruit de lecture est le plus bas tout en conservant une dynamique acceptable. Dans ce cas, pourquoi faire les offsets à bas iso ?

Pour les flats, je les ai toujours fait à 100 ou 200 iso car, pour moi, ils sont supposés corriger des défauts sur le chemin optique, je ne me suis jamais posé les questions en terme de dynamique. Cependant, cette modification de dynamique entre 100 et 3200 iso ne peut elle pas expliquer des halos dus à "un dégradé" du vignettage plus lissé sur les flats que sur les brutes ?

Edited by mbnb24

Share this post


Link to post
Share on other sites
Le 21/03/2019 à 22:31, Thierry Legault a dit :

mais il n'y a pas d'image d'offset cachée quelque part dans le fichier raw

 

@Thierry Legault: si, si, presque ! en tous cas pour les raw de Canon, l'image contient aussi les "blacks pixels" du bord de l'image, à partir duquel on peut évaluer l'offset et le bruit de lecture. Il y a quelques dizaines de colonnes/lignes tout autour, dont les pixels ne sont pas exposés à la lumière.

Par exemple, pour un Canon 7D2, le capteur fait 5568 x 3708 pixels pour une image de 5472 x 3648.

 

Sylvain

Share this post


Link to post
Share on other sites

Au fait, par rapport au problème initial de halo dans la première image du post... ça me fait bien penser à ce que j'ai eu une fois avec un problème d'humidité dans la chambre CCD -> buée qui apparait sur le capteur dans les coins lors du refroidissement. Et comme ça n'est pas stable (ou peut même être temporaire), la limite buée / pas buée apparait typiquement au prétraitement comme une frange blanc/noir plus ou moins circulaire. Il ne me semble pas que ça ait été évoqué dans le post, ça peut toujours faire un truc de plus à vérifier.

Share this post


Link to post
Share on other sites

sur un apn, il n'y a pas ce type de buee, le capteur etant plus chaud

  • Like 2

Share this post


Link to post
Share on other sites
Il y a 5 heures, mbnb24 a dit :

Les offsets servent à supprimer le bruit de lecture de l'apn.

 

absolument pas. Je ne sais pas où tu as lu ça, mais c'est complètement faux. L'offset sert à retirer le signal d'offset. Le bruit de lecture, comme tout vrai bruit qui se respecte,  est de nature aléatoire et variable d'une image à l'autre, donc il ne se retire pas.

 

il y a une heure, S.Chapeland a dit :

si, si, presque ! en tous cas pour les raw de Canon, l'image contient aussi les "blacks pixels" du bord de l'image, à partir duquel on peut évaluer l'offset et le bruit de lecture.

 

il y a plus simple : le niveau d'offset est inscrit dans les données exif d'un fichier raw, sur un APN c'est une constante qui ne varie pas. Quant au bruit de lecture, les logiciels type DPP, Camera Raw, Lightroom et compagnie n'en ont que faire, de toute façon.

 

:)

  • Like 1

Share this post


Link to post
Share on other sites

 

Il y a 1 heure, mbnb24 a dit :

sur un apn, il n'y a pas ce type de buee,

bien vu :D je n'avais même pas vu qu'on parlait d'une image d'APN au départ... je me demandais aussi pourquoi on parlait tant d'ISO !

  • Haha 1

Share this post


Link to post
Share on other sites

Bonjour à tous,

 

Je me permets de m'insérer dans cette conversation car j'ai le même phénomène constaté sur Siril v0.9.12 suite à une session photos la semaine dernière.

 

Voici ce que je soumettais à certains :

 

5ea2c25d0e938_CourstraitementSiril.jpg.ff5ebb4376e72ba0e3bbbd2207e0bd0f.jpg

 

Pour info, les photos, lights, darks, offset, et flats ont été prises avec un APN non défiltré, un Nikon D7000.

 

Sur les flats je ne note pas spécialement la présence de ce cercle (ici réduit et ramené à un fichier JPEG) :

 

5ea464f9ef9ee_DSC_9803Flat.thumb.jpg.c385b949e96e75c7f3e5badf1ca52b5f.jpg

 

J'ai posé à 1 000 ISO.

 

5ea4625a38082_HistogrammeD7000flat.jpg.7f6fbfdd30dbf60c46e13657b9e6e3d1.jpg

 

Pour les flats, j'ai utilisé une boite à flats Lacerta achetée en début d’année.

 

J'ai regardé l'histo, et pour le ramener dans les 3/4 j'ai remonté la vitesse de 20 secondes pour mes lights à 1/1250eme pour les flats pour garder la même sensibilité de tous mes clichés.

 

Je n'ai pas lu l'intégralité de ce fil de discussion, mais une réponse à t'elle été apportée au problème ?

 

Je tiens les fichiers d'origine à disposition si cela peut servir.

 

Philippe

Share this post


Link to post
Share on other sites

Salut

Je me rends compte que je n'avais pas donné de nouvelles.... 

 

J'ai résolu mon problème en ayant invvestit dans un écran à flat Geoptik avec potentiomètre.

Mes flats sont nickels, et je les fais toujours à même Iso que less images. 😁

Yoann 

 

Share this post


Link to post
Share on other sites
Il y a 10 heures, Yoann DEGOT LONGHI a dit :

J'ai résolu mon problème en ayant invvestit dans un écran à flat Geoptik avec potentiomètre.

Mes flats sont nickels, et je les fais toujours à même Iso que less images. 😁

Yoann 

 

Bonjour,

 

Ce ne "serait" qu'une question de puissance à ajuster !??

Il faudrait systématiquement passer par un potentiomètre ?

 

Pour les ISO, je le savais, donc je ne me suis pas posé de questions et j'ai appliqué les recommandations dès le début.

 

Philippe

Share this post


Link to post
Share on other sites
Le 25/04/2020 à 18:28, Phil49 a dit :

Je n'ai pas lu l'intégralité de ce fil de discussion, mais une réponse à t'elle été apportée au problème ?

 

Je ne pense pas que le flat soit à l'origine de ce problème. En tirant les curseurs ton flat ne présente pas cette structure :

image.png.11e9b1f73da9a758a138437fdf9f66d7.png

 

Ce problème doit venir d'un reflet sur tes lights, peut être un lampadaire ou un reflet interne dans l'APN...

Share this post


Link to post
Share on other sites

 

Il y a 13 heures, Fred_76 a dit :

Ce problème doit venir d'un reflet sur tes lights, peut être un lampadaire ou un reflet interne dans l'APN...

 

Bonjour,

 

Je me réponds à moi-même, en fait, il s'agissait probablement d'un artefact, j'entends plutôt par là, le résultat d'un traitement dans Siril via les scripts disponibles, qui "aurait" fait apparaître ce halo.

 

Voici le résultat d'un second traitement effectué cette fois-ci à la main :

 

5ea598c359452_GalaxieBodetest3Photoshop.thumb.jpg.66026d8328c746f371477af6ca943e2c.jpg

 

Alors certes, c'est encore bruité, mais compte tenu du peu de photos (60 + 20 DOF), il semblerait que ce soit difficile d'obtenir nettement mieux.

Mais le plus important, c'est de noter que le halo n'est plus là !

 

Pourtant ce sont les mêmes images et le traitement cosmétique est le même, juste une étape en moins avec un script Photoshop, mais le halo apparaissait déjà très tôt dans le process Siril, avant les traitements cosmétiques.

 

Il y a donc dans les scripts dispos une étape qui a mal été digérée, je ne sais pas laquelle, j'ai posé une question sur le forum d'en face aux développeurs de Siril, mais pas encore de réponse...

 

Quoi qu'il en  soit, je pense maintenant passer par un traitement manuel avec Siril, mais il me reste encore à comprendre toutes les étapes et choix sur certaines valeurs surtout...

 

Et l'autre point positif, les flats ne "seraient" pas responsables, du moins jusqu'à plus ample informé...

 

Voilà si cela peut aider d'autres personnes qui auraient ce genre d'artefact, juste une piste  ! ;-)

 

Philippe

 

 

  • Like 1

Share this post


Link to post
Share on other sites
Le 3/3/2019 à 08:24, PIX-astro a dit :

J'ai encore et toujours des soucis de halos disgracieux sur mes images, certainement dû aux flats.

 

Bonjour

 

Après avoir relu ce long post, il y aurait trois pistes pour résoudre le problème des halos circulaires bizarres sur les photos :

- un problème de Siril puisque le rendu est différent selon qu'on utilise les scripts ou qu'on fait le traitement à la main. Serait-ce le traitement "cosmétique" qui serait la cause ? (solution qui a résolu le pb de Phil)

- changer de boite à flats (solution qui a résolu le pb de Yoann)

- un problème avec le filtre anti PL. Ces filtres interférentiels n'aiment pas du tout les rayons hors axe et génèrent parfois des artéfacts circulaires, mais c'est sur les grands angles :

 

image.png.c29b0e48d89ea3afaaf5df90ef571e6c.png

Edited by Fred_76

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now