Yoann DEGOT LONGHI

Problêmes de flats....avis aux cadors _PAS RESOLU !_

Recommended Posts

Coucou et bonne année !

 

je reviens sur les offsets à 100 ISO dont @Thierry Legault nous a parlé.

 

C'est effectivement une bonne solution pour les appareils photo dont le gain est géré de la même façon pour tous les ISO. Mais les Sony récents ont une chaîne d’amplificateurs à étages qui s’activent à certains paliers d’ISO.

 

Par exemple les A7* ont visiblement un traitement du signal différent de part et d’autre de 2000 ISO.

 

bruit_lecture_a7s.jpg
(source : Th. Legault)

 

Dans ce cas, ne faudrait-il pas faire les offsets au plus bas du créneau dans lequel on fait les brutes, pour que le traitement du signal soit le même que les brutes ? En gros si je shoote à 3200 ISO je ferai les offsets à 2000 ISO, et si je shoote à 1600 ISO ils seront faits à 100 ISO.

 

Ou alors j’ai faux ?

 

a+
 

Fred

Edited by Fred_76

Share this post


Link to post
Share on other sites
Advertising
By registering on Astrosurf,
this type of ad will no longer be displayed.
Planetary Astronomy
Observing, imaging and studying the planets
A comprehensive book about observing, imaging, and studying planets. It has been written by seven authors, all being skillful amateur observers in their respective domains.
More information on www.planetary-astronomy.com

La seule chose qui compte pour la correction de flat, c'est que la réponse du capteur soit linéaire (aussi bien pour le flat que pour les brutes), et elle l'est quel que soit l'iso, et heureusement d'ailleurs !

 

Après, je ne comprends pas ce que tu entends par "traitement du signal" O.o

 

Edit : il y a une manip simple à faire. Prendre un flat à 200 iso, un flat à 2000 iso, et corriger l'un par l'autre (et réciproquement). Après tout, un flat est une image comme une autre. Si le résultat est bien uniforme en serrant les seuils, c'est que ça marche.

Comme j'avais quelques minutes, c'est ce que je viens de faire, et qui l'eût cru, les résultats de correction d'un flat par l'autre sont franchement uniformes, étrange non ? xD

 

 

Edited by Thierry Legault

Share this post


Link to post
Share on other sites

Je découvre ce fil, ma foi intéressant.

Pour ce qui est des flats j'ai toujours fais avec les isos/gain le plus bas, on cherche à corriger des problèmes optiques et pas directement liés au capteur.

 

Par contre la partie sur les offsets m'intrigue. J'ai lu un peu partout qu'avec les CMOS il n'y avait plus lieux d'en faire, voir que ça pouvait être contre productif avec certaines caméras dont les offsets sont mouvant d'une capture à l'autre. Personnellement je n'en ai jamais fait avec ma 183M et ça ne semble pas être un problème.

Le 21/04/2020 à 09:35, Thierry Legault a dit :

Pour l'offset, s'il est bien plat et sans bandes (comme habituellement sur les APN), tu peux en faire un seul, mesurer son niveau moyen, fabriquer une image synthétique à ce niveau, et l'utiliser ad vitam aeternam

 

Donc tu suggères de retirer une image fixe où tous les pixels ont la même valeur, je ne vois pas bien à quoi ça peut servir. Ca revient juste baisse juste la valeur des pixels des brutes d'un pouillième sur tout le champ, c'est quoi l'intérêt d'une telle manip ?

 

 

Share this post


Link to post
Share on other sites
il y a 8 minutes, Tromat2 a dit :

Donc tu suggères de retirer une image fixe où tous les pixels ont la même valeur, je ne vois pas bien à quoi ça peut servir. Ca revient juste baisse juste la valeur des pixels des brutes d'un pouillième sur tout le champ, c'est quoi l'intérêt d'une telle manip ?

 

Quand tu fais un flat ou un dark, il y a le signal que tu cherche à avoir + l'offset. Faire un offset, permet de nettoyer ses images de calibration, afin de n'avoir que le signal du dark dans le master dark, et que le signal du flat dans le master flat. Si tu ne fais pas cela, le pré-traitement ne peut pas se faire correctement.

Edited by Patrick Sogorb

Share this post


Link to post
Share on other sites
il y a une heure, Thierry Legault a dit :

Après, je ne comprends pas ce que tu entends par "traitement du signal"

 

Je parlais de la gestion interne du système Sony qui fait qu'une image prise en dessous de 2000 ISO, en dehors du simple gain, ne suit pas le même traitement que la même image prise au dessus de 2000 ISO. Sony met en œuvre un système d'amplification à plusieurs étages, étages qui ne s'activent pas tous en fonction des ISO.

 

D'où ma question qui ne traitait que des offsets, pas des flats...

Share this post


Link to post
Share on other sites

hé bien on fait la même manip, un offset à 200, un offset à 2000, on soustrait l'un de l'autre et s'il ne reste que du bruit autour de zéro, alors c'est que ça marche.

Et quand on sait ce qu'il y a dans un offset et à quoi ça sert, alors on comprend pourquoi ça marche xD

  • Like 1

Share this post


Link to post
Share on other sites
Il y a 13 heures, Patrick Sogorb a dit :

Quand tu fais un flat ou un dark, il y a le signal que tu cherche à avoir + l'offset. Faire un offset, permet de nettoyer ses images de calibration, afin de n'avoir que le signal du dark dans le master dark, et que le signal du flat dans le master flat. Si tu ne fais pas cela, le pré-traitement ne peut pas se faire correctement.

 

ou, dit autrement :

 

le résultat de

 

b / f

 

ne sera jamais équivalent à

 

(b-d) / (f-o)

 

Seul le second calcul est correct :)

  • Like 1

Share this post


Link to post
Share on other sites
Le 22/01/2021 à 08:50, Thierry Legault a dit :

ou, dit autrement :

 

le résultat de

 

b / f

 

ne sera jamais équivalent à

 

(b-d) / (f-o)

 

Seul le second calcul est correct 

Ah, vu comme ça... En retirant le dark des brutes on retire aussi le signal d'offet et donc il faut le retirer des flats avant division.

Après ça c'est la théorie, reste à voir ce que ça donne en pratique, je fais toujours (b-d) / f et mes images calibrées sont propres.

Share this post


Link to post
Share on other sites
Il y a 1 heure, Tromat2 a dit :

je fais toujours (b-d) / f et mes images calibrées sont propres.

 

Apparemment propres, à l’œil... Mais n'essaye pas de faire une mesure photométrique, tu risque d'avoir des magnitudes fantaisistes.

  • Like 1

Share this post


Link to post
Share on other sites
Il y a 1 heure, Tromat2 a dit :

Après ça c'est la théorie, reste à voir ce que ça donne en pratique, je fais toujours (b-d) / f et mes images calibrées sont propres.

 

Ca n'est pas une question de théorie : tes flats passent probablement parce que le niveau d'offset est très inférieur au niveau de flat, mais essaye avec un APN (genre 7S) avec un offset à 512, et un niveau de flat par exemple dans les 2000, et là hum hum...:S

  • Like 1

Share this post


Link to post
Share on other sites
il y a 54 minutes, Thierry Legault a dit :

Ca n'est pas une question de théorie : tes flats passent probablement parce que le niveau d'offset est très inférieur au niveau de flat, mais essaye avec un APN (genre 7S) avec un offset à 512, et un niveau de flat par exemple dans les 2000, et là hum hum...

Ben je dois être neuneu mais j'ai fais le test en ajoutant une valeur arbitraire à mon master flat qui l'amène juste sous le seuil de saturation, et quand je l'utilise pour calibrer une brute ça ne change strictement rien entre la version calibrée avec le masterflat d'origine et la version avec le masterflat customisé. Tu dis que la réponse du flat doit être linéaire hors en ajoutant une valeur synthétique, qu'elle soit calculée ou farfelue le flat reste bien linéaire, non ?

 

il y a une heure, Patrick Sogorb a dit :

Mais n'essaye pas de faire une mesure photométrique, tu risque d'avoir des magnitudes fantaisistes.

Surement, même si je n'ai pas la prétention de faire de la science avec mes images. Ceci dit quand j'utilise la photométrie pour calibrer les couleurs le résultat me semble honnête.

 

Après j'essaie juste de comprendre hein :)

 

Share this post


Link to post
Share on other sites
Il y a 3 heures, Tromat2 a dit :

Tu dis que la réponse du flat doit être linéaire hors en ajoutant une valeur synthétique, qu'elle soit calculée ou farfelue le flat reste bien linéaire, non ?

 

heu, linéaire ici ça veut dire proportionnel à la quantité de lumière reçue, donc niveau=0 pour lumière=0, ce qui n'est évidemment plus vrai quand le signal d'offset y est encore présent, ni quand on ajoute ou retranche une constante arbitraire (sauf si la constante retranchée d'un flat brut est justement la valeur moyenne de l'offset). Ca ne peut passer que si la dite constante est négligeable devant le niveau du flat, ou si le flat est très uniforme (capteur petit avec instrument présentant peu de vignetage, et pas de poussières marquées). Bon, à la limite si le flat est vraiment plat et le capteur bien propre, il ne sert plus à rien :)

 

PS : mets un capteur 24x36 ou même APS-C sur ta lunette à la place de ta 183, et refais ta manip de constante arbitraire, juste pour voir xD

 

 

Edited by Thierry Legault

Share this post


Link to post
Share on other sites
il y a 51 minutes, Thierry Legault a dit :

PS : mets un capteur 24x36 ou même APS-C sur ta lunette à la place de ta 183, et refais ta manip de constante arbitraire, juste pour voir xD

 

Thierry, pendant qu'on te tient :)

 

Plusieurs questions ont été posées au sujet des flats et bias, ici ou là, et j'aimerais ton avis.

 

Question 1.

Depuis quelques temps je propose de faire non pas des bias, mais des darks de flats, car beaucoup d'écrans à flat basés sur le principe de la feuille électroluminescente au phosphore (genre les Gerd Neuman) provoquent un scintillement énorme dès qu'ils ne sont pas à 100%

Par conséquent pour lisser la trame induite par le scintillement de l'écran, je fais des poses de 2 ou 3s pour mes flats.

C'est pour cette raison que j'ai changé les scripts de pré-traitement de SiriL en remplaçant le (image_flat) - bias (image_bias) par (image_flat) - dark (image_bias).

Sur des temps de pose très courts, la commande -dark revient au même que la commande -bias, est-ce qu'on est d'accord ?

Sur des temps de pose longs (quelques secondes) ça permet de soustraire le dark de flat.

Est-ce que ça te paraît correct ?

 

Question 2.

Un astram sur le forum d'en face est soumis à un problème insoluble.

Il récupère ceci sur ses images de flats :

 

Flat_500ms_Bin1_gain100_20210119-000334_

 

que le flat soit fait à 1/100s comme à 3 secondes de pose, la trame visible ne change pas.

Est-ce que ça pourrait être la caméra qui provoque cette trame (ASI2600MC) ?

Sur la mienne je ne récupère pas cette trame :

 

2021-01-20T12_24_52.thumb.png.6bed4ea95f

 

Merci d'avance pour tes éclaircissemets :)

Share this post


Link to post
Share on other sites
il y a 3 minutes, Colmic a dit :

Sur des temps de pose très courts, la commande -dark revient au même que la commande -bias, est-ce qu'on est d'accord ?

Sur des temps de pose longs (quelques secondes) ça permet de soustraire le dark de flat.

Est-ce que ça te paraît correct ?

 

oui tout à fait. Ce qui compte, c'est de retirer de la brute et du flat des choses qui ont été prises avec les mêmes temps de pose (et la même température). Donc pour un flat en pose longue ça fait un genre de dark (ou dark-flat comme on l'appelle parfois), qui se résume à un offset en pose courte 

Share this post


Link to post
Share on other sites
il y a 14 minutes, Colmic a dit :

Un astram sur le forum d'en face est soumis à un problème insoluble.

Il récupère ceci sur ses images de flats :

 

déjà, je vois que ton flat est monochrome alors que le sien est en couleurs : la première question que je poserais est : débayerise-t-il correctement ? Une mauvaise debayerisation suivie d'une réduction de taille peut conduire à ce genre de trame. Et la première chose que je regarderais est l'allure de chaque composante couleur (sans debayerisation bien sûr) par un équivalent de split_cfa d'Iris.

 

 

Edited by Thierry Legault

Share this post


Link to post
Share on other sites
il y a 1 minute, Thierry Legault a dit :

déjà, je vois que ton flat est monochrome alors que le sien est en couleurs : la première question que je poserais est : débayerise-t-il correctement ? Une mauvaise debayerisation suivie d'une réduction de taille peut conduire à ce genre de trame.

 

Je me suis aussi posé cette question, on est d'accord qu'on retire les flats (et les darks et bias) aux brutes avant la débayérisation ?

En tout cas sous SiriL, la débayérisation se fait après.

  • Like 1

Share this post


Link to post
Share on other sites

Tiens il m'a filé le FIT de son flat, je l'ai ouvert dans SiriL dans les mêmes conditions que la mienne, et j'ai ça :

 

2021-01-23T17_04_02.thumb.png.e514cfd37425711801b941bb3b1f2550.png

 

Effectivement la trame est très marquée sur la sienne alors que j'ai pas ça du tout sur la mienne...

 

Share this post


Link to post
Share on other sites
Il y a 1 heure, Thierry Legault a dit :

PS : mets un capteur 24x36 ou même APS-C sur ta lunette à la place de ta 183, et refais ta manip de constante arbitraire, juste pour voir 

Ah. Je viens de faire le test mes brutes provenant d'un D700 sur newton 200 f/5 et il faut pousser l'exercice au maximum. Mon masterflat à un niveau max de 0.047 (sur 1 sous pi) et j'ai ajouté 0.95 à l'ensemble. Et effectivement la correction n'est plus optimale, les coins sont trop éclaircis, l'image reste quand même bien lisible.

 

image.png.1775ef3371c37c68aa00bd030124cc8e.png

Share this post


Link to post
Share on other sites

J'ai mis en ligne un article qui je pense résume bien toutes ces pages. Voir ici :

 

 

  • Love 1

Share this post


Link to post
Share on other sites
Le 23/01/2021 à 18:06, Colmic a dit :

Effectivement la trame est très marquée sur la sienne alors que j'ai pas ça du tout sur la mienne...

Bonjour à tous

C'est moi l'auteur de ce flat mystérieux... Merci Colmic d'avoir relayé mon problème ici.

 

Le 23/01/2021 à 17:41, Thierry Legault a dit :

déjà, je vois que ton flat est monochrome alors que le sien est en couleurs : la première question que je poserais est : débayerise-t-il correctement ? Une mauvaise debayerisation suivie d'une réduction de taille peut conduire à ce genre de trame. Et la première chose que je regarderais est l'allure de chaque composante couleur (sans debayerisation bien sûr) par un équivalent de split_cfa d'Iris.

En fait, Thierry, je suis maintenant presque convaincu que les trames que j'observe sont dues au fonctionnement de l'ASI2600MC. J'utilise un écran à flat dimmable Lacerta 180mm (https://www.pierro-astro.com/materiel-astronomique/ecrans-a-flat/ecrans-flatfieldbox-lacerta_detail). Mon écran est alimenté par l'AsiAir Pro qui permet de faire varier sa luminosité par PWM.

 

J'explique:

. PWM à 100% (donc a priori pas de PWM - la tension est continue) = pas de trame quelque soit le réglage (gain, expo)

. PWM < 100% (donc modulation de la tension provoquant un scintillement perceptible à l’œil) = présence d'une trame quelque soit le réglage (gain,expo)

 

En fonction du réglage de la caméra, les bandes sombres sur le flat apparaissent plus ou moins larges et disparaissent sans PWM.

Pour un même réglage de la caméra, la position des bandes ne sont pas au même endroit d'un flat à l'autre et elles sont de la même largeur sur chaque flat..

 

La solution pour moi a été d'alimenter sans PWM. J'ai de très beau flat sans trame avec le gain au plus bas (0) et une expo de 50ms.

 

Je m’adresse à la communauté astram pour faire part de mon expérience (bon, au départ, vu ce que j'avais lu sur les forums, je n'avais même pas essayé de faire mes flats à un gain et une expo si faible car je pensais que ça ne pouvait pas marcher et qu'il fallait que je les fasse au même gain que les brutes) et aussi pour voir si quelqu’un par hasard n'aurait pas une compréhension plus fine de ce phénomène qui n'est pour le coup pas du tout intuitif: pourquoi j'obtiens ces trames même avec des expos de plusieurs secondes? Bon désolé, j’adore comprendre ce qui se passe... Mais quand même content d'avoir trouve un réglage qui me permette de faire de beau flat avec mon matos!

 

Share this post


Link to post
Share on other sites

Salut 

J'avais essayé de bidouiller une boîte à flats à partir d'un panneau led à pas cher, mais j'obtenais systématiquement des bandes sur mes flats. 

J'ai investi dans un Geoptik Flat Field generator avec variateur de lumière, et depuis mes flats sont nickels. 

C'est celui là :

https://trevincaskies.com/product/geoptik-210mm-flat-field-generator/

Cher, mais c'est la top qualité. 

Share this post


Link to post
Share on other sites
il y a une heure, Yoann DEGOT LONGHI a dit :

J'avais essayé de bidouiller une boîte à flats à partir d'un panneau led à pas cher,

Je vais tenter l'expérience ...comme j'ai dit dans un autre post , pour un peu plus de 40 e je ne me mouille pas trop...et au pire cela éclairera mon établi :)

 

Ph

Share this post


Link to post
Share on other sites
Le 29/01/2021 à 17:03, toyof a dit :

La solution pour moi a été d'alimenter sans PWM. J'ai de très beau flat sans trame avec le gain au plus bas (0) et une expo de 50ms.

Bon bah, pas si simple que ça... Les mystères de l'électricité... A mon grand étonnement, quand j'alimente ma boite à flat avec ma batterie (via l'asiair pro), ça ne marche plus et j'ai des trames d'une nouvelle nature. Alors que si j'alimente ma boite à flat  par un transfo 12V, mes flats sont cleans... Pénible quand même... Ça veut dire que je ne peux probablement pas faire mes flats en nomade  (je ne me souviens plus si j'ai testé avec la batterie sans passer par l'asiair pro)... AArrgghhh!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now