Sign in to follow this  
AlSvartr

Problème de calage en fréquence avec ALPY et son module de calib

Recommended Posts

Posted (edited)

Salut,

 

J'ai un peu de temps pour prendre en main le module de calib Ar-Ne de l'Alpy 600, et je me heurte à un soucis de calage en fréquence dans ISIS. Je donne la coordonnée du pixel de la raie à 5852, le tilt et le smile sont correctement corrigés, ensuite je trouve ceci lors de la calib:

 

Etalonnage spectral
--------------------------------------------------------------------------
Dispersion primaire :
Coefficient a4 : -2.551835E-13
Coefficient a3 : 6.834014E-09
Coefficient a2 : -6.286833E-05
Coefficient a1 : 0.51488
Coefficient a0 : -933.162
--------------------------------------------------------------------------
RMS : 0.120257 (en pixels)
--------------------------------------------------------------------------
Ecart d'ajustement en longueur d'onde sur les points primaires
point #1  Lambda = 3770.630  px = 429.196  dx = -0.087
point #2  Lambda = 3797.300  px = 436.593  dx = 0.203
point #3  Lambda = 3835.390  px = 447.140  dx = -0.103
point #4  Lambda = 3889.050  px = 461.964  dx = -0.018
point #5  Lambda = 3970.080  px = 484.283  dx = 0.056
point #6  Lambda = 4101.750  px = 520.397  dx = -0.065
point #7  Lambda = 4340.480  px = 585.497  dx = -0.022
point #8  Lambda = 4861.340  px = 726.703  dx = 0.052
point #9  Lambda = 6562.850  px = 1196.468  dx = -0.092
point #10  Lambda = 6869.000  px = 1284.015  dx = 0.088
point #11  Lambda = 7605.000  px = 1498.731  dx = -0.012
--------------------------------------------------------------------------
Equation de dispersion inverse
Coefficient a4 : 2.886431E-10
Coefficient a3 : -1.251927E-06
Coefficient a2 : 1.871447E-03
Coefficient a1 : 2.45527
Coefficient a0 : 2117.639
--------------------------------------------------------------------------
RMS : 19.196982 (en angstroms)
--------------------------------------------------------------------------
Ecart d'ajustement en longueur d'onde
point #1  x = 573.674  lambda = 3936.965  dlambda = 9.135
point #2  x = 639.736  lambda = 4174.844  dlambda = -16.254
point #3  x = 738.843  lambda = 4534.381  dlambda = -23.651
point #4  x = 738.818  lambda = 4534.290  dlambda = 10.760
point #5  x = 769.217  lambda = 4644.853  dlambda = 13.047
point #6  x = 798.824  lambda = 4752.547  dlambda = 12.323
point #7  x = 857.016  lambda = 4964.054  dlambda = 1.026
point #8  x = 977.531  lambda = 5400.181  dlambda = 0.379
point #9  x = 1110.822  lambda = 5877.737  dlambda = -25.247
point #10  x = 1212.289  lambda = 6237.453  dlambda = 29.037
point #11  x = 1291.838  lambda = 6517.491  dlambda = -10.961
point #12  x = 1471.164  lambda = 7146.026  dlambda = 1.014
point #13  x = 1538.980  lambda = 7384.587  dlambda = -0.607
--------------------------------------------------------------------------
Coefficient a4 : 2.886431E-10
Coefficient a3 : -1.251927E-06
Coefficient a2 : 1.871447E-03
Coefficient a1 : 2.45527
Coefficient a0 : 2117.639
--------------------------------------------------------------------------
RMS : 19.196982
--------------------------------------------------------------------------

 

Le premier calage est très bon, avec un RMS stratosphérique de 0.12A, mais lors de l'apairage en wav on passe à un RMS 19A. Je pense louper un détail (c'est même certain), mais lequel ? :-) J'ai testé plusieurs  tailles de pixels (c'est un ST10 donc j'ai varié de 6.5 à 7.2um), mais aucune des valeurs testée ne permet de drastiquement améliorer le RMS. En gros il reste entre 17 et 22.

 

Merci pour votre aide,

 

Simon

 

Edited by AlSvartr
  • Like 1

Share this post


Link to post
Share on other sites
Publicité
En vous inscrivant sur Astrosurf,
ce type d'annonce ne sera plus affiché.
Astronomie solaire : la bible est arrivée !
400 pages, plus de 800 illustrations !
Les commandes sont ouvertes sur www.astronomiesolaire.com

Bonjour

as-tu correctement renseigné la taille du pixel?

quitte à la remesurer avec la formule de Christian

Share this post


Link to post
Share on other sites

C'est peut être un problème d'identification des raies par le soft. Quelques pistes :

Tu as un  bon rapport signal/bruit sur les spectres de la lampe de calibration ? Il faut pauser assez longtemps, faire des essais. Et faire une médiane de plusieurs images pour augmenter le SNR.

Si ce sont des tests sur table il faut faire attention qu'il n'y ai pas de lumière parasite qui rentre qui pourrait perturber l'identification.

Pour jouer sur la taille de pixel c'est à la fraction de pixel, de 6.5 à 7.2 me parait énorme (avec mon atik 314 je joue entre 6.40 et 6.50)(voir http://www.astrosurf.com/buil/isis/guide_alpy/resume_calibration.htm).

La mise au point du spectro est elle bonne ?

Enfin, vérifie si les raies de ta lampes correspondent bien à celles attendues; je te joins une carte, les raies utilisées par Isis sont en bleue.

 

Jean-Philippe

Carte_alpy_isis.jpg

Share this post


Link to post
Share on other sites
Posted (edited)

Merci pour vos retours,

 

Le S/B dans le bleu est clairement moins bon, et ça je pense que c'est en partie du au fait que c'est une ST10xme dont le rendement quantique est maximal dans le rouge autour du Halpha, et bien plus faible dans le bleu. Ce qui est bizarre c'est que le premier calage (premier RMS) est parfait, c'est ensuite que ça part en vrille.

 

Si dessous un print screen du spectre de calib, je pense que la mise au point est correcte mais je peux me tromper. En revanche on voit bien que c'est faiblard dans le bleu.

 

 

 

image.png

 

EDIT: bon en faitm le QE de la ST10xme est encore très bon autour de 400nm, de l'ordre de 50%, donc c'est pas ça. Ou alors est-ce que ça pourrait être la lampe qui manque d'argon? au pire ça coute 2 balle a changer.

 

Edited by AlSvartr

Share this post


Link to post
Share on other sites

Pour calculer la taille des pixels c'est :

3123 / ( x en pixel de Halpha -  x en pixel de Hbeta)

Tu devrais trouver un peu moins que ta taille de pixels.

 

Pour mon Atik414 et ces pixels de 6.45µm je trouve une taille des pixels de 6.256µm

Share this post


Link to post
Share on other sites
Posted (edited)

@apricotBon si je fait la correction par le flat alors je me rapproche un peu de ce que tu montres:

 

image.png.350d4d44bfefd639bc9e3137ae356ba8.png

Edited by AlSvartr

Share this post


Link to post
Share on other sites

Ton problème vient de ton spectre de la lampe de calibration car le premier étalonnage en longueur d'onde dans le process ISIS est réalisé sur les raies de Balmer de l'étoile de référence et ce calage est bon, par contre le 2ème étalonnage vient de la lampe Ne/ar seule et là plusieurs paramètres peuvent en être la cause :

- Est ce que ton spectre de la lampe Ar/Ne est suffisamment exposé sans saturer ? Vérifier le nombre d'ADU sur la raie la plus lumineuse

- Est ce que tu as fait ce spectre juste après la cible sans bouger le télescope (problème éventuelles de flexions mécaniques si le spectro bouge pendant un goto par exemple).

- Attention, la raie à identifier dans le cas d'un étalonnage en longueur d'onde mixe (raies de Balmer et rais de la lampe) est à faire sur celle à 5944,83 Å (la 3ème à droite de la raie la plus lumineuse celle à 5852 Å)

Share this post


Link to post
Share on other sites

@OlivierG Je vais préciser ma démarche :-) Je fais une expérience de table, j'ai simplement acquis un spectre en visant à travers la fenêtre, puis des spectres de la lampe de calib (flat et ArNe). Donc ici point d'étoile de référence pour l'estimation de la réponse instrumentale. J'ai suivi exactement ce qui est fait en point 2 sur http://www.astrosurf.com/buil/isis/guide_alpy/resume_calibration.htm , i.e. faire un calage en fréquence uniquement à partir de la lampe.  

Share this post


Link to post
Share on other sites
Posted (edited)

 

il y a 33 minutes, AlSvartr a dit :

 

@OlivierG Je vais préciser ma démarche :-) Je fais une expérience de table, j'ai simplement acquis un spectre en visant à travers la fenêtre, puis des spectres de la lampe de calib (flat et ArNe). Donc ici point d'étoile de référence pour l'estimation de la réponse instrumentale.

 

Alors là je pense qu'il y a un problème de la manip : quel est l'objet que tu as visé à travers ta fenêtre ?

Est ce une étoile de type A ou B ? Est ce le spectre Solaire ? Dans ce dernier cas, la méthode utilisée pour la calibration ne peut fonctionner car mélangeant les raies de Balmer d'une étoile chaude avec la lampe Ne/Ar. La méthode mixe ne fonctionne qu'avec des étoiles chaude de type A ou B ne comportant que les raies de Balmer. Le spectre a trop de raies pour que le soft puisse étalonner correctement le spectre. 

Si tu fait le spectre solaire, alors il faut utiliser la méthode n'utilisant que la lampe spectrale pour l'étalonnage en longueur d'onde.

Edited by OlivierG

Share this post


Link to post
Share on other sites

C’est un simple spectre solaire réfléchi sur les montagnes (je suis à l’obs de st veran), il fait ignoblissime donc on s’occupe comme on peut 😀

mais ok j’ai ma réponse alors, le spectre de la lampe de calib a lui seul est trop compliqué pour le calage. Merci!

Share this post


Link to post
Share on other sites
Il y a 1 heure, AlSvartr a dit :

mais ok j’ai ma réponse alors, le spectre de la lampe de calib a lui seul est trop compliqué pour le calage. Merci!

Non, c'est le contraire, c'est le spectre Solaire qui comporte trop de raies pour que la calibration se fasse dans de bonnes conditions.

Mais tu peut très bien calibrer le spectre Solaire avec ISIS en ne prenant en compte que les raies de la lampe de calibration Ar/Ne.

 

Share this post


Link to post
Share on other sites
il y a 13 minutes, OlivierG a dit :

Mais tu peut très bien calibrer le spectre Solaire avec ISIS en ne prenant en compte que les raies de la lampe de calibration Ar/Ne

 

Oui c’est exactement ce que je suis en train de faire. Comme tu le vois sur le log le premier RMS est excellent (et c’est déduit de la lampe de calib) c’est après que ça pose soucis. Donc peut-être un problème de SNR.

Share this post


Link to post
Share on other sites

Je pense qu'il y a confusion, le 1er RMS a été calculé sur les raies de Balmer supposé du Soleil et non pas sur la lampe de calibration (c'est pas des longueurs d'onde de la lampe Ar/ne). Le RMS est bon car le soft mélange les raies avec d'autres car trop nombreuses sur un spectre solaire (pas que les raies de Balmer qui sont utilisés par ISIS pour faire la calibration).

 

Les raies de Balmer sont celles figurant dans ton 1er tableau :


point #1  Lambda = 3770.630  px = 429.196  dx = -0.087
point #2  Lambda = 3797.300  px = 436.593  dx = 0.203
point #3  Lambda = 3835.390  px = 447.140  dx = -0.103
point #4  Lambda = 3889.050  px = 461.964  dx = -0.018
point #5  Lambda = 3970.080  px = 484.283  dx = 0.056
point #6  Lambda = 4101.750  px = 520.397  dx = -0.065
point #7  Lambda = 4340.480  px = 585.497  dx = -0.022
point #8  Lambda = 4861.340  px = 726.703  dx = 0.052
point #9  Lambda = 6562.850  px = 1196.468  dx = -0.092
 

On a par ordre chronologique inverse : H alpha 6562, H Beta 4861, H Gamma 4340, H delta 4101, H eps 3970, etc...

 

Il faut donc n'utiliser que les raies de la lampe Ar/ne pour la calibration (mode prédéfini en sélectionnant le module de calibration ALPY) ou encore en utilisant un fichier .lst ou l'on indique à ISIS les raies que l'on souhaite prendre en compte pour la calibration.

 

Après si la météo le permet, le mieux serait de faire par exemple un spectre de Vega (A0V) ne necéssitant que très peut de temps de pose (j'espère que tu trouveras une fenêtre météo pour cela d'ici la fin de cette semaine à St Véran ?)

 

 

Share this post


Link to post
Share on other sites

C'est ça qui est bizarre, c'est que je n'utilise à aucun moment le spectre solaire (pour ce test, j'utilise le spectre de la lampe de calib comme signal et pour caler), donc je vois pas trop pourquoi il cherche à identifier les raies de Balmer.

 

il y a 6 minutes, OlivierG a dit :

Il faut donc n'utiliser que les raies de la lampe Ar/ne pour la calibration (mode prédéfini en sélectionnant le module de calibration ALPY)

 

C'est bien le cas.

 

il y a 6 minutes, OlivierG a dit :

Après si la météo le permet, le mieux serait de faire par exemple un spectre de Vega (A0V) ne necéssitant que très peut de temps de pose (j'espère que tu trouveras une fenêtre météo pour cela d'ici la fin de cette semaine à St Véran ?)

 

C'est malheureusement peu probable à part peut-être fin de semaine.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this