assurtourix

wifi raspberry ekos/indi

Recommended Posts

Bonjour,

 

rencontrez vous des problèmes de communication entre le raspberry 3 et votre pc a distance ?

A environ 7 metres + une fenetre entre les 2 la communication est tres instable du coup c'est ingérable.

J'ai mis le raspberry en hotspot wifi.

 

Merci pour vos retours.

Share this post


Link to post
Share on other sites
Publicité
En vous inscrivant sur Astrosurf,
ce type d'annonce ne sera plus affiché.
Photographier la Lune
Guide complet pour la photographier de la Lune.
Information et commande sur www.photographierlalune.com

Bonjour,

Oui. Pareil chez moi en région parisienne.

Sauf dans les Pyrénées dans un village.

Maintenant je passe par un câble ethernet.

Share this post


Link to post
Share on other sites

mon pi 3+ est à l'étage, et à l'opposé (horizontalement) de ma box qui est au rez-de chaussée. Il n'y a pas 7m, mais j'ai une dalle à traverser et un mur porteur. Je me connecte depuis un autre PC relié en filaire en SSH + Serveur X sans problème pour ma part.

 

Marc

 

Share this post


Link to post
Share on other sites

patry dans cette configuration ton pi est en mode "client" de ton réseau interne. Moi je l'ai mis en hotspot wifi, je pense que l'antenne est nul en emission....

Pour la reception , ca doit mieux le faire.

Share this post


Link to post
Share on other sites
Il y a 1 heure, jjc a dit :

Maintenant je passe par un câble ethernet.

c'est exactement ce que je voulais éviter mais je ne vois pas trop comment..... je n'ai pas de wifi sur un des lieux d'observation et je voudrais bien rester au chaud

 

Share this post


Link to post
Share on other sites

Non "pas que" car mon PC sert aussi à l'affichage ('X' window) dont le flux de données vient du PI3 !

Le display se fait sur mon terminal (coté PC, relié en filaire) et le PI gère tout cela très bien.

Du coup il y a certainement plus de flux sortant que les quelques commandes entrantes (clavier, souris). J'envoie finalement très peu de données sur le PI car je n'ai réussi à monter un dossier de mon NAS synology correctement QUE pour l'utilisateur PI, mais les autres comptes, l'accès y est systématiquement interdit (je n'ai toujours pas compris pourquoi).

Du coup j'ai peu de transfert client -> pi (peu de flux "fichier").

 

Rappel de ma config

PC => box -> PI (commandes, clavier, souris)

PI -> box => PC ('X' window, retour des programmes)

avec 

PC <=> box en filaire (gigabit d'un bout à l'autre)

PI <-> box en Wifi

 

Le wifi est partagé avec 1 autre ordinateur, et 2 à 3 téléphones mobiles.
 

Maintenant il faut voir ce que tu utilise comme flux de ton coté. Et combien de clients WIFI sont connectés (bande passante partagée).

 

Marc

 

Share this post


Link to post
Share on other sites

Vois aussi si tu n'as pas des obstacles au wifi que tu peux éviter (éléments métalliques en particulier). Parfois, déplacer d'un petit mètre peut changer beaucoup la donne... Du côté du Raspberry, comme de celui du routeur (par exemple, j'en ai vu un derrière une tele écran plat. Tout l'écran est recouvert de métal conducteur...)

 

Tu peux aussi prendre un petit routeur wifi, brancher ton raspberry pi dessus par ethernet et utiliser le routeur comme client de ton routeur wifi principal.

Si c'est l'aspect nomade qui entre en jeu, j'en avais un qui était autoalimenté (batterie interne Li-Ion). Mon modèle (Emtec) n'est plus commercialisé, mais il existe peut-etre des formules similaires chez les autres.

 

 

Share this post


Link to post
Share on other sites
il y a 8 minutes, Jijil a dit :

is aussi si tu n'as pas des obstacles au wifi que tu peux éviter (éléments métalliques en particulier)

J'avoue que je n'ai rien sauf une baie vitrée. Faut que je regarde s'il n'y a pas un autre truc qui perturbe autour...

Ce qui me dérange c'est que le ping est tres irrégulier dans ses réponses. Ca fait un yoyo de dingue...!!

 

 

Share this post


Link to post
Share on other sites

Attention, peut être que la baie vitrée est traitée "athermique" sur laquelle il y a parfois une mince couche métallique. Sans aller a couper le signal tu peux bien l'atténuer.

 

Il y a des applications sur mobile qui te donne le niveau de signal WiFi. C'est certainement très approximatif mais donnera une indication de la qualité de ton signal.

 

 

Marc

 

Share this post


Link to post
Share on other sites

Bonsoir

 

L'antenne du RPI3 est médiocre. Tu as 2 options a mon avis à tester dans l'ordre :

 

1. Essayer d'optimiser la conf du RPI pour faire avec:

- Changer le canal du WIFI. Une appli type Wifi analyzer sous android te donnera le taux d'occupation des canaux.

 

thumbnail.jpeg.41b2198288a2f9f0f3b68354feee47b9.jpeg

 

Contrairement aux AP Wifi du commerce, le RPI ne va pas chercher tout seul le canal optimal. Il faut le lui donner à la main.

Sur RPI3 Rasbpian ca se change dans le fichier /etc/hostapd/hostapd.conf 

channel=7 --> Remplacer 7 par un canal libre

 

- Essayer de passer en 2.4 GHz (moins rapide mais un peu plus passe muraille)

hw_mode=g --> au lieu de "a" pour le 5  Ghz dans le même fichier

 

2. Si ca ne marche toujours pas, le plus économique est de mettre un dongle WIFI USB avec antenne externe compatible du RPI3

Exemple : MediaTek Ralink RT5370N

La manip pour l'installer : https://thepihut.com/blogs/raspberry-pi-tutorials/how-to-set-up-the-ralink-rt5370-wifi-dongle-on-raspian

 

Bonne soirée

Nicolas

 

 

Edited by NicoF

Share this post


Link to post
Share on other sites
Le 17/09/2019 à 12:40, assurtourix a dit :

Je n'ai rien sauf une baie vitrée.

Sauf que certaines baies vitrées sont traitées dans la masse et provoque une cage de faraday.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now