Recommended Posts

Bonjour,

j'ai quelques spectres acquis récemment avec un SA100 en cours de traitement. Avec l'aide des différents tutos trouvés ici et là, je commence à me familiariser avec Isis. J'ai encore un petit problème concernant les titres sous Gnuplot. J'ai suivi à la lettre le tuto de Christian pour l'installation du soft et notamment celle des fichiers std.gnu. Lorsque j'accède à la page dédiée, tout semble fonctionner correctement, la création du fichier de sortie au format png semble être ok mais en réalité, le fichier n’apparaît nul part sur le disque. Y aurait-il une petite subtilité dont je n'ai pas connaissance ?

Merci

 

Isis.jpg

Share this post


Link to post
Share on other sites
Advertising
By registering on Astrosurf,
this type of ad will no longer be displayed.
Planetary Astronomy
Observing, imaging and studying the planets
A comprehensive book about observing, imaging, and studying planets. It has been written by seven authors, all being skillful amateur observers in their respective domains.
More information on www.planetary-astronomy.com

Il faut installer une ancienne version de gnuplot, la 4.6 de mémoire mais pas la dernière.

 

Attention également à certains caractères qui peuvent ne pas être pris en compte correctement comme "/", ")" ou " ° " par exemple ou qui peut empêcher la génération correcte du fichier png. Il faut éviter également les noms de répertoire avec des espaces.

Le fichier généré en png se retrouve dans le répertoire de travail que l'on a défini dans l'onglet configuration.

Share this post


Link to post
Share on other sites

Je vois cela. J'ai la V 5.2 qui a nécessité que je renomme un sous répertoire (bin en binary)

Merci

Share this post


Link to post
Share on other sites

Cela coince toujours. La seule version téléchargeable sur le site Gnuplot.info est la V5.2. Après désinstallation puis nouvelle installation, Isis ne trouve pas le bon chemin. Le répertoire binary n'existe pas. Seul le répertoire bin existe. Il contient 3 exécutables : gnuplot, wgnuplot et wgnuplot_pipes. Or Isis essaie d'accéder à pgnuplot qui manifestement n'existe pas. J'ai essayé précédemment de renommer le répertoire bin en binary et le fichier gnuplot en pgnuplot. Plus de message d'erreur mais le fichier png n'est pas crée. C'était l'objet de mon premier msg. Pas mieux en retirant le symbole _

 

Isis.jpg

Edited by esoub83

Share this post


Link to post
Share on other sites

Merci beaucoup, la V 6.4 fonctionne parfaitement bien. Je suis en train de chercher la façon de coloriser le spectre. Isis le permet-il ? 

Share this post


Link to post
Share on other sites

Bonjour,

j'ai mis un petit message sur le site d'ARAS !

La version 4.6.6 fonctionne très bien, mais plus la 5.2

Pour la colorisation :

#============================================================
# GnuPlot script : STD2.GNU 
#============================================================
# Parameter 0 : input data file #1
# Parameter 1 : input data file #2
# Parameter 2 : graph title
# Parameter 3 : min X:max x
# Parameter 4 : min y:max y
# Parameter 5 : size x, size y
# Parameter 6 : label #1
# Parameter 7 : label #2
# Parameter 8 : ouput file (PNG format)
#============================================================

# --------------------------------------
# Setting
# --------------------------------------
#palette by Namio MATUDA
lmax = 7800; lmin = 3800
k=lmax-lmin
set cbrange [lmin:lmax]
r(x)=x<4400?-(x-4400)/(4400-3800):x<5100?0:x<5800?(x-5100)/(5800-5100):x<=7800?1:0
g(x)=x<4400?0:x<4900?(x-4400)/(4900-4400):x<5800?1:x<6450?-(x-6450)/(6450-5800):0
b(x)=x<4900?1:x<5100?-(x-5100)/(5100-4900):0
f(x)=x<4200?0.2+0.7*(x-3800)/(4200-3800):x<7200?1:0.2+0.7*(7800-x)/(7800-7200)
set palette functions f(k*gray+lmin)*r(k*gray+lmin),g(k*gray+lmin),f(k*gray+lmin)*b(k*gray+lmin)
set encoding utf8 ## required for Å symbol
set xlabel 'Wavelength (Å)'  ## lambda char = {/Symbol l}
set ylabel "Relative intensity"
set xrange [$3]
set yrange [$4] 
## set yrange [0<*:]  ## no negative y value (required for color boxes)
set grid ytics xtics mxtics  ## grid : comment this line to disable it, or choose in  ytics xtics mytics mxtics
set mxtics  ## minor x tics
set mytics  ## minor y tics 
set tmargin 2
set title '$2' offset 0,-0.5
set style fill transparent solid 0.95 noborder  ## colored boxes style ; 0.6=60% opacity
unset colorbox ## disable color scale
set terminal push

# ------------------------------------
# Plot on the computer screen 
# ------------------------------------
set terminal windows "Arial" 9

## /!\ only 1 enabled plot/replot commands block /!\

## classic blue/red lines chart
#plot "$0" title "$6" with lines linecolor rgb 'blue' , "$1" title "$7" with lines linecolor rgb 'red'

## color-filled + blue/red lines
plot "$0" using 1:2:1 with boxes linecolor palette notitle , "$1" using 1:2:1 with boxes linecolor palette notitle
replot "$0" title "$6" with lines linecolor rgb 'blue', "$1" title "$7" with lines linecolor rgb 'red'

# ------------------------------------
# Plot on a PNG file
# ------------------------------------
## terminal pngcairo instead of png is needed for transparency, unicod, ...
set terminal pngcairo enhanced font "Verdana,9" size $5
set output '$8'
replot

# ------------------------------------
# Finalize
# ------------------------------------
set output
set terminal pop
reset

 

Il suffit de remplacer le code dans std2.gnu

 

Mizar11

  • Like 1

Share this post


Link to post
Share on other sites

Bonjour,

le script fonctionne dans la partie plot double d'Isis. J'ai supprimé une ligne de code qui affichait sur le graphique le nom des fichiers #1 et #2.

(replot "$0" title "$6" with lines linecolor rgb 'blue', "$1" title "$7" with lines linecolor rgb 'red')

La représentation colorée est ainsi plus parlante et plus agréable à l'œil.

Merci beaucoup à vous deux.

 

 

 

Regulus.png

  • Like 1

Share this post


Link to post
Share on other sites

Le rendu n'est pas aussi creusé qu'avec un spectro à fente, mais c'est déjà bien.

 

La version un seul spectre utile pour d'autres utilisateurs...

#============================================================
# GnuPlot script : STD.GNU
#============================================================
# Parameter 0 : input data file
# Parameter 1 : graph title
# Parameter 2 : min x:max x
# Parameter 3 : min y:max y
# Parameter 4 : Size x, Size y
# Parameter 5 : output file (PNG format)
#============================================================

# -------------------------------------
# Setting
# -------------------------------------
#palette by Namio MATUDA
lmax = 7800; lmin = 3800
k=lmax-lmin
set cbrange [lmin:lmax]
r(x)=x<4400?-(x-4400)/(4400-3800):x<5100?0:x<5800?(x-5100)/(5800-5100):x<=7800?1:0
g(x)=x<4400?0:x<4900?(x-4400)/(4900-4400):x<5800?1:x<6450?-(x-6450)/(6450-5800):0
b(x)=x<4900?1:x<5100?-(x-5100)/(5100-4900):0
f(x)=x<4200?0.1+0.7*(x-3800)/(4200-3800):x<7200?1:0.2+0.7*(7800-x)/(7800-7200)
set palette functions f(k*gray+lmin)*r(k*gray+lmin),g(k*gray+lmin),f(k*gray+lmin)*b(k*gray+lmin)
set encoding utf8 ## required for Å symbol
set xlabel "Longueur d'onde(A)"  ## lambda char = {/Symbol l}
set ylabel "Intensite relative"
set label "ISIS: Spectrography Software" at graph 1.01,0 left rotate by 90 
set title '$1' offset 0,-0.5
set tmargin 2  ## top margin
set xrange [$2]
set yrange [$3]
## set yrange [ 0<* : ]  ## no negative y value (required for color boxes)
set grid ytics xtics mxtics  ## grid : comment this line to disable it, or choose in  ytics xtics mytics mxtics
set mxtics  ## minor x tics
set mytics  ## minor y tics 
set style fill transparent solid 0.95 noborder  ## colored boxes style ; 0.6=60% opacity
set key off ## disable keys (legends)
unset colorbox ## disable color scale

set terminal push
set grid

# -------------------------------------
# Plot on the computer screen
# -------------------------------------
set terminal windows "Arial" 9

## /!\ only 1 enabled plot command /!\

## classic black line chart : 
#plot "$0" with line linecolor rgb 'black'

## color-filled chart with black line :
plot "$0" using 1:2:1 with boxes linecolor palette z, "$0" with line linecolor rgb 'black'

## colored line chart :
#plot "$0" using 1:2:1 with line linecolor palette z

# -------------------------------------
# Plot on a PNG file
# -------------------------------------
## terminal pngcairo instead of png is needed for transparency, unicod, ...
# set terminal pngcairo enhanced font "Verdana,9" size $4
set terminal pngcairo enhanced font "Verdana,9" size 1440,900
set output '$5'
replot

# -------------------------------------
# Finalize
# -------------------------------------
set output
set terminal pop
reset

 

Remplacer le code dans le fichier "std.gnu"

 

Mizar11

Share this post


Link to post
Share on other sites

Bonjour,

Je commence à utiliser ISIS (version 5.9.7) avec gnuplot (V4.6.6) avec copie des trois fichiers de script std.gnu, std2.gnu et std2y.gnu dans la racine du répertoire Gnuplot- j'ai aussi essayé avec gnuplot (V4.6.0), ma mon problème est le même:

 J'ai obtenu un spectre de Vega (onglet "4.GO" puis "5.Profil") (j'ai aussi un tracé du spectre dans l'onglet "5.Profil" et en cliquant sur l'icone qui est juste à droite du bouton "DAT" avec représentation des axes X et Y et de la courbe du spectre -tout semble bon jusque là...). Mais lorsque je vais dans l'onglet "6.Gnuplot", en plot libre j'ai bien la création d'un fichier .png avec les axes X et Y mais sans la courbe du spectre (voir copie d'écran jointe) et je n'ai pas de message d'erreur....

Pouvez-vous m'aider ?

Merci par avance.

Gnuplot et ISIS.JPG

Share this post


Link to post
Share on other sites

Quelques pistes :

- Est ce que le répertoire de travail est bien défini dans l'onglet configuration.

- Le nom du répertoire que je vois dans la copie d'écran est trop long et comporte des espaces qui peuvent générer des bugs de ce style. faut faire des truc simple du style "20120914_Alpy"

- le fichier spectral doit être en fit pas en dat

- Ne pas confondre le fichier spectral 2D et le 1D, c'est le 1D qu'il faut utiliser ici

 

Edited by OlivierG

Share this post


Link to post
Share on other sites

Merci Olivier pour ton aide.

J'ai bien défini le répertoire de travail dans l'onglet configuration et j'ai simplifié le nom du répertoire de travail  devenu "nuit20120914_s", mais j'ai encore un tracé "vide" avec seulement les axes X et Y.....Par contre, je ne l'avais pas signalé, la séquence GO me génère seulement un fichier @vega.dat que je suis obligé de convertir en .fit (avec les onglets Outils puis Spectre3) et je lance ensuite le tracé par l'onglet Gnuplot est-ce normal ?

 

PS: comment faire la distinction entre fichier 1D et 2D ( par son nom ou autrement ? - Dans le répertoire de travail, je ne vois qu'un fichier nommé "2D_vega.fit" qui est généré après la séquence GO)

Share this post


Link to post
Share on other sites

Si la courbe s'affiche bien dans l'onglet 5 profil, c'est que le fichier 1D est bien généré.

Après on peut toujours sauvegarder le résultat du profil (5).

Pour cela il suffit de cliquer sur la case "Sauver " à droite du profil, lui donner un nom et cocher la case .fits

 

Ce même nom de fichier est à reproduire dans la fenêtre dédiée à gnuplot pour générer le png.

 

Sinon, est ce que le profil est bien normalisé à 1 au niveau du continuum dans la zone de longueur d'onde définie dans l'onglet  Configuration ?

Je vois par ailleurs que la valeur Y2 =1, ce qui veut dire que le maxi en Y est fixé à 1 alors que sans doute la courbe dépasse cette valeur. 

Il faut vérifier la valeur Y maxi du spectre dans l'onglet 5 profil pour bien renseigner cette valeur.
 

Edited by OlivierG

Share this post


Link to post
Share on other sites

Bonjour,

Je suis aussi surpris par la valeur Y2=1 ;  Et même normalisé à 1, c'est pour une longueur d'onde donnée, donc ça peut dépasser largement.

 

Alors, il est possible de ne rien voir du tout du signal; donc dans l'onglet profil voir quelle est l'intensité maxi et la reporter sur Y2.

 

Si ça peut servir, j'ai installé Gnuplot directement à la racine du disque système; sinon je rencontrai des problèmes.

 

Bonne soirée

Thierry

 

Share this post


Link to post
Share on other sites

Merci Olivier pour tous tes conseils.

Le tracer marche maintenant avec l'onglet 6.Gnuplot:

Je n'avais effectivement pas fait la normalisation (onglet profil): j'ai utilisé les deux valeurs Lambda 1 et 2 figurant dans le champ "région spectrale utilisée pour la mise à l'échelle du profil" de 'onglet Configuration.

De plus, je faisais aussi l'erreur de ne pas sauvegarder le profil dans l'onglet 5.Profil -bouton "Sauver" - ce que j'ai fait (en format FITS) (copie d'écran jointe).

Le tracer ( onglet 6.Gnuplot) a alors fonctionné (copie d'écran jointe). J'ai réajusté la valeur de Y2 avant de lancer le tracer).

VEGA_Sauvegarde_Profil_FITS.JPG

VEGA_GNUPLOT.JPG

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now