Daniel B

Help! QHY5III290M beaucoup trop lente

Recommended Posts

Bonjour tout le monde,

 

Je viens enfin de recevoir ma nouvelle QHY5III-290M, d'installer les drivers (que je viens de télécharger) et là, déception. Que ce soit avec SharpCap ou avec FireCapture 2.6, en plein format je me traîne à 13 images/sec et avec un tout petit ROI genre 500x400 j'arrive tout juste à 30-40 im/s. Ce truc est censé me donner au moins 200 ou 300 im/s, non?

Windows 7, USB3, seul appareil connecté, connexion directe, USBTraffic ne change rien (de 0 à 60), images d'1 milliseconde. J'ai même essayé d'interposer un hub USB3 alimenté, sans changement.

J'ai une ASI224MC qui me débite 200 im/s par le même port USB avec des ROI semblables.

 

Quelqu'un aurait-il eu le même problème et si oui, l'aurait-il résolu?

 

Toute aide serait la bienvenue!

 

Merci,

 

Daniel

 

Share this post


Link to post
Share on other sites
Publicité
En vous inscrivant sur Astrosurf,
ce type d'annonce ne sera plus affiché.
Photographier la Lune
Guide complet pour la photographier de la Lune.
Information et commande sur www.photographierlalune.com

Il faut régler la vitesse du port usb

Usb speed à 0 dans sharpcap dans les réglages à droite

Bonne nuit 

Luc 

 

  • Thanks 1

Share this post


Link to post
Share on other sites

Merci Luc mais ça ne marche pas.

 

Le seul réglage du genre ue je vois s'appelle "USB traffic" (le même que dans FireCapture), et le mettre à 0 augmente un petit peu la vitesse, mais environ de 30 à 40 im/s en 640x480. On est loin du compte...

 

Daniel

 

Share this post


Link to post
Share on other sites
Posted (edited)

Il faut surtout un disque SSD ... ;):) et pis cela dépend du temps de pose ...

 

Edited by Beagle
  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

Rien à voir, puisque ma ASI224 débite plus de 200 images par seconde.

Merci quand même!

 

Daniel

Edited by Daniel B

Share this post


Link to post
Share on other sites
Posted (edited)

elle semble être reconnue en USB2 par le,PC au lieu d'USB3. ça arrive parfois avec les PC un peu anciens, une histoire de compatibilité entre le port, les câbles, les drivers USB3...

Il faut débrancher, rebrancher, essayer d'autre port d'autre câbles, mettre à jour les drivers et désactiver les fonctions d'économie d'énergie du port USB3.

l'ordre de branchement peut jouer aussi : d'abord la camera puis le PC ou inverse.

 

ça m'arrive assez souvent sur un PC ancien avec la 224 en direct. si je vois le débit trop faible, je débranche rebranche et ça repars. usb trafic à 2 en full frame, à 1 voir 0 suivant le ROI.

sharpcap et windows 7 ou 10. mais ca dépend surtout du chipset USB3 indépendant et ses drivers. On n'a plus ce soucis sur les PC récents et usb trafic toujours à 0, plus besoin de ralentir le transfert que ce soit avec la QHY 224 ou la 290.

Pas essayé la 290 sur le vieux PC, faudra que je vérifie...

Un hub usb3 peut aider aussi si il est bien reconnu par le PC en USB3...là aussi on a les mêmes problématiques de câble et compatibilité. Et un câble peu marcher avec un.hub.ou.une caméra mais pas une autre et inversement.

Edited by olivdeso
  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Teste en mettant USB traffic un peu au dessus de 0 voir si ça augmente pas un peu.

Bon courage.

Luc 

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

Bonjour,

pour ma part j'ai le meme probleme avec une Asi174 , une astuce qui marche à tout les coups pour passer de usb2 à 3 .

je lance normalement le PC ,je branche la caméra ( là j'ai  Usb2 et un faible débit).

je fais redémarrer , le PC prend plus de temps pour démarrer (il doit chercher les bons drivers) mais USB3 sur firecapture.

ca me le fait tout le temps sur un PC et trés rarement voir pas du tout sur les autres.

Paul

 

Edited by banjo
  • Thanks 1

Share this post


Link to post
Share on other sites

Bonjour Paul,

 

Merci pour cette suggestion!

Malheureusement, ça ne fonctionne pas non plus. 

Cela dit, c'est bel et bien un problème de reconnaissance de l'USB3.0 qui est derrière tout ça. En effet, quand je connecte ma ZWO ASI224, dans le cadre de FireCapture je lis "USB2.0". Et malheureusement ton truc ne fonctionne pas non plus avec cette caméra. En revanche, le 2.0 pour l'ASI est nettement meilleur que celui pour la QHY, puisqu'avec l'ASI j'atteins allègrement les 200 im/s avec des petites ROI.

Il semble donc bien que je devrai me procurer un nouvel ordi :(

 

Daniel

Share this post


Link to post
Share on other sites

Pour éliminer toute question de stockage tu peux faire des tests avec firecapture.

Quand tu sélectionne, disons une exposition de 10ms, Firecapture affiche (sans même enregistrer le flux), le débit théorique (100 i/s dans ce cas) et le débit réel de la caméra. En pleine résolution si possible tu sera vraisemblablement moins que cela (sans ROI, une 290 ne débite pas 100i/s il me semble).

Si tu est très en dessous, tu a effectivement un couac dans l'interface, vraisemblablement vu en USB2 au lieu d'USB3 (les prises bleues). Change de prise et si cela ne passe toujours pas, tente une réinstallation des drivers ou ... change de PC ?

Si c'est bon et que c'est à l'enregistrement que cela ne suit pas, passe au SSD.

Si c'est toujours pas bon, vire la compression NTFS qui couche assez mal avec les flux des caméras (testé sur un i5 ou un i7 et un SSD, cela ne passe pas non plus alors que tous les bench montrent 500 à 600Mo/s).

Une fois viré l'option, les benchs ne changent pas, mais on a greffé un turbo à Firecapture.

 

 

Marc

 

  • Like 1

Share this post


Link to post
Share on other sites
Il y a 12 heures, patry a dit :

Une fois viré l'option, les benchs ne changent pas, mais on a greffé un turbo à Firecapture.

Bonjour Marc,

comment on vire NTFS sur le Pc

Paul

 

Share this post


Link to post
Share on other sites

Non ce n'est pas le NTFS mais l'option de compression qui va avec ce format.

Tu sélectionne le disque depuis l'explorateur windows (partie gauche de la fenêtre), propriétés. En bas tu a une case "Compresser ce lecteur pour augmenter l'espace disponible" qui doit être décochée. Sinon, la décocher puis valider (attention cela peut être long de reprendre tous les fichiers).

 

Marc

 

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Merci pour ces nouvelles indications Marc.

 

Les cadences matériel/réel sont très différentes, en effet. Cela dit, je *sais* maintenant que quoi que je fasse la caméra est reconnue comme USB 2.0.  De plus, je l'ai testée sur le PC de mon fils (pas mal plus à jour que le mien!), là l'USB3.0 a été reconnu et et en 640x480 la caméra crache du 350 im/s !

 

Demain je vais chez mon petit vendeur/monteur d'ordinateurs et je me fais faire une petite bécane dédiée :-)

 

Merci encore à tout le monde!

 

Daniel

 

 

Share this post


Link to post
Share on other sites

C'est quand même curieux. Tu n'a pas un disque dur ou une clé en USB 3 qui traîne pour vérifier l'interface.

Si rien ne marche, vérifie que les drivers USB 3 ne sont pas simplement absents/obsolètes  de ton PC ?

 

Je pose la question juste pour vérifier mais tu branche bien la caméra sur un port USB "bleu" ? Il n'est pas rare d'avoir les deux types de ports disponibles. Sur mon portable (pourtant pas une antiquité) j'ai 2 USB 3 (à gauche, plus un USB 3.1 mais je n'y branche rien) et 2 USB 2 (à droite). Les caméra USB 3 sont évidemment toujours branchées du même coté. Celles en USB 2 sont branchées indifféremment à droite ou à gauche.

 

Marc

 

  • Thanks 1

Share this post


Link to post
Share on other sites

Bonjour Marc,

 

Je suis passé par toutes les vérifications que tu mentionnes, y compris des mises à jour complètes de mon Windows 7. Et oui, bien sûr, j'utilise le port "bleu" ;-)

 

Mais c'est maintenant du passé. Je viens de me procurer un petit portable Acer tout neuf que j'ai pu essayer dans la boutique même, avec installation des drivers, de Firecapture et test de la caméra. J'obtiens des cadences enregistrées de 40 im/s en plein format, dans les 300 im/s en 640x480 et pour une petite fenêtre de 400x400 il rentre 400 im/s. Et le disque n'est même pas un SSD :-)

 

Merci encore!

 

Daniel

Share this post


Link to post
Share on other sites

1 ou 2 gbits/s suivant que tu sois en 8bits ou 16bits, donc 3 ou 6 fois le débit de l'usb2. c'est forcément de l'usb3 cette fois.

  • Like 1

Share this post


Link to post
Share on other sites
Il y a 7 heures, Daniel B a dit :

avec installation des drivers, de Firecapture et test de la caméra. J'obtiens des cadences enregistrées de 40 im/s en plein format,

Content pour toi! Et tu as essayé la version 2.7 de firecapture? un bond enorme en cadence et stabilité!

De 30im/s en plein format avec un cable de 5m usb3, je suis passé à 110im/s! avec la meme config! (qhiii290-mm)

 

  • Thanks 1

Share this post


Link to post
Share on other sites
il y a 52 minutes, exaxe17 a dit :

As-tu as essayé la version 2.7 de firecapture?

 

Wow, non!! est-elle suffisamment stable pour ne pas faire de mal à mon pôvre nouveau PC?

 

Daniel

Share this post


Link to post
Share on other sites
Posted (edited)

Je suis en train de tester la QHY5III290M sur mon vieux PC et sharpcap 3.2 dernière version à ce jour :

 

- le réglage de l'USB traffic est assez différent de la QHY5III224 : avec la 290 je peux descendre à 9 en plein capteur mais pas en dessous. Avec la 224 je peux descendre à 2. Mais le capteur de la 290 a quasiment 2 fois plus de pixels à transférer. En ROI c'est très similaire par contre, donc même quantité de pixels = même usb_traffic. Le driver est le même pour toutes ces QHY. (il a plus d'un an d'ailleurs, à mettre à jour peut être)

 

remarques importantes:

- le débit est nettement plus élevé avec sharpcap 3.2 qu'avec qharpcap 3.1 et plus stable

- il y a une régression notable sur mon PC du moins entre 3.1 et 3.2 : la fonction quickcapture ne fonctionne plus correctement, ni la limite en temps de capture. ça fonctionne bien en unlimited. J'ai eu un crash de sharpcap en 1440x1080

- avec le nouveau PC (core I5 de 8ème génération 8250u moins de 2ans tout passe en USB_TRAFFIC = 0, pas besoin de ralentir l'USB, ça passe à fond même en full frame.

- Avec le vieux PC core i7 2ème génération de 9 ans d'age on est obligé de freiner un peu le traffic surtout en full frame. à partir de 1024x768 tout passe à fond, débit identique sur les 2 PC. Donc le vieux PC fonctionne aussi bien que le neuf en planétaire. (i.e. en ROI)

- l'ancien PC plafonne à 1.3 Gbit/s de débit sur l'USB3 quand le nouveau monte à au moins 2.24Gbit/s

 

les résultats (sur 1minute de capture environ. preview sensiblement éqale à enregistrement, pas de ralentissement grace aux SSD et à la ram dispo). Cable USB3 d'origine livée avec la caméra.

 

ancien PC : PC portable DELL core i7 2630Q quad core 8 threads, 16Go de ram, 2 SSD 512 pour le système et 750 pour la capture win10/64 familial . charge processeur 30 à 40%. pas au taquet, c'est probablement plutôt le chip USB3 qui freine : en l'ocurence marque Renesas

nouveau PC : portable HP core I5 8250U 4 cores 8 thread 32 Go de ram 2 SSD 256 nvme pour le système 2To sata pour la capture charge processeur environ 40% au total dont 40% pour sharpcap 2thread au taquet en full frame

 

ancien PC : USB_TRAFFIC = 9    Sharpcap 1920x1080 : 76 fps (débit 1.26 gigabit/s)  Firecapture : 82 fps

nouveau PC : USB_TRAFFIC = 0   1920x1080 : 135 fps débit 2.24 gigabit/s

 

ancien PC : USB_TRAFFIC = 4      1440x1080 : 105 fps  (9.5ms par image USB_TRAFFIC = +2ms) débit 1.3 gigabit/s 

Firecapture 105fps @usb_trafic 4 mais on peu descendre à 3 avec FC et le débit monte un peu à 111 fps 1.32 gigabits/s

nouveau PC : USB_TRAFFIC = 0   1440x1080 : 135fps (idem à full frame !  7.5ms par image) débit 1,41 gigabit/s

 

ancien PC : USB_TRAFFIC = 2    1280x1024 : 125 fps   (8m par image -> USB_TRAFFIC = +1ms)

FireCapture 124 fps @usb_trafic 2 mais on peut descendre à usb_trafic 1 et on a 133 fps debit 1.32 Gbits/s

nouveau PC : USB_TRAFFIC=0   1280x1024 : 142 fps   (7ms par image)

 

ancien et nouveau PC : c'est strictement identique à USB traffic = 0 et ce pour FireCapture et Sharpcap

 

USB_TRAFFIC = 0  r
1024x768 : 186 fps débit 1.17 gigabit
800x600 : 233 fps
640x480 : 285 fps
480x480 : 285 fps
400x300 : 425 fps
320x320 : 403 fps
100x100 : 944 fps !

 

-> une unité d'USB_TRAFFIC ajoute une temporisation de 0.5ms à chaque image (dans ce cas précis)

Edited by olivdeso
ajout statistiques firecapture 2.7 beta
  • Like 1

Share this post


Link to post
Share on other sites
Il y a 3 heures, olivdeso a dit :

Je suis en train de tester la QHY5III290M sur mon vieux PC et sharpcap 3.2 dernière version à ce jour :

 

Ouhlaaa! Merci pour ces tests d'une extraordinaire précision!

 

Je vais faire quelques tests plus approfondis aussi, mais ma machine, même nouvelle, est beaucoup plus modeste...

 

Daniel

Share this post


Link to post
Share on other sites
Il y a 8 heures, olivdeso a dit :

-> une unité d'USB_TRAFFIC ajoute une temporisation de 0.5ms à chaque image

 

Tu est sur de toi ? Moi que je mette l'USB traffic à 95 (comme actuellement) ou à 50, je n'ai aucune influence sur le débit d'image (Firecapture), c'est toujours à fond les ballons sur l"ASI 178mm, que cela soit sur le SSD 500Go actuellement ou sur le couple cache RAM + SATA 500Go comme j'avais précédemment (à concurrence du remplissage des 7~8Go  du cache, donc 100% du planétaire et 90% des captures lunaires). Mesures faites sur une tour i7; 3,5GHz; 16Go de RAM, ou sur un portable i5, 12Go RAM, SSD 128Go Systeme, + SSD 512Go captures, ce dernier est dédié à l'Astro.

 

Mais je vais refaire des mesures pour m'en assurer avec FC 2.7 en particulier.

 

Marc

 

 

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)
Il y a 4 heures, patry a dit :

Tu est sur de toi ? Moi que je mette l'USB traffic à 95 (comme actuellement) ou à 50, je n'ai aucune influence sur le débit d'image (Firecapture), c'est toujours à fond les ballons sur l"ASI 178mm

 

edit : précision 0.5ms de tempo par unité d'usb traffic, c'est juste pour la QHY et une déductionvdes mesures de débit ci dessus, avec ou sans USB traffic.

 

attention sur ZWO le curseur marche dans l'autre sens. En gros en pourcentage de débit, plus tu augmente moins le débit est freiné. (au début ZWO faisait comme QHY mais ils ont changé)

 

Bref QHY dans sharpcap est différent de ZWO dans firecapture.

 

Je vais essai avec la QHY178mm et te dire.

 

l'idée de l'USB trafic est de ralentir le débit à faire passer sur l'USB3 pour que le PC puisse l'absorber. Dans le cas des vieux PC comme mon I7 de deuxième génération ce n'est ni le processeur, ni la ram ni le SSD le facteur limitant, mais bien le chip USB3 de première génération. c'est là où on a besoin de l'USB trafic. Avec le PC récent plus besoin tout passe à fond.

 

les caméras planétaires n'ont pas de buffer de ram : toutes les données doivent être transférées à chaque image à coup sur. Donc pour ralentir le débit de données à transférer, soit on augmente le temps de pose, soit on met une tempo entre les images, soit on fait du ROI.

 

Une fois, que c'est dans le PC, les firecapture et sharpcap récent utilisnt un buffer ram comme mémoire tampon. Et il y a aussi le cache disque. (voir un ram disk, mais plus besoin avec les SSD)

 

 

Edited by olivdeso
  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

résultats pour la QHY5III178 sur nouveau PC  i.e. tout passe à fond en raw 8 .ser, pas besoin de jouer sur l'USB traffic

 

3056x2048 52 fps
1600x1200 86 fps
1280x1024 100fps
1024x768  131 fps
800x600 164 fps
640x480 200 fps
320x320 285 fps

 

test USB_TRAFFIC nouveau PC

 

3056x2048
usb_traffic 0   52 fps
usb_traffic 1   44 fps
usb_traffic 2   39 fps
usb_traffic 3   35 fps
usb_traffic 4   31.5fps
usb_traffic 5   29 fps

....etc jusqu'à 60

 

test USB_TRAFFIC vieux PC :

ne fonctionne qu'à partir de 6 pas en dessous

usb_traffic 6   26.5 fps

 

 

-> le débit en sortie de la caméra est bridé de plus en plus quand on augmente l'USB_TRAFFIC sur les QHY. (Sur ZWO le curseur marche dans l'autre sens)

ici pas besoin de brider le débit, ça fonctionne encore bien à usb_traffic 0, donc c'est ce qu'il faut choisir bien sur

 

REMARQUE TRES IMPORTANTE : j'ai eu des soucis avec la 178 sur le vieux PC : elle était reconnue en USB2 seulement. pour résoudre il a fallut faire 2 choses:

- nettoyer le connecteur coté caméra : il y avait  une saleté sur les pin USB3 (petite languette) qui sont beaucoup plus petite que les USB2 (4 grosses pins)

- redémarrer le PC, le contrôleur USB3 Renesas avait planté suite à l'USB mal reconnu plusieurs fois de suite

Edited by olivdeso
  • Thanks 1

Share this post


Link to post
Share on other sites
Il y a 2 heures, olivdeso a dit :

attention sur ZWO le curseur marche dans l'autre sens. En gros en pourcentage de débit, plus tu augmente moins le débit est freiné. (au début ZWO faisait comme QHY mais ils ont changé)

 

Ouhlaaa, v'la autre chose... On parle de FireCapture, de Sharpcap ou des deux?

 

Merci,

 

Daniel

Share this post


Link to post
Share on other sites
Posted (edited)

le test de la QHY5III224 avec sharpcap 3.2 : point interessant, le débit s'est légèrement amélioré sur le vieux PC par rapport au 3.1

-> quasiment tout passe à fond sur le vieux PC avec USB_TRAFFIC à 0 sauf en full frame où la je suis obligé de réduire à peine à  USB_TRAFFIC=1

 


nouveau PC USB_TRAFIC 0 : 1280x960 154fps

vieux PC USB_TRAFIC 1 : 140 fps

-> la réduction est minime sur le vieux portable en full frame et c'est

 

Ancien et nouveau PC résultats idem car stable avec USB_TRAFFIC = 0
1024x768  191 fps
800x600 242 fps
640x480 299 fps
320x320 435 fps
100x100 1080 fps

 

conclusion:

- la 224 est extrêmement rapide, même sur vieux PC et reste donc le meilleur choix actuel pour du planétaire couleur

- la 224 (qui a moins de pixels) tourne parfaitement sur un vieux PC à fond quasiment tout le temps sauf en full frame et encore la réduction de débit est minimale

Edited by olivdeso
  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now