Recommended Posts

@frank-astro On a la même config, jusqu'à la box SFR !

 

il y a une heure, frank-astro a dit :

J'ai essayé Kstar depuis mon PC et cela fonctionne sans grande différence depuis une prise de main à distance mais je ne sais pas si c'est conseillé que ce soit le PC à distance qui pilote l'autoguidage et les prises de vues.

J'ai lu justement que c'est ce qui était conseillé de faire ici : https://www.astronamis.net/t6460-kstars-ekos-indi-une-solution-alternative-pour-l-astrophoto

Remarque que c'était peut être plus le cas avant le RPI4.

Mais c'est justement ce que je n'arrive pas à faire. Quand je lance Kstar/Ekos sur mon PC, il ne voit pas le RPI Stellarmate...

 

Edited by Jean-Marc_M

Share this post


Link to post
Share on other sites
Advertising
By registering on Astrosurf,
this type of ad will no longer be displayed.
Planetary Astronomy
Observing, imaging and studying the planets
A comprehensive book about observing, imaging, and studying planets. It has been written by seven authors, all being skillful amateur observers in their respective domains.
More information on www.planetary-astronomy.com

Ha oui, intéressant. Donc si je lance Kstars depuis mon pc, il n'utilise qu'INDI sur le RPI ? Je pensais qu'il utilisait SM.

Donc à tester...

 

Depuis mon PC, si je lance Kstars + EKOS, je lui demande de scanner pour trouver l'INDI et ça le fait de suite. J'ai rien bricoler pour une fois...

Share this post


Link to post
Share on other sites
il y a 13 minutes, frank-astro a dit :

Donc si je lance Kstars depuis mon pc, il n'utilise qu'INDI sur le RPI ?

C'est ce que j'ai compris.. Ca donnerait un système sans latence sollicitant peu le RPI pour la partie logiciels puisque ce sont ceux du PC qui travaillent.

il y a 22 minutes, frank-astro a dit :

Depuis mon PC, si je lance Kstars + EKOS, je lui demande de scanner pour trouver l'INDI et ça le fait de suite

Compris, enfin...

Merci !

Share this post


Link to post
Share on other sites
il y a 33 minutes, frank-astro a dit :

Depuis mon PC, si je lance Kstars + EKOS, je lui demande de scanner pour trouver l'INDI et ça le fait de suite. J'ai rien bricoler pour une fois...


Il trouve INDI sans avoir à spécifier l'IP du RPi ni autre chose ? Wow !
Faut que j'essaye ça ! :)

Share this post


Link to post
Share on other sites

Ben oui toé ! Ça marche !!! Juste en me connectant avec Ekos sur PC il me demande où est branché mon matériel et Stellarmate est là, il communique en Stellarmate:local... Et voilà !!! Génial !!! Merci à vous deux ! Maintenant va falloir faire des essais en live... Cool !

  • Like 2

Share this post


Link to post
Share on other sites

Pour faire des essais, va falloir qu'il fasse beau. Et moi, en ce moment, c'est la misère :(

Share this post


Link to post
Share on other sites
il y a 4 minutes, Looney2 a dit :

Ben oui toé ! Ça marche !!!

Super ;)

 

Petit test dans mon salon, ça semble plus réactif et stable pour le pilotage du setup. Par contre, l'affichage de la brute en liveview est un poil long forcément (environ 7 secondes), l'image de 30 Mo a du chemin à faire pour arriver sur mon PC. Ca pourrait bien être pénible pour faire la MAP en manuel avec un Bahtinov par exemple. Mais si la MAP auto fonctionne comme je l'espère alors ça ne sera pas bien grave.

A suivre donc !

Share this post


Link to post
Share on other sites

Sauf que le mode live doit surement être compressé donc peut-être pas si mal pour faire du live ? Enfin si tu fais une acquisition pour valider la MAP en effet va falloir attendre la brute qui passe dans le réseau. Faut prendre un vieux 40D avec des RAW de 9Mo :D

Share this post


Link to post
Share on other sites

Il faudrait faire un crop ou passer en bin2 ou 3 mais c'est pas super intuitif Ekos...

  • Like 1

Share this post


Link to post
Share on other sites

J'ai trouvé, le crop se fait facilement dans le liveview de l'onglet focus (logique...) et là ça va très vite. Ca commence à me plaire de plus en plus Stellarmate !

  • Like 2

Share this post


Link to post
Share on other sites

Pour la connection sur le PC, il suffit dans la configuration d'Ekos (profile) de remplacer le pointage de local à remote, le SSID est déjà mis sur stellarmate, donc sauf si vous avez changé le nom du réseau, il n'y a rien à faire.

 

A la prochaine sortie, je vais essayer cette configuration, pour voir ce que cela donne :D

 

 

J'ai bon espoir que nos efforts conjoints nous permettrons à tous d'avoir quelque chose d'opérationnel. J'ai l'impression que la connection au RPI est un point clé du bon fonctionnement du setup.

 

Avez-vous pu améliorer ou trouver les bon réglages pour la capture des images.

J'ai aussi essayé la vidéo, le FPS average indiqué semblait très bas par rapport aux capacités de la caméra.

Share this post


Link to post
Share on other sites

Question : j'ai mis un nano routeur TP Link pour pouvoir attraper mon réseau local depuis ma cour. Or, je me dis que c'est tellement bien fait que je le garderais bien dans les configs nomades même si de fait j'aurai besoin de moins de puissance, étant proche du télescope. 
Je m'aperçois qu'avec le nano routeur, Stellarmate considère qu'il est en mode Ethernet donc il ne veut pas lancer le Hotspot... Y'a t-il moyen de paramétrer SM pour qu'il se mette en Hotspot avec le nano routeur ou faut il que je l'utilise en "répéteur" avec toute la config qui vient avec à chaque changement de setup nomade/réseau local ?

Rhooo et sur une page Facebook, je viens d'apprendre qu'on peut finalement utiliser le Raspberry avec VirtualHere qui transforme votre RPi4 en gros port USB VPN et à l'autre bout vous mettez ce que vous voulez avec le système que vous voulez... Donc en gros, on installe VirtualHere sur SM et à l'autre bout on fait rouler N.I.N.A par exemple. Par contre j'imagine qu'il faut que le réseau soit rapide... Incroyable ce qu'on peut faire avec un RPi !!!!

Edited by Looney2
  • Like 1

Share this post


Link to post
Share on other sites

Bonjour, 

Pour le hotspot, je le bascule soit depuis l'interface Android soit sur le bureau en  vpn (en haut à droite).

De mon coté,  je trouve le système opérationnel.  Si je n'avais pas tenté une mise à jour à distance,  et si j'avais compris qu'il faut le brancher sur la box pour générer une adresse ip, je n'aurais jamais été embêté.

Indi a reconnu de suite mes caméras,  ma monture et mon EAF.

J'ai encore testé hier soir et tout fonctionne parfaitement, y compris le solving et le flip au méridien.

Mon seul bémol à ce jour est l'onglet Openweather que j'ai du mal à interpréter. 

Concernant NINA, vous pouvez m'éclairer sur ce soft ?

Qu'a t il de plus ?

Merci. 

Edited by frank-astro

Share this post


Link to post
Share on other sites

Pour le nanorouteur, je vais tester cela la prochaine fois, connecté au réseau wifi ou en hotspot?

 

J'ai regardé la doc de stellarmate:

https://stellarmate.com/support.html?view=kb&kbartid=10

 

Par contre, il est indiqué que le hot spot est actif, ce qui ne semble pas le cas chez moi.

Je vais me pencher là-dessus aujourdh'ui (si j'arrive à dégager le temps).

 

@frank-astro: j'ai l'impression qu'un poste fixe simplifie les choses :D

 

Share this post


Link to post
Share on other sites
Il y a 6 heures, kaelig a dit :

Par contre, il est indiqué que le hot spot est actif, ce qui ne semble pas le cas chez moi.


"By default, StellarMate operates in HotSpot mode. Even if configured for WiFi connection or LAN, StellarMate always switches back to HotSpot mode when the other connection mode become unavailable. This is to enable you to always access the device regardless of network avalibility."

Ça c'est ok et c'est plutôt bien...

 

"If StellarMate is connected over Ethernet, the HotSpot is NOT started. It is only started when all connections are unavailable."

 

C'est là qu'il y a problème... On ne peut donc pas basculer le Hotspot vers le nano routeur qui est considéré comme un réseau ethernet.

 

Il y a 7 heures, frank-astro a dit :

Pour le hotspot, je le bascule soit depuis l'interface Android soit sur le bureau en  vpn (en haut à droite).


Oui j'ai bien vu ça, on peut le faire aussi dans l'OS du SM avec l'icone du Wifi si je me souviens bien mais du coup c'est l'antenne du SM qui émet, plus le nano routeur à ce que j'en comprends. Le nano routeur est vu comme un réseau ethernet, pas comme un périphérique Wifi donc on retombe dans les portées limitées de la chose... :(

Share this post


Link to post
Share on other sites
Il y a 7 heures, frank-astro a dit :

Concernant NINA, vous pouvez m'éclairer sur ce soft ?

Qu'a t il de plus ?


N.I.N.A est le logiciel GRATUIT à la mode sous windows car il a une interface visuelle très claire et très bien faite, il permet un setup complet et contient bien des options pour paramétrer sa séance avec un atlas complet pour la planification. À priori ça marche bien et vite et la communauté toujours plus nombreuse fait en sorte que le logiciel évolue très vite (bcp de mises à jour) et prend en charge à peu près tout ce qui existe de matériel astro sur terre... Cerise sur le sundae : il est multi langages...

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Avec Ekos, les images de ma caméra (ASI183) font 19 Mo en 8 bits alors qu'avec mon logiciels habituel (APT) elle faisaient environ 30 Mo en 16 bits.

Je ne trouve pas où régler ce paramètre, help !

Share this post


Link to post
Share on other sites
il y a 5 minutes, Jean-Marc_M a dit :

Avec Ekos, les images de ma caméra (ASI183) font 19 Mo en 8 bits alors qu'avec mon logiciels habituel (APT) elle faisaient environ 30 Mo en 16 bits.


Normalement quand tu lances ton driver INDI dans EKOS il y a une fenêtre de paramètres INDI qui apparait. Sinon clique sur le logo INDI dans EKOs (voir image) quand tout est connecté et ton interface de configuration INDI devrait apparaitre.

 

 

ekos.jpg

Share this post


Link to post
Share on other sites

Oui je passe par ça mais c'est grisé en 8 bits/pixel...

6010461dbdd99_Capturedcran2021-01-26174003.jpg.57f4894cc0d9b6467716b902fea123e9.jpg

L'ADC depth est bien en 12 bits (la caméra est en 12 bits) mais l'image ne fait quand même que 19 Mo pour les 30 Mo habituels. J'ai comparé le "Fits header" de mes images prises sous APT avec celles d'Ekos, c'est bien 16 bits vs 8 bits >:(

Si vous utilisez une caméra ZWO, avez vous ce cas ?

 

Share this post


Link to post
Share on other sites

Hum, bizarre, pas regardé avec ma 290MC... As-tu exploré les différents onglets que tu peux déployer en haut à droite avec la petite flèche ? Y'a rien qui permet de choisir le bit depth ?
Oh j'y pense : as tu bien branché ta caméra sur un port USB 3 ?

Share this post


Link to post
Share on other sites
Il y a 2 heures, Looney2 a dit :

Cerise sur le sundae : il est multi langages...

 

Notamment le langage g...astronomique on dirait :P  !

 

  • Haha 2

Share this post


Link to post
Share on other sites
il y a une heure, Jean-Marc_M a dit :

Si vous utilisez une caméra ZWO, avez vous ce cas ?


Je viens de brancher ma petite 290MC pour voir et tout est en 16 bits... Mais l'histoire du USB 3 pourrait être la réponse. Tu utilises bien un RPi4 avec ses deux ports USB 3 ? Le RPi3 n'a que des USB 2.0 et je pense que de fait il ne prend pas le 16 bits (à vérifier).
[EDIT] : je viens de brancher ma 290MC sur l'USB 2 et il sort quand même en 16 bits... Après est-ce la même chose pour toutes les caméras ?
 

ZWOINDI.jpg

 

Va voir dans INDI onglet "controls" si tu as les différents formats, peut être simplement RAW 16 bits qui n'est pas activé ?

 

raw16.jpg.939b47f3ed3d9cf85efa1f51d3671638.jpg

Edited by Looney2
  • Thanks 2

Share this post


Link to post
Share on other sites
il y a 19 minutes, Looney2 a dit :

As-tu exploré les différents onglets que tu peux déployer en haut à droite avec la petite flèche ?

Effectivement il y a une petite flèche que je n'avais pas vue... Et à l'onglet controls il y a le choix 8 bits ou 16 bits !

Merci ;)

 

  • Like 3

Share this post


Link to post
Share on other sites

Ce fil est super constructif (hors @Penn bien sûr, LOL), j'ai essayé plusieurs choses ce soir

J'ai tout recâblé, mais ca fait quand même pas mal de boite: RPI, nanorouteur, hub power, 

 

 

1) test du  nanorouteur

---------------------------------------

J'ai connecté le nanorouteur tplink wr902Ac, il est connecté au RPI avec un câble Ethernet.

Je l'ai testé en mode 'range extender', dans les 2 configurations suivantes

- en point de recopie du wifi réseau de la maison

- en point de recopie du hot spot 'stellarmate' du rpi (rappel du psswd du hotspot: stellar@mate)

 

Ca marche super, pas pu le tester en extérieur, il y a un gain très notable. Vivant dans un vieux lieux

avec des murs épais, je pense l'utiliser dans un premier temps en mode 'stellarmate'.

 

Comme j'ai connecté le wifi de la maison dessus, c'est ce réseau qu'il utilise. J'ai configuré le nanorouteur

en répéteur du hotspot stellarmate avant, je rentre sur le RPI, je rebascule en hotspot, ca marche

sans souci. 

 

Quand je testerai en extérieur, je vous dirai ce qu'il en est.

 

2) test de kstars/ekos en remote sur le PC

--------------------------------------------------------------------

Pas de nanorouteur ou nanorouteur / connection sur le réseau de la maison ou en stellarmate,

la connection se fait ... mais

 

J'ai eu quelques crash de kstars/ekos que je n'ai pas compris. Je vais regarder ma version. J'ai 

une nette amélioration avec le nanorouteur (moins de crash, plus de fluidité). J'ai vu quelques

petits soucis:

- la fenêtre type 'raquette' qui est trop petite et que l'on ne peut pas agrandir

- le temps d'affichage d'une photo (j'ai essayé la sauvegarde sur le PC ou sur le SSD connecté au RPI), je suis à

un peu moins d'une minute. ca me parait beaucoup, je vais regarder ca. Avez-vous fait le test?

- j'ai fait suivre une cible, la monture a bougé, suivi, mais impossible d'arrêter le suivi monture ... il ne voulait pas me rendre la main. Je retesterai.

 

Autrement, lorsque j'ai voulu me connecté à Ekos sous windows, en mode hot spot, j'ai pu me connecter sur l'adresse hot spot 250.250.10.1

 

Je vais essayer de creuser cette histoire de kstars/ekos en remote, je pense que c'est le plus efficient à terme.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



  • Similar Content

    • By Sauveur
      Bonjour a nouveau
       
      voila une fois n'est pas coutume je me suis fais quelques session cp en mode amateur  mais pourquoi et comment mais venue l'idée 
       
      Vendredi dernier il etait prevu beau temp donc Mars pour moi mais je voulais faire profité Alain mon ami de mon emplacement pour qu'il puisse shooté (ca fais au moins 6 mois qu'il a rien a ce mettre sous la dent  a cause de ces contrainte
       
      comme sa météo ne lui donnait pas beau temps il passa son tour  il a bien regretté apres coup 
       
      Donc Emilio vite texto et lui etait partant
       
      on a fais Mars ensemble puis il a fais du Cp moi pour rester avec lui bein mis suis mis aussi au Sony A7S défiltré par mes soins
       
      une nuit au top pas d'humidité pas froid on sait bu au moins 3 café serre pour tenir la nuit 
       
       
      Comme je savais pas quoi shooter bein on a avisé a la dernier minute avec plus ou moins de succès 
       
      Pas trouver le fantôme qui est prêt de l'iris  du temps de pose de perdu
       
      ma mairie a eu la bonne idée de remplace mes lampadaire sodium par des led pinaise on y vois super bien pour pas taper dans la monture mais pas cool pour les reflet dans les images même en pointant a l'opposer surtout que j'avais zappé le par buée
       
       
      Donc mon petit tour en amateur ma donnée envie de continué quelques nuit tous seul en plus la au vue de certain post me suis noté quelques objet sympa
       
       
      M 44 au C11 réducteur 6.3 cop des reflet
       
       

       
      L'iris mais la la collim j'ai pas refait et c'est bien plus bas que Mars
       

       
      M13 en vite fait
       

       
      la m81 du soir
       
      384 poses de 30 s 3200 iso pas de flat c'est vilain petit canard qui avais la flemme et pas de quoi aussi 
       
      C11 Sony a7s
      Siril 
       

       
       
      Donc du coup comme elle ma plus la nuit suivante je voulais lui adjoindre des poses 
       
      la dof  (flat sur le ciel)
       
      Erreur de débutant j'avais pas corrigé l'orientation du Sony  pis apres les flat suis allez en butée pied me modifiant l'orientation de l'apn 
       
      Bon j'ai vue une autre nuit que le c11 la map bouge pas mal en fonction de l'orientation du coup faudrait la reprendre en cour de nuit au moins trois fois  pas cool ca et j'ai pô fais
       
      Si quelqu'un a un lien pour les vis de blocage du primaire suis preneur
       
       
      M64 vite fait acr a cette focale c'est pas rapide les acquisition même si le Sony est une bombe
       

       
       
      M82 car Emilio a fais ca et je voulais essayer même si c'est pas ma preferer et j'ai pas le filtre Halpha
       
      bein la c'est gros hein 
       

       
      Ngc 3521
       

       
       
      pis celle que j'ai continuer car j'ai flaché sur elle donc la en cour deux session
       
       

       
       
       
      la total noté sur l'image
      pis le coquin a tous stacker avec Siril  pas de sélection n'y f machin n'y rondeur
       

       
       
      La tif si vous voulez me l'amélioré ca serais sympa j'arrive pas utilisé le logiciel recommandé pas Alain pour arrondir les étoiles 
       
      C'est cropper a cause de mon erreur de position apn du a ma négligence le premier soir
       
       
      toutes m81 _pp_brute_stacked.tif
       
       
      Bonne journée et merci des conseils
       
       
      Sauveur
       
       
       
       
    • By siegfried_M31
      Cela faisait un moment que l'envie ciel profond me démangeais.
      L 40*300s bin1
      R+B 10*300s bin2
      G6*300s bin2
      Sauf réduction étoiles, traitement complètement bio.
      NGC4438 est vraiment très spéciale, elle est sacrément tordu, j’adore, c'est vraiment très esthétique.
      Le couple NGC4438 &  NGC4435 est également connu sous le nom ARP120
      Veuillez cliquez sur l'image

      Voir ici aussi : https://telescopius.com/pictures/view/84287/deep_sky/M/86/galaxy/by-siegfried_m31
    • By Lonelystar78
      Bonsoir à toutes et tous,
      Nouveau possesseur d'une caméra CMOS refroidie (ASI2600MC Pro), je me demande s'il est légitime de faire une bibliothèque de darks et d'offset pour différentes valeurs de température et gain en actualisant celles-ci régulièrement pour tenir compte d'un vieillissement du produit?
      L'avantage est que l'on peut faire cela les jours de pluie  et gagner du temps de pose pendant les sessions photos
      Merci d'avance pour vos retour
       
      Bon ciel
      Patrick
    • By CB7751
      Bonjour,
      Je sais que ce n'est pas la meilleure période pour la faire, mais des soucis de guidage avec une CEM70 (pour l'instant j'ai envie de dire évitez d'acheter ça) sur les galaxies plus hautes m'ont fait choisir quelque chose un peu au hasard plus bas.. le cadrage n'est pas  idéal parce qu'après au moins 4 sorties dans le froid pour tripoter la monture j'ai eu la flemme d'aller tourner le capteur.
       
      C'est quand même la première image finie avec le nouveau matériel.
      RASA 11, caméra ZWO ASI183MC Pro, 167x120s filtre STC MultiSpectra
      Edit: voilà une brute pour les curieux https://we.tl/t-ivgHt878gL 

    • By Nathanael
      Bonjour à tous,
      *J'ai fait aluminer ce 250 pour la première fois en 92 quand je suis parti au service militaire (oh le vieux!) www.flickr.com
      Et depuis, il a subi des modifications "mecatroniques", notamment l'autoguidage et le rembobinage automatique du secteur lisse.
      J'ai fait hier, sous la pleine lune, un petit time lapse de l'engin en fonctionnement Pour les bricoleurs, notez le rembobinage du secteur toutes les deux heures environ et le va et vient du contrepoids
       
      J'ai fait 1200 images de 20s en jpg avec sharpcap, la 224mc et l'objectif d'origine, monté la vidéo dans virtualdub.
      [Résolu: -> virtualdub2, merci @David2010 ]  Je bute sur un problème de compression. Vous avez ci-dessous le gif de 20 mo mais l'avi non compressé fait 1go. Comment on fait? mp4? Comment, avec quel logiciel? Merci par avance!

      Nathanaël
       
       
      23/03 épisode 4 : vue du contrepoids
       
      La vidéo mp4
       
       
      20/03 épisode 3 :
       
           La vidéo mp4
       
       
      10/03, épisode 2 : l'éclairage erratique du début correspond au réglage du télescope sur la cible de la nuit avant les poses. En étant observateur, on peut deviner dans quelle constellation
       
          La vidéo mp4 4Mo
       
       
           La vidéo mp4 2Mo
       
  • Upcoming Events