NicoF

Mesure EP de jour

Recommended Posts

Advertising
By registering on Astrosurf,
this type of ad will no longer be displayed.
Planetary Astronomy
Observing, imaging and studying the planets
A comprehensive book about observing, imaging, and studying planets. It has been written by seven authors, all being skillful amateur observers in their respective domains.
More information on www.planetary-astronomy.com

Bonjour,

Merci , bien pensé ce logiciel, ca pourrai marcher avec une étoile artificielle ?

Paul

 

  • Thanks 1

Share this post


Link to post
Share on other sites
Il y a 2 heures, banjo a dit :

ca pourrai marcher avec une étoile artificielle ?

 

En fait non car durant la manip le système de prise de vue balaye le champ (15 deg en 1 heure environ), avec une grande focale l'étoile artificielle ne restera pas dans le champ.

Exemple de balayage de champ pour réalisé les courbes obtenues ci-dessus.

DSC09710_pipp.gif.8819794d6473ccfc427b186e7654da8b.gif

 

De plus le principe de l'algo est de comparer les images 2 à 2: 

Il prend une portion de 10% du champ au centre de l'image

Pattern.png.479e437f4bd06ce690f9fc6ff38589cc.png

 

et recherche ce "Pattern" dans la seconde image pour calculer le mouvement :

 

 Detected_point.PNG.ecef7f5cf703617c771e08243118ec75.PNG

 

Bonne journée

Nicolas

  • Thanks 4

Share this post


Link to post
Share on other sites

Excellent ! Mais ça m'intrigue... As-tu comparé le résultat obtenu avec celui d'une mesure d'EP classique, celle faite avec PHD par exemple ?

Share this post


Link to post
Share on other sites

Oui j'ai vérifié ca colle assez bien.

L'étape délicate est l'intégration de la vitesse de déplacement pour revenir à la position. Cette intégration génère un drift qui doit être compensé.

La compensation dans l'algo fonctionne bien si la durée d'acquisition est a minima de 2 voire mieux 3 tours de vis sans fin. Dans ce cas j'ai des mesures comparables.

Si  l'acquisition n'est faite que sur une seule période ou moins , l'EP a tendance a être minimisée. Je dispose d'un autre algo de compensation pour ces acquisitions courtes (pratique aussi pour tester rapidement l'effet d'un réglage);

 

 

  • Like 2

Share this post


Link to post
Share on other sites

Super travail que tu as fait là. J avais pensé a un truc similaire il y a quelques années sans jamais aller plus loin que la pensée. Ca va aider et faire gagner du temps a pas mal de personnes.

Merci pour le partage.

 

Thomas

  • Thanks 1

Share this post


Link to post
Share on other sites

C’est tout à fait génial !

 

ce qui serait bien, c’est de pouvoir entrer l’échantillonnage manuellement, on peut en effet l’avoir sur le CP après une résolution astrométrique.

 

pour lire les exifs il y a exiftools qui est constamment mis à jour 

 

attention aussi à ne pas viser un paysage trop proche sinon il y aura pollution des résultats par la parallaxe. Ou alors il faut placer le centre de pivot sur la pupille d’entrée de l’objectif.

Edited by Fred_76
  • Thanks 1

Share this post


Link to post
Share on other sites

Bonjour 

Et merci de ton commentaire.

 

Il y a 6 heures, Fred_76 a dit :

ce qui serait bien, c’est de pouvoir entrer l’échantillonnage manuellement,

 

L'algorithme calcule automatiquement l'échantillonnage à partir de a vitesse de suivi stellaire (rapport entre la vitesse mesurée en pixels par seconde et 15,04 arcsec/seconde).

Une entrée manuelle n'apporterai rien pour le calcul.

Comparer le résultat avec des données astrométrique permet de valider le calcul complet. Je m'en suis servi pour la validation.

 

Il y a 6 heures, Fred_76 a dit :

pour lire les exifs il y a exiftools qui est constamment mis à jour 

 Le S/W utilise la lib python Exifread.

Pour utiliser le Soft vous n'avez pas trop a vous en préoccuper. Il faut juste s'assurer que les images aient bien des données EXIF et notamment la date/heure de prise de vue.

C'est le cas si vous avez shooté avec un APN standard.

 

Il y a 6 heures, Fred_76 a dit :

attention aussi à ne pas viser un paysage trop proche sinon il y aura pollution des résultats par la parallax

Je n'ai pas constaté de problème en visant une cible proche, si ce n'est que nos instruments n'arrivent pas à faire la mise au point à courte distance et qu'il faut que cette mise au point reste bonne pendant la durée du balayage ce qui n'est pas évident à courte distance.

 

Bonne soirée,

Nico

 

  • Like 1

Share this post


Link to post
Share on other sites

A ton avis, quelle focale faut-il au minimum pour avoir un résultat fiable ? La plus grande focale que j’ai est de 200 mm. Après, ma monture n’est plus capable de porter le poids... (c’est une SAM).

Share this post


Link to post
Share on other sites

La focale et la taille des photosites du capteur  vont influer sur la résolution de ta courbe d'EP.

Plus le pixels seront petits et plus la focale sera longue plus grande sera la résolution.

 

Par exemple si tu as un A7S  (photosite 8.32 µm) derrière un 200mm tu auras une résolution de 9 Arcsec.

Si tu mets une camera type ASI120 (photosites 3.5 µm) avec le même objectif la résolution augmente à 3.6 Arcsec.

 

Tu peux aussi jouer avec des barlows la qualité de l'image n'est pas fondamentale, l'algo de pattern matching prend une grande zone même avec une image qui bave il  s'en tire bien.

Les points fondamentaux pour conserver la précision sont :

- faire 2/3 tours de vis sans fin

- Eviter les bords du capteur, toujours faire en sorte que le décalage d'une image à l'autre soit entre 50 et 100 pix. Sinon le centre de la première image va se retrouver au bord du capteur sur la deuxième 

 

Bonne soirée,

Nico 

 

  • Like 1

Share this post


Link to post
Share on other sites

Bravo ,  super boulot.

Je vois qu'il y a beaucoup d'avantages avec cette méthode. 

Pas de mise en station précise à faire .

Pas d'achat supplémentaire de matériel . Certain  constructeur utilise un codeur optique très précis pour mesurer l'EP.

On fait ça de jour .Il faut juste avoir un horizon dégagé.

Trop cool

 

Merci

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)
Le 30/12/2020 à 23:47, Fred_76 a dit :

La plus grande focale que j’ai est de 200 mm

 

Donc je viens de faire quelques essais.

A 200mm avec mon A7s, il me faut des intervalles de 40s entre prises (là ou j'étais à 10s avec une focale de 900mm).

J'ai shooté une cible proche (2m environ)

DSC02234_pipp.gif.9145c71b5c22bf73c46875a0473144c2.gif

 

Ca fonctionne mais on perd toute les fréquences supérieure à 1/(2x40) secondes donc on ne voit plus que les phénomènes de période supérieur à 80s.

La courbe d'EP avec la même monture donne ceci :

 

image.png.945e65c3f8a6c8e46e4a910d96e16c87.png

 

A comparer à celle-ci faite à 900mm

 image.png.457086c8f9de5021ceb2a5c424130f8b.png

 

On constate que les résultats restent valides mais que l'on ne voit que les phénomènes liés à la vis sans fin. Tout ce qui se passe avant dans la chaine de transmission (moteur pas à pas, poulie/courroie, etc) est à plus haute fréquence et n'apparaît plus sur la courbe.

En conclusion, la manip peut présenter un intérêt en fonction de ce que tu cherches à caractériser.

 

Bonne soirée,

 

Nicolas

Edited by NicoF
  • Like 2

Share this post


Link to post
Share on other sites

Ça ira, j’ai un paysage avec près de 500 m de recul. Je vais tenter ça un de ces 4 !

Share this post


Link to post
Share on other sites
Posted (edited)

Bonjour

Je n'ai pas constaté de différence notable liée à la distance de prise de vue 2m ou 10km donneront des résultats semblables. 

En revanche, c'est la focale et le pitch des photosites du capteur qui comptent et en général les instruments à longue focale ne savent pas faire la mise au point sur des cibles proches.

 

Nicolas

Edited by NicoF
  • Like 2

Share this post


Link to post
Share on other sites
Posted (edited)

Bonjour Nicolas,

 

Un petit up pour te remercier chaleureusement pour le partage de ton travail.

 

J'ai fait une acquisition rapide ce midi vers un toit voisin et j'ai testé le traitement ce soir.

Ca marche très bien. je n'ai pas fait une acquisition suffisamment longue mais l'allure de la courbe ne semble pas délirante et ça fonctionne bien. Je vais profiter du weekend pour faire une acquisition plus longue. 

 

A noter que la version package avec les exe fonctionne jusqu'à la génération du fichier xx_calib_raw_result.csv et rien ne s'affiche. 

J'ai alors utilisé directement le code source en installant les bonnes dépendances et là tout fonctionne. J'aboutis bien à l'affichage des courbes sous chrome.

Ca ne me dérange pas mais c'est juste pour te faire un petit retour de test.

 

Merci à nouveau pour ce très beau travail et son partage. Je pense que ton outil me permettra, périodiquement,  de vérifier annuellement et de jour, du besoin d'envoyer ma monture pour une petite révision.

Et si jamais je me sens apte à mettre les mains dans le cambouis, à valider mes réglages.

 

Bon ciel à toi

Samuel

Edited by samdav
  • Thanks 1

Share this post


Link to post
Share on other sites

c'est pas mal ça ! 

 

en complement de parser les exifs, il n''y aurait pas moyen de récup l'heure de prise de vue dans l'en-tête des fichiers .fit / .fits / .ser ? 

on a pas tous des apn ;) 

  • Thanks 1

Share this post


Link to post
Share on other sites

Bonjour

 

Merci de vos commentaires et encouragements.

Le 3/18/2021 à 23:07, samdav a dit :

A noter que la version package avec les exe fonctionne jusqu'à la génération du fichier xx_calib_raw_result.csv et rien ne s'affiche. 

Je vais regarder ca --> Merci du retour, je teste sur un PC sur lesquels les dépendances sont déjà installées donc pas évidant à détecter.

Le 3/18/2021 à 23:31, ZeMrHyde a dit :

en complément de parser les exifs, il n''y aurait pas moyen de récup l'heure de prise de vue dans l'en-tête des fichiers .fit / .fits / .ser ? 

Oui j'y travaille, je suis sur une version qui prend des vidéos en entrée, il faut juste être sûr que le pas de temps entre les prises soit correct.

 

Bonne soirée,

Nicolas

  • Like 1

Share this post


Link to post
Share on other sites

Cool, ce Up, j'avais oublié ce truc génial !

  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



  • Similar Content

    • By Jean-Marc_M
      Bonjour à tous !
      Après avoir été enthousiasmé par la dernière petite monture Ioptron GEM28 (clic), je déchante un peu à l’utilisation..
       
      L'EP
      Lors d'une animation sur une protubérance solaire avec une Lunt 60/500 et une barlow x2, je trouvais que mon cadrage se déplaçait un peu trop pour une EP annoncée à ± 10”. J’en ai donc fait la mesure mais je ne sais pas l’analyser avec PECPrep puisqu’elle n’est pas dans la liste des montures du logiciel et il me manque une info pour la créer (le nombre de pas par révolution). Le relevé a été fait sur une cinquantaine de minutes avec une lunette 60/330 et une ASI178MM en bin 2 (pixels natifs de 2.4 µm). L’étoile qui a servi était proche du méridien et de l’équateur, la monture parfaitement équilibrée.
      L'EP est lisse (bonne nouvelle) mais je pense qu'elle est de l’ordre de 40” crête à crête (moins bonne nouvelle). J’ai un doute par le fait que la caméra était en bin 2 et que 40" c'est pile le double de 20", le ±10" promis par Ioptron.
       
      >> Quelqu’un pourrait-il confirmer mon interprétation sur cette valeur d’EP ?
       

      Section Heading 
      Guiding Begins at 2021-04-07 22:23:22  
      Equipment Profile = TS 60/330 & ASI178  
      Dither = both axes, Dither scale = 1.000, Image noise reduction = none, Guide-frame time lapse = 0, Server enabled  
      Pixel scale = 3.00 arc-sec/px, Binning = 2, Focal length = 330 mm  
      Search region = 15 px, Star mass tolerance = 50.0%, Single-star mode  
      Camera = ZWO ASI178MM, gain = 60, full size = 1544 x 1040, no dark, no defect map, pixel size = 2.4 um  
      Exposure = 3000 ms  
      Mount = iOptron CEM120/70/26/GEM28 Mount (ASCOM), connected, guiding disabled, xAngle = 88.3, xRate = 2.427, yAngle = 178.3, yRate = 2.329, parity = +/+  
      Norm rates RA = 7.4"/s @ dec 0, Dec = 7.0"/s; ortho.err. = 0.0 deg  
      X guide algorithm = Lowpass, Slope weight = 5.000, Minimum move = 0.200  
      Y guide algorithm = Lowpass, Slope weight = 5.000, Minimum move = 0.200  
      Backlash comp = disabled, pulse = 20 ms  
      Max RA duration = 2500, Max DEC duration = 2500, DEC guide mode = Auto  
      RA Guide Speed = 7.5 a-s/s, Dec Guide Speed = 7.5 a-s/s, Cal Dec = 11.9, Last Cal Issue = None, Timestamp = 07/04/2021 22:19:33  
      RA = 10.16 hr, Dec = 11.9 deg, Hour angle = -0.37 hr, Pier side = West, Rotator pos = N/A, Alt = 55.8 deg, Az = 170.4 deg  
      Lock position = 1486.689, 659.999, Star position = 1486.689, 659.999, HFD = 1.97 px 
       
      Le guidage
      Là ça se complique  J'ai d'abord utilisé les paramètres que je connais pour guider mon AZEQ6, très très mauvaise idée. C'est très instable et ça fini par décrocher.. J'ai testé plusieurs paramètres et tous les algorithmes dispos dans PHD2 dont forcément celui conseillé par Ioptron (passe-bas et temps de pose assez longs), cata complète. Pour rigoler, quelques aperçus, mon ex HEQ5 faisait mieux même en sautant à plusieurs autour une nuit avec du vent :
      Passe-bas

       
      Z-filter...

       
      Resist Switch

       
      Le seul qui passe à peu près bien est à 0.5" de pose en Resist Switch, sauf que 0.5" c'est sensible à la turbu.

       
      >> Si il y a déjà quelques utilisateurs de cette monture, pourriez-vous m'aiguiller sur vos paramètres ?
      >> Idem pour les possesseurs des versions précédentes, les séries 25 ?
       
      Je peux évidemment la renvoyer en garantie mais si je me suis planté, les frais de port aller/retour de chez moi à Ioptron US en passant par la Maison de l'astro sont pour ma pomme...
       
      Merci pour votre aide !
      Jean-Marc
    • By Simon Fabre
      Bonjour à toutes et tous,
       
      Pour faire suite à ce sujet des vis pour paliers de G11:
      Voilà le réglage proprement dit, après réception des 4 vis qui vont bien.
      Cela tombe très bien, car j'ai encore eu récemment un message du Gémini ("lags") lors de ma dernière session d'imagerie lunaire.

      Donc exit les anciennes vis de serrage des paliers (3 sur les 4 ont les empreintes 6 pans massacrées):
      Démontage des moteurs et réducteurs sur chaque axe, après avoir mis la monture hors charge (contre-poids et tube démontés).
      Démontage remontage de chaque vis, l'une après l'autre, en la remplaçant par une neuve.

      Réglage du jeu en se servant du pivot offert par le palier côté moteur, et pression du second palier à la fois en direction du premier palier et en direction de la roue dentée.
      Pas super simple, mais par itérations on finit par converger. 
       
      Problème, je me rends compte que le réglage n'est pas le même freins de la monture serrés ou pas:
      Le jeu roue/vsf se réduit lorsque les freins sont lâches, à tel point que le coupleur en extrémité de la vsf ne tourne plus à la main! 
       
      Sans vraiment expliquer ça, on va tenter d'être pragmatique.
      Alors je vais régler les jeux avec la monture en condition d'imagerie!
      Remontage tube et contre-poids, équilibrage et surtout freins serrés modérément comme en imagerie.
      Et c'est parti pour le réglage.

      Attention, cela va sans dire, à ne pas complètement retirer une des 2 vsf, sinon rien ne retient la roue dentée associée...
      Même si j'ai équilibré l'ensemble on ne va pas tenter le diable!
       
      Alpha: réglage en jouant sur la pression du palier externe (loin du moteur).
      Le réglage est facile car les deux paliers sont en un seul bloc.
       
      Delta: je me rends compte que mon premier réglage était mauvais: le tube brinquebalait en delta, le jeu axial étant loin d'être nul, la vsf bougeait entre les 2 paliers.
      Reprise du réglage en poussant bien le palier externe vers son jumeau, en ajustant en même temps la pression sur la vsf.
      Le poids de l'ensemble tout monté aide bien à sentir ce que l'on fait, et à bien pousser fort sur le palier externe en direction de son homologue.
       
      Voilà un moment plus tard, le télescope est en configuration imagerie, et chaque petit coupleur en bout de chaque vsf tourne librement à deux doigts.
      En alpha ça ne bagotte pas, et en delta quand bouge la platine support de tube, il subsiste un léger jeu mais la vsf ne bouge plus axialement.
       
      Remontage réducteurs, moteurs et capots.
      A vérifier Gémini branché que tout ce petit monde tourne normalement sans résistance et ce sera tout bon! 
    • By CB7751
      Bonjour à tous.
      Un premier retour d'expérience sur cette monture, déjà quelques impressions sans être un grand connaisseur..
      Points positifs:
      - c'est un bel objet, j'aime le look global à première vue bien fini
      - livré dans une mallette de rangement robuste et bien fichue
      - impression de robustesse j'ai eu le même sentiment en passant de la HEQ5-Pro à la EQ6-R Pro, c'est un cran bien au dessus, la barre de contrepoids impressionne
      - viseur polaire électronique pour ceux qui en ont l'utilité
      - connectivité pas mal, du USB 2.0, du 12V
       
      Points négatifs:
      - pas de viseur polaire optique ni en option
      - pas de wifi possible (le module iStarFi ne fonctionnera pas) sauf à prendre la version G pour un surcoût de 500€ qui donne aussi du USB 3.0 
      - réglages azimut très limité +-4°, deux fois sur 3 sorties j'ai du pivoter le tout légèrement pour faire ma MES
      - pas de poignée pour la manipuler
      - fixation sur trépied pas très pratique il faut le dire, les vis ne sont pas très facile d'accès (perso je la laisse toujours montée..)
      - quelques finitions pas terribles, des fils exposés sans gaines ou gaines trop courtes, c'est bête
       
      Plus d'un mois après l'avoir achetée, j'ai pu l'utiliser le week end dernier.
      Voici la courbe d'autoguidage pour sa première sortie...

       
      Une cata.... je vérifie mon équilibrage, ma MES... tout ça deux fois. rien à faire. Autoguidage ou pas les étoiles font des sauts de plusieurs pixels.. je laisse tomber et je remballe tout.
       
      Le lendemain je me décide à regarder le réglage de la vis sans fin en RA, la procédure est dans le manuel, monture sans charge je serre 1/8 de tour environ, j'entend que ça gratte donc je desserre un peu et nouvel essai en réel.
      Impeccable je fais une première belle nuit avec un autoguidage autour de 0.6" : http://www.astrosurf.com/topic/145242-luminances-m63-m94-m100-première-lumière-rasa11-et-cem70/ 
       
      Nuit suivante je change la caméra pour faire la couleur de ces galaxies. Et cette fois en DEC ça ne va pas... la monture met régulièrement 3 impulsons avant de réagir et part trop fort à l'inverse et en RA c'est imparfait aussi.. RMS total autour de 1.3" proche du zénith sur les mêmes cibles que la veille... mon HEQ5 en surcharge avec le C9 faisait mieux...
      Je touche donc à la vis sans fin en DEC, et je me rend compte que la vis sensée bloquer le réglage n'est pas du tout serrée.. ça ne change rien, j'avance un peu idem, je recule un peu idem, x fois... j'ajoute un peu de tension sur la courroie idem.. entre chaque opération un calibrage de l'autoguidage, par -3°C dehors..
      Je décide de pointer une autre cible qui a besoin de moins de précision NGC7023 http://www.astrosurf.com/topic/145374-ngc7023-nebuleuse-de-liris et finalement sur cette cible l'autoguidage est acceptable à 0.8".
       
      Entre temps quelques échanges de mail avec le revendeur qui me conseille de contacter aussi iOptron pour avoir leur avis (mail envoyé lundi sans réponse à ce jour)
      Je suis pas chiant je peux encore tripoter les vis sans fin, j'ai aussi une marge de manoeuvre avec l'équilibrage j'ai fait un contrepoids qui équilibre parfaitement le RASA aussi quand il pointe au zénith..... mais si vous avez des idées sur des méthodes pour régler les vis sans fin je suis preneur.
      Je me dis si dans 2 ou 3 nuits de galère j'ai pas réglé ça je dépose la monture chez le revendeur et je le laisse gérer dans le cadre de la garantie. J'ai encore l'EQ6-R et des setup possibles plus léger si ça doit prendre du temps pour avoir un produit qui fonctionne comme il devrait.
      En voyant le forum CN où il y a aussi beaucoup de soucis rapportés sur cette monture j'ai envie de vous dire ne l'achetez surtout pas pour l'instant... vraiment.
       
    • By Nathanael
      Bonjour à tous,
      *J'ai fait aluminer ce 250 pour la première fois en 92 quand je suis parti au service militaire (oh le vieux!) www.flickr.com
      Et depuis, il a subi des modifications "mecatroniques", notamment l'autoguidage et le rembobinage automatique du secteur lisse.
      J'ai fait hier, sous la pleine lune, un petit time lapse de l'engin en fonctionnement Pour les bricoleurs, notez le rembobinage du secteur toutes les deux heures environ et le va et vient du contrepoids
       
      J'ai fait 1200 images de 20s en jpg avec sharpcap, la 224mc et l'objectif d'origine, monté la vidéo dans virtualdub.
      [Résolu: -> virtualdub2, merci @David2010 ]  Je bute sur un problème de compression. Vous avez ci-dessous le gif de 20 mo mais l'avi non compressé fait 1go. Comment on fait? mp4? Comment, avec quel logiciel? Merci par avance!

      Nathanaël
       
       
      23/03 épisode 4 : vue du contrepoids
       
      La vidéo mp4
       
       
      20/03 épisode 3 :
       
           La vidéo mp4
       
       
      10/03, épisode 2 : l'éclairage erratique du début correspond au réglage du télescope sur la cible de la nuit avant les poses. En étant observateur, on peut deviner dans quelle constellation
       
          La vidéo mp4 4Mo
       
       
           La vidéo mp4 2Mo
       
    • By Chani11
      Bonjour,
      Depuis quelques séances, mon autoguidage est devenu calamiteux J'utilise depuis mi-2016 le système Lacerta MGEN 2 sur une lunette de 60mm. Ce système autonome (pas d'ordi ) fonctionne à merveille et je n'ai jamais eu de problèmes auparavant. A l'APN en CP, mes temps de pose sont en général de 5 minutes quand le ciel est clair sans lune.
      J'ai d'abord soupconné le vent, puis l'équilibrage du tube. Ce n'est pas ça. J'ai vérifié les paramèrtres de guidage sur la raquette de commande, ils n’avaient pas été modifiés depuis que tout marchait bien. Je les ai optimisés un peu, mais cela n'a rien changé.
      J'ai également soupçonné le suivi de la monture, mais à très fort grandissement (barlow 2,7x + caméra planétaire et ROI), je n'observe aucun à coup juste une faible dérive due à l'erreur périodique.
      Voici la signature de 80% de mes images, ici pose de 2 minutes, cela ne ressemble pas à une dérive régulière qu'on pourrait attendre de l'absence d'autoguidage.
       

       
      Si parmi vous, un utilisateur de ce système a des idées à me proposer, j'en serai bien entendu râvi
       
      Durant les 8 heures de poses sur les deux dernières nuits, j'ai pu sauver un peu plus d'une heure et obtenir ça
       

       
      Ça casse pas trois pattes à un canard (pauvre bête !), mais je ne me serai pas gelé le cul pour rien
       
      Un grand merci à vous
       
  • Upcoming Events