gagarine

Reparer la motorisation d'une monture Taka EM2

Recommended Posts

il y a 10 minutes, olivdeso a dit :

D'ailleurs si tu commute l’interrupteur S2, ça devrait inverser les pins 3 et 4 et les sorties correspondantes et faire tourner le moteur d'un pas

Quand je commute cet interrupteur ca inverse bien les tensions des bornes 3 et 4 TD62004

 

Mais le moteur ne bouge pas d'un pouce

Edited by gagarine

Share this post


Link to post
Share on other sites
Advertising
By registering on Astrosurf,
this type of ad will no longer be displayed.
Planetary Astronomy
Observing, imaging and studying the planets
A comprehensive book about observing, imaging, and studying planets. It has been written by seven authors, all being skillful amateur observers in their respective domains.
More information on www.planetary-astronomy.com

oui effectivement avec le réducteur intégré on ne va pas le voir...

24 pas par tour réduit de 500 fois, ça fait 0,03 degrés...

 

Bon bilan pour le moment ça semble venir des sorties 11 et 12 de l'oscillateur qui ne bougent pas. Elles sont à 0?

 

Est ce que ton multimètre à une fonction pour mesurer les fréquences symbole Hz probablement ?

 

edit : pour info le moteur est en 12V donc ce n'est pas lui qui va griller si on met du 12V. Le seul qui puisse griller dans ce cas c'est l'oscillateur.

 

edit 2 : un truc qui me plait moyen sur les photos : nettoyer au cutter entre les 2 pins pour être sur qu'il n'y ait pas de court circuit ici

 

image.png.945e8873d0baf83bfed35449cb17cda2.png

Edited by olivdeso

Share this post


Link to post
Share on other sites

Conclusion : à priori c'est un problème  des étages de réduction en fréquence du TC5036

 

-> idée : tu peux vérifier la pin 14 de l'oscillateur TC5036 : c'est le reset. MAIS si il est actif, il resete toutes les sorties SAUF la pin Q4 qu'on avait mesuré en premier

 

(j'ai du mal à voir si cette pin 14 est en l'air ou connectée à une piste sous le composant. Elle pourrait être utilisée pour stopper le suivi par exemple.)

 

image.png.c5c3f8d3dfdbf55f26be6ceb7c846884.png

Edited by olivdeso

Share this post


Link to post
Share on other sites

Merci beaucoup Olivier pour ton aide, je tente ca en revenant du boulot.

Share this post


Link to post
Share on other sites
Il y a 10 heures, xs_man a dit :

pour quelle utilisation cette monture ?  Simple visuel, imagerie lunaire/planétaire/solaire,

CP en poses courtes, CP en poses longues ?

Salut Alberic, plutôt visuel. Je ne sais pas si c'est top de l'utiliser pour la photo.

Share this post


Link to post
Share on other sites
Il y a 6 heures, gagarine a dit :

Merci beaucoup Olivier pour ton aide, je tente ca en revenant du boulot.

 

je t'en prie

 

(gros) point positif : l'oscillateur oscille bien, donc il y a de l'espoir. Et on a pu le constater même avec un simple multimètre

point négatif : la sortie Q4 oscille bien, mais pas les sorties Q15 et Q16 qui nous intéressent

 

de là 2 possibilités :

- soit ce circuit intégré oscillateur/diviseur de fréquence est grillé, mais très peu probable qu'une partie fonctionne et l'autre soit grillée.

- soit les sorties au delà de Q4 sont bloquées par la logique du circuit intégré. Et effectivement on voit bien sur le block diagram que le signal reset bloque les bascules de toutes les autres sorties mais pas la Q4. C'est donc un bon candidat.

 

Fonctionnement résumé du truc : le quartz est branché entre Xt et Xt/ (on dit Xt "barre"  i.e. Xt inversé) à gauche. Il est branché entre l'entrée et la sortie d'un ampli inverseur (le triangle (ampli) avec un petit rond en sortie (inverseur)) et si le déphasage entre l'entrée et la sortie de l'ampli est suffisant, ça oscille (l'entrée de l'ampli essaie de ratraper la sortie mais en retard et n'y arrive jamais). Ce déphasage est créé par l'ensemble quartz et les 2 petites capas de charge.

 

De là on a un signal qui ressemble à une sinusoïde tronquée qui rentre dans un étage trigger de shmidt (un ampli inverseur avec de l'hystérésis) pour transformer ça en signal carré, puis un deuxième ampli inverseur pour bufferiser. à partir de la on a un signal d'horloge propre qui peut attaquer les étages de division de fréquence.

 

Les étages de division de fréquence sont des bascules D montés en flip flop. Une bascule D est une mémoire à 1 bit. Quand un front montant (ou descendant suivant le type de bascule) d'horloge est appliqué sur l'entrée clock, elle mémorise l'entrée D qu'on retrouve en sortie Q La bascule D a aussi une sortie inversée Q/ (Q barre).

 

Ici les bascules D sont montée en "flip flop" (=Toggle ou encore bascule T) : la sortie Q/ est rebouclée sur l'entrée D, ce qui fait que à chaque front montant d'horloge la sortie change d'état logique. celà fait donc un diviseur de fréquence par 2. La première bascule Q1 a aussi pour effet de fournir un signal carré, ce qui n'est pas forcément le cas au départ.

 

La sortie Q4 est donc un signal carré (d'où les 3V mesurés au voltmètre) à la fréquence du quartz divisé par 2^4 (2 puissance 4 = 16)

 

les sorties qui nous intéressent Q15 et Q16 devraient être des signaux carrés a des fréquence de

- pin11 Q15 : fréquence_quartz/2^15

- pin12 Q16 : fréquence_quartz/2^16

 

image.png.7f4497ad1a0cbc7d0b61921dc5b72f05.png

 

Il faudra aussi regarder les pins 6 "Phi" et pin 9 FC au cas où. Pareil elle pourraient bloquer les sorties qui nous intéressent

Q12 et au delà.

Phi est une entrée tirée à la masse en interne si elle n'est pas connectée en externe, ce qui nous irait bien : elle doit être à 0. Et FC est une entrée/sortie suivant ce qu'on veut en faire. SI elle est non connectée en externe, on aura un signal d'horloge dessus, c'est la sortie de Q9 si l'entrée Phi est en l'air.

Pareil il vaudrait mieux qu'elle soit non connectée. Il me semble que c'est le cas sauf piste sous le circuit qu'on ne verrait pas

 

résumé :

- vérifier pin 14 RESET devrait être à 0V

- vérifier pin 6 Phi devrait être à 0V

- vérifier pin 9 : devrait osciller si les 2 précédentes sont bien à 0. Mais je soupçonne un problème dans la raquette ou son jack qui forcerait un des deux à 1 = +6V

Edited by olivdeso
  • Like 2

Share this post


Link to post
Share on other sites
Il y a 21 heures, olivdeso a dit :

- mesure la résistance entre les fils rouge (le+6V) et chacun des autres fils d'autre couleur : chaque fil correspond à en bobinage du moteur. Tu devrais trouver quelques Ohms et environ la même chose pour chaque.

Bon alors j'ai repris les mesures. Je constate qu'en mesurant la résistance entre les deux fils rouges qui connectent le moteur à la carte, j'ai une résistance identique à celle du court circuit, alors que sur les autres fils j'ai une resistance d'environ 70 ohm

  • Like 1

Share this post


Link to post
Share on other sites
Il y a 9 heures, olivdeso a dit :

- vérifier pin 14 RESET devrait être à 0V

- vérifier pin 6 Phi devrait être à 0V

- vérifier pin 9 : devrait osciller si les 2 précédentes sont bien à 0. Mais je soupçonne un problème dans la raquette ou son jack qui forcerait un des deux à 1 = +6V

Alors le pin 14 est bien à 0, le pin 6 n'est pas complètement à 0, proche de 1v et le pin 9 est proche de 6v (mais je ne sais pas si mon voltmetre peut détecter une oscillation).

Share this post


Link to post
Share on other sites
Il y a 22 heures, gagarine a dit :

Bon alors j'ai repris les mesures. Je constate qu'en mesurant la résistance entre les deux fils rouges qui connectent le moteur à la carte, j'ai une résistance identique à celle du court circuit, alors que sur les autres fils j'ai une resistance d'environ 70 ohm

 

OK très bien, tout est bon, moteur OK

 

Il y a 21 heures, gagarine a dit :

Alors le pin 14 est bien à 0, le pin 6 n'est pas complètement à 0, proche de 1v et le pin 9 est proche de 6v (mais je ne sais pas si mon voltmetre peut détecter une oscillation)

 

OK ça ne me parait pas anormal à première vue (malheureusement). Je vérifie et je te dis.

Le voltmètre ne peut pas vraiment détecter une oscillation en général, mais il va faire une "moyenne" sur une période (d'intégration) et si le signal est carré et à ne fréquence suffisante, alors tu aura à peu près la moitié de la tension max. Mais si la fréquence est trop basse ou trop haute ça ne fonctionne pas évidement et il faut des outils plus adaptés. La on fait au mieux avec ce qu'on a sous la main...

Edited by olivdeso

Share this post


Link to post
Share on other sites

C'est un post passionnant, je n'y comprends absolument rien, mais je le suis avec un grand intérêt. Et puis quel suspense !! La monture va-t-elle être réparée en direct sur Astrosurf ? Bravo les gars :-)

Share this post


Link to post
Share on other sites

Si  Phi est à l'état bas, alors Fc est une sortie, la sortie de Q9 inversée. C'est ce qu'on veut. On devrait avoir un signal carré dessus la fréquence du quart divisée par 2^9

(sinon Fc serait une entrée pour une clock annexe, l'entrée de Q9)

 

 Phi est tiré à la masse en interne par une résistance de 200Kohms ce qui est cohérent avec les 1V que tu mesure.

Le max de l'état bas garanti à 5V d'alim est 1,5V, donc avec 1V et 6V d'alim on a vraiment de la marge, pas de doute c'est bien l'état bas.

 

-> donc les 2 entrée vérifiées Reset et Phi sont bien au niveau attendus.

 

donc c'est embêtant...tout à l'air nominal mais rien qui bouge. à première vue le 5036AP à l'air HS, mais il faut se méfier des impressions et toujours vérifier quelque soit la science...le truc est peut être bloqué par autre chose...

Là il va falloir mettre un oscilloscope dessus.

 

Tu me MP si tu veux.

 

Edited by olivdeso

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now