Sign in to follow this  
Pierro

Transformer une Toucam Pro II en SPC 900 : ca marche !!!

Recommended Posts

Hier soir, je me balladais sur le net pis via un lien de webastro, je trouve un bon site web (anglophone excusez du peu) expliquant qu'une toucam pro 2 pouvait recevoir le firmware de la spc 900 et devenir celle-ci pour de bon, ainsi qu'utiliser les nouveaux drivers philips etc...

Ok c'est parti... courage fuyons
je vais sur http://home.versatel.nl/m.m.j.meijer/D_I_Y/spc900nc.htm
je télécharge le firmware de la spc 900 dispo sur le site...
j'ouvre négligemment Wrcmac (cf l'excellent site d'Etienne Bonduelle) je télécharge le firmware dans la caméra... tout se passe bien
et là... patatra, plus d'image... la caméra ne réponds plus...
Bon pas de panique....
je vais sur le site de philips, je télécharge les pilotes (pas glop le site de philips, vraiment pas intuitif...)
je débranche la cam, j'installe les pilotes, tiens fo rebooter ??? merci windows
hop de retour sur le bureau, je branche la cam et ... rien...
bon pas de panique , un petit tour dans le gestionnaire de périphériques (touche windows + touche "pause")
hop la cam est bien reconnue mais y a un point d'interrogation (drivers philips... :malade: )
je débranche la cam, j'attends que windows se calme (nonnnnnnnnn un nouveau périphérique on m'avait jamais fait le coup !!!)
je rebranche la cam et là ooooh miracle !!! ca marche !!!!!


Bref maintenant j'ai une belle SPC-900 toute neuve

J'allais pas m'arrêter en si bon chemin tout de meme ... alors quelques essais...
maintenant que le transfert entre les 2 firmwares est possible je me suis amusé à comparer la toucam et la SPC900 (enfin par rapport à leur firmware et aux drivers)
Et... force est de constater que chez Philips on préfère améliorer firmware et drivers et vendre une nouvelle caméra avec un nouveau plastique plutôt que de livrer des nouvelles versions pour un produit, car avec la même caméra physiquement parlant, l'image avant et apres n'a plus rien à voir...
Avec le firmware de la spc900 la caméra donne un rendu proche de ce qu'on trouve sur un camescope bas de gamme (ce qui est toutefois bien mieux qu'une webcam de base) le bruit a été drastiquement éliminé, je ne sais pas trop comment ils font, mais meme dans le noir avec juste la lumière de l'écran ca marche, c'est beau et c'est fluide !!!
Le rafraichissement monte jusqu'à 60 images / seconde en 640x480 mais je n'ai pas vu d'amélioration de la fluidité par rapport au mode 30 images / seconde.
Le rêglage "tout auto" fonctionne très bien dans une utilisation de tous les jours, la luminosité auto fonctionne très bien et est super réactive les couleurs sont plus vives, et un filtre auto "nettoie" l'image et la lisse (oups ca pour les planètes je ne sais pas si ce sera très bien...)
En bref, foncez, ca marche d'enfer, c'est gratos et le résultat est bien au dela de mes plus folles espérences...

Je n'ai pas essayé d'installer ce firmware sur l'ATIK 2HS N&B car jene sais pas trop bien le résultat avec la matrice n&b... et je perdrai le RAW... mais je vais peut etre tenter ? je ne voudrais pas cependant flinguer une caméra... on verra


voili, j'espere ne pas avoir été trop long, bon ciel a tous

Share this post


Link to post
Share on other sites
Publicité
En vous inscrivant sur Astrosurf,
ce type d'annonce ne sera plus affiché.
Photographier la Lune
Guide complet pour la photographier de la Lune.
Information et commande sur www.photographierlalune.com
Ouais, pourquoi pas...

POur ma part, j'ai mis ma cam en mode RAW et c'est amplement suffisant. Je trouve l'image très fine et le rendu des couleurs beaucoup plus naturel.

Share this post


Link to post
Share on other sites
Ah bon ??!!

Ben je m'en vais peut etre essayer ça, quitte à revenir en arriere avec Wrcmac si ça créé d'autres problèmes...

Apparemment, on pourrait aussi faire ça pour une 740 !! (Vesta Pro ? ).

Merci Pierro pour le lien.

BGI

[Ce message a été modifié par BGI (Édité le 25-04-2006).]

Share this post


Link to post
Share on other sites
OOOps, !!!

Autant pour moi, la Vesta c'est 690, pas 740 !!!

Voilà ce qui arrive lorsque l'on veut poster plus vite que son...Nombre ...

Sorry,
BGI

[Ce message a été modifié par BGI (Édité le 25-04-2006).]

Share this post


Link to post
Share on other sites
mais dis moi Pierro, pour que je comprenne, pkoi tu as fais çà au lieu de flasher les macros pour utiliser le RAW?
GG31

Share this post


Link to post
Share on other sites
Parceque l'association du nouveau firmware et du nouveau driver de la spc 900 permettent d'avoir bcp plus d'images par seconde sans dégradation
du coup pour un temps de capture identique on a plus d'image , ou encore on peut réduire le temps de la capture avec quand meme bcp d'images
le reve c'est un firmware de SPC900 avec mode raw ou couleur optimisé à la Bond'
enfin j'dis ca j'dis rien

Share this post


Link to post
Share on other sites
Salut Pierro,

très bien ton trip flashouillage de webcam, ça donne des idées... et des questions...

L'augmentation du framerate vient :
- du passage du controlleur de la webcam en USB2 ???
- d'une compression plus élevée dans le tuyau???
- Obiwan Kenobi???

Est-ce que ça veut dire qie les toucII étaient déjà équipées d'un chip USB2, si oui ça vaut vraiment le coup de flashouiller on dirait.

Les codecs possibles pour l'enregistrement sont-ils toujours iyuv (ms h263) et i420 ou ont-ils changés? ça pourrait nous renseigner sur le format des données en sortie de webcam (yuv 420, codage sur 12 bits).

Share this post


Link to post
Share on other sites
Finalement cette Touc III elle est bien pour le planetaire oui ou non ?par rapport aune Touc II.
L'adatateur est le meme que les autre TOUc Philips?

Je cherche une web pour le planetaire !

Bon ciel


Share this post


Link to post
Share on other sites
mouif
deux deux chose
l'une ou webcam philips toucam 2 etait déjà usb2 mais 'bridée' a usb1 dans ce cas je marche
ou non (c'est une usb 1) et le 60 i/s sans degradation ne m'inspire aucune confiance...

faite le test suivant placé une toucam 1 ou 2 (calé sur 5i/s) devant un texte avec differente taille de carratere de façon a ce que les carracteres petit soie juste lisible. pis acceléré la cadence.
z'aller rire

Share this post


Link to post
Share on other sites
La toucam pro III 900 n'est pas en USB2....elle est seulement:
"compatible" USB 2...nuance....

...Bien lire la doc de Philips...

On en avait déjà discuté dès le premier post de Christian Arsidi avec ses premiers essais TCIII.

[Ce message a été modifié par astrovicking (Édité le 26-04-2006).]

Share this post


Link to post
Share on other sites
bonsoir,
ca marche! mais probleme!

sur iris,astrosnap et qfocus,pas moyen de lire en yuy2,marche seulement en iyuv et 60fps non disponinble.de plus c'est tout en anglais alors que si je clique sur le logo de la web situé sur la barre d'outils,le logiciel philips de config est en francais avec possibilité de choisir 60fps! sur maxdslr tout fonctionne bien! on dirait que les autres logiciel ne prennent pas en compte le driver en version fr!

Share this post


Link to post
Share on other sites
!!!!!!!!!
Bonsoir à tous,

ce soir, mise en place du firmware SPC900 dans une ATIK-2HS puis passage mode RAW noir et blanc :

impeccable, qualité bien plus grande qu'avec le driver d'origine génial, ca marche j'adore

enjoy

Share this post


Link to post
Share on other sites
C'est tentant.
Mais en ce moment je ne suis pas très chaud pour changer de firmware v uque j'ai flingué un lecteur mp3 il a quelques jours comme ça. Mais bon là ça a été testé :-) On verra ça ce week end.

Share this post


Link to post
Share on other sites
Salutatous,
Merci pour tout m'sieur Pierro, c'est super sympa tout ça qu'est c'que vous faites.
Bon trève de ... je viens de tester ça.

Test sous XP :
1-modif de la toucam pro II en SPC900 avec wrcmac Ok
2-suite à ce qu'à dit ANGE06 j'ai installé le driver english
Reboot Ok je branche la cam détection SPC900 et TUUUUUTTT
PLANTAGE DU PC et systématiquement à chaque redémarrage.
3-installation du pilote français, reboot, détection de la cam et là tout est Ok
YOUPI sous XP

Test sous WIN98SE :
Installation du pilote 98SE en français
Reboot, détection de la cam Ok
Tout fonctionne avec QCFocus, Astrosnap etc
YOUPI aussi sous WIN98SE.

Bon, c'est bien d'avoir une SPC900, reste à voir maintenant si les résultats sont vraiment meilleurs, surtout sur le ciel.
A confirmer.
Amicalement,
AG

Share this post


Link to post
Share on other sites
Bonjour
La manipe m’intéresse mais certain lien ne fonctionne pas ! Il faut aller ici : http://home.versatel.nl/m.m.j.meijer/D_I_Y/spc900nc.htm
Bon jusque la ça va, mais le driver Pb !!? le lien du site ne marche pas : http://www.p4c.philips.com/cgi-bin/dcbint/cpindex.pl?cat=PC_CAMERAS_CA&sct=WEBCAMS_SU&scy=GB&grp=MONITORS_PC_PERIPHERALS_GR&ctn=SPC900NC/00&slg=ENG&mid=Link_Software&hlt=Link_Softw are
Sur le site Philips , y pas de 900 ??

Sinon, vous utiliser bien ce .Bin (http://home.versatel.nl/m.m.j.meijer/D_I_Y/spc900nc.bin)

Pour pierro
Quel fichier tu utilises pour passer après en mode Raw ?

Share this post


Link to post
Share on other sites
Oui oui du moment que tu gardes le firmware d'origine sur ton pc

A savoir (et c'est normal) quand on fait la modif, la webcam "plante" enfin n'est plus reconnue puisqu'il faut alors télécharger et installer les drivers de la SPC900 (ben vi la toucam n'est pas compatible niveau drivers...)

Donc la modif est vraiment très sympa, j'ai pas mal bidouillé mais j'ai pas flingué mes deux webcam donc ca doit être assez peu risqué je pense

Share this post


Link to post
Share on other sites
tégéa oui ça fonctionne sur une Toucam Pro I
Je viens de le faire mais pas eu le temps de faire des tests

pour les drivers effectivement ils ne sont plus présent sur le site de Philips. J'ai d'ailleur posté un message là dessus.
Merci Gilles pour les drivers, ça marche nickel .
Donc histoire de renvoyer l'ascenceur si qqu'un a besoin des drivers de la SPC900 je peux lui envoyer par email

[Ce message a été modifié par Deneb (Édité le 15-06-2006).]

[Ce message a été modifié par Deneb (Édité le 15-06-2006).]

Share this post


Link to post
Share on other sites
les drivers sont TOUJOURS en ligne mais sur le site philips US pis faut fouiller un peu il est vrai

allez on fouille on fouille

Share this post


Link to post
Share on other sites
merci Gibé, je m'ai cassé le poil de la main et j'arrive plus à chercher .

Comment va?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this