Sign in to follow this  
baroche

coefficients RVB!

Recommended Posts

J'essaie de suivre le meilleur tuto que l'on m'a conseillé pour la calibration des coefficients RVB avec Iris. Tout à l'air simple, photo d'une feuille blanche au soleil, offset, etc, vous connaissez... mais le problème c'est qu'avec moi ça ne fonctionne pas, mes valeurs moyennes obtenues sont beaucoup trop hautes, le tuto dit que les valeurs des trois canaux rouge, vert et bleu doivent être supérieures à 500-1000 et inférieures à 3000 pour que ça soit ok... chez moi toutes les valeurs moyennes sont supérieures à 13000! rogntudju!...

Je pense que le problème vient au départ de l'image de la feuille blanche qui est soit trop lumineuse soit pas assez et c'est là que le meilleur tuto est pour le moins vague, "régler en RAW à 400IOS, une vitesse de 1/1000 ou plus rapide, un objectif lumineux, s'assurer que la photo ne soit ni saturée ni trop sombre"... le problème est là je pense? il faut contrôler l'histogramme de l'image? le cas échéant il doit être comment cet histogramme? car l'image blanche est toujours cramée, ou alors il faut vachement fermer le diaphragme ou augmenter la vitesse et l'image n'est plus blanche mais franchement grise, mais alors pourquoi dans ce cas utiliser un objectif lumineux, etc.?

Bref, je me débat pour enfin connaître ces coefficients pour bien utiliser Iris. J'ai trouvé sur le net des coefficients donnés pour mon 600D (R2,3 V1.0 B1,7)qui sont semble-t-il beaucoup trop haut car mes images sortent toutes roses avec, mais alors rose de rose, rose bonbon, pas légèrement trop rouge comme je les montre parfois ...

Que se passe-t-il siou plaît ...

Share this post


Link to post
Share on other sites
Advertising
By registering on Astrosurf,
this type of ad will no longer be displayed.
Planetary Astronomy
Observing, imaging and studying the planets
A comprehensive book about observing, imaging, and studying planets. It has been written by seven authors, all being skillful amateur observers in their respective domains.
More information on www.planetary-astronomy.com

bjr,
a la prise de vue, verifie sur l'APN que l'histogramme de la photo de la feuille blanche est bien au centre de l'échelle.
Pas à gauche, pas à droite.

JPG

Share this post


Link to post
Share on other sites
Ok merci beaucoup jpg&mtl, ouf! donc l'histogramme doit être au milieu, mais l'image est dans ce cas grise et non blanche c'est ça? alors pourquoi ne le précise-t-on pas dans les tutos??? rontudju!... et comment obtenir ce résultat avec l'exemple sité dans le meilleur tuto, soit 400iso au 1/1000 avec un objectif lumineux? ... donc il faut vachement fermer l'objo ou augmenter la vitesse, je vais ré-ré-ré-ré-ré-essayer! ...

merci!

Share this post


Link to post
Share on other sites
Baroche,

Ne suit pas les indications à la lettre. Si ton histogramme est trop haut, baisse le temps de pose ou les ISO et ca marchera aussi bien. Le flat doit être assez élevé en valeur mais pas trop car certains pixels (ou pire une des couches RVB) pourraient saturer. C'est surtout ce point qu'il faut regarder.

En plus, tu ne cherches dans ton cas que des coefficients, tu peux donc tout te permettre du moment qu'il n'y pas de saturation.

Share this post


Link to post
Share on other sites
Bon, je viens de refaire un essai, histogramme au milieu, ce qui à été possible en fermant à 14 et au 1/1250 à 400iso, pourtant le soleil n'est pas spécialement fort (pourquoi on préconise un objectif lumineux alors?)... l'image est bien grise mais les valeurs moyennes sont encore beaucoup trop hautes comme le montre ma capture d'écran ... en arrière-plan c'est l'image de ma feuille blanche et non l'offset , donc mon blanc est au départ bien gris et les valeurs sont encore bien trop hautes, est-ce qu'il faut obtenir un noir de la feuille blanche pour que ça marche? ...


ou alors je suis une sacré tanche!

Share this post


Link to post
Share on other sites
Merci Tyco ce qui m'énerve le plus c'est que les différents tutos et vidéos qui expliquent cette opération présentent ça comme une simple routine! on voit même sur une vidéo un mec qui pose négligemment une feuille quelconque par terre, qui tient son APN d'une seule main pour photographier sa feuille blanche sans vraiment cadrer ni rien régler et qui passe ensuite à l'ordi et obtient du premier coup les valeurs demandées! pis moi je galère et ça me donne des résultats bidons! ...
ça m'les casse! ...

Share this post


Link to post
Share on other sites
salut pierre-alain
pourquoi tu n'essaies pas sur une feuille blanche à l'intérieur de la maison sans lumière artificielle?
polo

Share this post


Link to post
Share on other sites
Salut Polo, les tutos disent de prendre l'image de la feuille au soleil! ... bon, j'ai calculé un coef avec des moyennes un peu trop hautes et le résultat est assez proche de ce que j'ai trouvé sur le net... j'ai calculé R:2,35 V:1,00 et B:1,41, bon... le problème c'est que quand j'applique dans Iris ce coefficient à une image RAW qui est verte par nature, j'obtiens un résultat rouge!!! alors que l'image devrait montrer des couleurs assez fidèles avec le coefficient non??? c'est bien le but du coefficient??? autrement il sert à quoi ce coefficient si on doit trouver les bonnes couleurs en tâtonnant à la main???

on n'est pas sortis de l'auberge!...

Share this post


Link to post
Share on other sites
salut Pierre Alain
ta couche bleue est à 3163 et le tutu dit qu'il faut être en dessous de 3000, ce n'est pas ça qui cloche?
J'ai le même souci que toi, faudrait aussi faire une photo plus tôt le matin, mais ce que je ne comprends pas comment, en gros: on peut être surex, et on nous invite à prendre un objectif trés ouvert...
Bonne journée Pierre Alain
Salut à tous
GG

Share this post


Link to post
Share on other sites
Bonjour,
Attendez juste un peu de logique SVP

1:c'est comme toute photo classique il ne faut pas être SUREXPOSE donc on joue sur le couple diaph/vitesse ou on se mets en AUTO mais avec fichier RAW) et à la valeur ISO que l'on va utiliser en astro.

Comme l'offset est vers 2048 sur un 550D, on essaye TOUT SIMPLEMENT d'obtenir une valeur moyenne de l'image dans les mêmes valeurs (3000, 4000) et pas 30 000 (surexposé) ou 10 (sous exposé)

2:sur ton image d'écran
les seuils de visu sont de 0 à 16383

la valeur de ton image affichée est de 2700, 3600, 3100 pour les couches

donc dans l'échelle demandée 0 à 16383 c'est quand même FRANCHEMENT NORMAL qu'une valeur de 3000 soit cadrée vers la GAUCHE donc soit sombre....

Si pour une valeur de 3000 tu veux que ton image:
soit plus sombre tu demandes à IRIS un seuil de 0 à 32000
soit plus claire tu demandes à IRIS un seuil de 0 à 5000 par exemple

Sur le compteur de vitesse de ma 2 cv, le 100 km/h est à 99% à droite du cadran
Sur le compteur de vitesse de mon Aston Martin DB7, le 100 km/h est au 1/4 du cadran.

Ce n'est donc qu'un pb classique d'affichage de valeur sur une échelle à adapter (flat, histogramme, cadran auto, température...)

Suis je clair

Share this post


Link to post
Share on other sites
Tu es très clair bboulant merci, mais je n'ai rien compris! ...

au final, pourquoi mes images sortent toutes rouges quand j'applique le coefficient RVB, que ce soit celui du net, soit celui que j'ai calculé et qui en est approchant? il me semble que ce coef est fait justement pour obtenir une image aux couleurs assez fidèles par rapport à la RAW d'origine toute verte avec Iris, non?

Share this post


Link to post
Share on other sites
d'accord avec Pierre Alain, on insiste, on fait ce qu'il faut, et c'est toujous trop vert, où est le piége alors, là je ne vois pas...
cordialement
GG

Share this post


Link to post
Share on other sites
Non Gérard, trop vert c'est normal car il y a deux photosites verts pour un rouge et un bleu . En format RAW, Iris ouvre l'image totale si je puis dire, donc elle est trop verte ... le coefficient RVB est semble-t-il destiné à régler la colorimétrie de l'image en rajoutant du rouge et du bleu à l'image qui est trop verte. Mais chez moi l'image vire au rouge avec le coef!

Share this post


Link to post
Share on other sites
Et comme les images valent mille mots...

aspect d'une image RAW brute ouverte avec Iris, elle est toute verte et c'est normal ...

l'image après application du coefficient RVB (R2,3 V1,0 B1,7) et c'est le désastre! j'aime bien le rose mais pour m42! ...

l'image telle qu'elle devrait à peu près être...

Share this post


Link to post
Share on other sites
Ah! c'est beau la Suisse!...Sinon, essaye de jouer sur tes coeff...au piff! juste pour voir ce que ça donne (par ex. baisse le rouge)
aries51

Share this post


Link to post
Share on other sites
Bonsoir,

Je pense que là, il faudrait nous expliquer la manip depuis le début.
Parce que ces photos ne sont pas des photos en couleur, mais des photos monochromes ( 1 en dégradés de vert et l'autre en dégradés de rose ).
Wait and see
Amicalement,
AG

Share this post


Link to post
Share on other sites
oui je sais Pierre Alain, que l'image est verte quand ou ouvre une image dans iris et sans avoir au logiciel ou quoi que ce soit.
Mais quand on lui donne les cooéficients avec justement les valeurs du rouge, du vert et du bleu qui vont bien, et bien pour moi c'est pareil...
désolé

Share this post


Link to post
Share on other sites
Merci Aries, j'ai essayé plein de coef différents mais ça ne marche pas ...

En effet AG ces images paraissent, ou sont monochrome et tu me mets un doute, j'essaie quelque chose et je reviens plus tard! ...

Share this post


Link to post
Share on other sites
Celle en vert est bien en couleur, la rose est ...bizarre ...

[Ce message a été modifié par astrovicking (Édité le 23-09-2012).]

Share this post


Link to post
Share on other sites
En fait AG je ne vois pas ce qui cloche, je viens de réessayer avec une RAW brute du ciel, je décode l'image RAW, elle s'ouvre en noir et blanc, je convertis l'image, elle s'ouvre avec une dominance verte, c'est normal, j'applique le coefficient RVB et elle devient toute rose et monochrome! ... en fait astroviking à raison, regarde mon image verte ci-dessus, elle n'est pas monochrome mais la rose si! je ne sais pas ce qui se passe!...

merci en tout cas pour votre aide ...

Share this post


Link to post
Share on other sites
Re,
--------------
Tu es très clair bboulant merci, mais je n'ai rien compris!
--------------
Ok, je laisse donc tomber, j'ai déjà perdu trop de temps pour un truc si scolaire

Mais avant de sortir, comme on dit "les images valent mille mots..."

Voila mon cygne pris de jour, 100 ISO, en Raw(je ne shoote qu'en RAW), chargé dans IRIS

Voila la sortie corrigée et ajustement des seuils .

Notez bien que c'est bien du CR2, que l'image est couleur (48 bits) dans les 2 cas, qu'on ne me dise pas que je suis de mauvaise fois ou que que ...que ..que

Exemple finalisé avec:
1:la commande 'dark' appliquée sur une zone du bec qui est vraiment noire(faut quand même bien dire à Iris ce qui est noir dans une image, je ne vois pas comment il pourrait le deviner !!),

2:ajustement des seuils (voir explications plus haut de quelques messages) pour améliorer la visualisation

3:sortie en jpeg


Bye et bon courage

Share this post


Link to post
Share on other sites
Bon, on va y aller plus doucement.
Dans Iris, tu ouvres le menu "Fichier",
tu choisis "Charger" et dans type tu sélectionnes "Photo" (cr2 ou crw)
Et pis c'est tout !
L'image qui s'ouvre est déjà convertie par Iris !
Un réglage des seuils (ou auto) pour bien visualiser l'image.
Et c'est là qu'on peut appliquer les coefs.
Menu "Photo numérique" "Balance RGB" et on entre les coefs R G B.
Ok ?
Allez, on s'y recolle
AG

Share this post


Link to post
Share on other sites
Désolé si j'ai pu te vexer bboulant, ce n'était évidemment pas ce que je souhaitais ... merci en tout cas pour le temps que tu m'as consacré, c'est vraiment sympa ... "je n'ai rien compris" était une plaisanterie pour dire que j'ai du mal à suivre ... en fait tu as raison, c'est probablement du scolaire, le problème est justement qu'il faudrait que je suive des cours, je n'y pige que dalle en ce qui concerne les seuils de visualisation notamment, je ne sais pas qu'il faut renseigner Iris sur ce qui est noir, la base m'échappe, ce n'est pas inné, ça doit s'apprendre et c'est ce que j'essaie péniblement de faire! ...

donc il ne suffit pas d'appliquer le coefficient RVB pour que les couleurs d'une image devienne potable, ce n'est pas si simple? bon ben, je vais voir pour la suite mais j'en ai un peu marre de tâtonner et d'essayer de m'en sortir simplement avec des tutos et votre aide néanmoins précieuse évidemment ... le secret est de suivre des cours ou alors qu'une personne qui maîtrise, du genre de bboulant, me montre les différentes étapes à suivre mais en direct, sans l'intermédiaire d'un forum ou de tuto qui ne permettent pas d'avancer bien vite...

Et ton cygne est magnifique ...

Share this post


Link to post
Share on other sites

c'est un signe que ça marche pierre-alain la démonstration par l'image!
tu n'as pas de cygne dans ton beau pays de suisse : au bord du lac
léman......
je me moque pierre-alain: mais c'est bizarre ton histoire
polo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this