Sign in to follow this  
Philippoïde

ASI 120MM : trame in air

Recommended Posts

Je soumets à la sagacité des pros de l'imagerie et des caméras CMOS ou autres ce petit test que j'ai fait avec ma récente ZWO ASI 120 MM

Il s'agit de simples flats : 1 et 100 frames
la taille d'origine est 1280x960. Les 2 premières images sont donc recadrées pour ne pas prendre trop de place.
Les suivantes sont obtenues par réduction avec échantillonnage "au plus proche" c'est à dire non bilinéaire ou bicubique. On a un effet de moiré qui révèle bien la trame
Enfin, en bas, le spectre de puissance obtenu par FFT et qui montre un caca fréquentiel pas tres aléatoire
(Merci à nebulium d'avoir mentionné dans un autre fil le logiciel fitswork que je ne connaissais pas. Je ne sors pas beaucoup)

Mon questionnement est le suivant : Est-ce que c'est grave docteur et suis-je tombé sur une bouse ?

je précise que j'ai fait ce constat sur 2 pc différents, à différentes températures, avec différents cables USB, dans différentes tailles d'acquisition (1280x960 ou autres), dans différents formats video (AVI et SER) et différents formats d'images (PNG, FIT, TIF)... la trame est toujours là.

Glob

Share this post


Link to post
Share on other sites
Publicité
En vous inscrivant sur Astrosurf,
ce type d'annonce ne sera plus affiché.
Photographier la Lune
Guide complet pour la photographier de la Lune.
Information et commande sur www.photographierlalune.com
c'est un problème de soft/algo, pas hardware, non?
en changeant de logiciel ça le fait aussi?

Share this post


Link to post
Share on other sites
Hello Alain
je ne sais pas si c'est un pb hardware ou software. J'ai utilisé firecapture et le zinzin qui va avec la cam (ASI120MM Camera). Les 2 utilisent le driver ZWO et me sortent de l'AVI non compressé.

je vais regarder s'il y a d'autres logiciels de capture pour faire tourner cette cam.
Glob

Share this post


Link to post
Share on other sites
Salut,

Je ne connais pas cette caméra mais j'ai utilisé un moment une QHY5(PL1-M) qui me faisait ce genre de truc. Ça doit venir du capteur CMOS donc faut faire avec...
La solution c'est de faire des offsets ET flats. En tout cas pour du solaire en LB c'est la seule façon de se débarrasser de la trame quand on composite très peu d'images. Peut-être que pour du planétaire on peut s'en passer(mais je préférais en faire quand même).
Sur la QHY5 la trame se décalait parfois d'un pixel sans raison, d'une acquisition à l'autre ou même en cours d'acquisition, ce qui rendait le traitement assez rigolo.
Après quelques séances de franches poilades je suis passé à un capteur CCD.

Share this post


Link to post
Share on other sites
Pour levée de doute, je propose que
- tu génères dans le même format de trame, une image de test avec IRIS (Fill 1024): champ gris uniforme.
- tu l'exportes et tu la visualises dans ton format

On verra si le tramage est un artefact capteur ou affichage.

JPG

Share this post


Link to post
Share on other sites
Merci thierry et jpg

Thierry, le peu que j'ai testé avec l'offset ne me semble pas probant, mais je vais reprendre ça un peu plus serieusement dès que j'ai du temps(là je suis en pause au taf ).

Jpg, une image grise uniforme avec photoshop ça va aussi ?


Autre exemple à partir de ce fil de skywatcher : http://www.astrosurf.com/ubb/Forum2/HTML/039053.html

faites glisser une des images du Soleil sur votre bureau puis ouvrez-la dans la visionneuse de windows (si vous etes sous win). Agissez sur la taille de la fenetre pour faire varier la taille de l'image... surprise vers 50%.

Share this post


Link to post
Share on other sites
quote:
Thierry, le peu que j'ai testé avec l'offset ne me semble pas probant, mais je vais reprendre ça un peu plus serieusement dès que j'ai du temps(là je suis en pause au taf ).

Si l'offset ne résout pas ton problème alors essaye un flat.
D'ailleurs sur le fil que tu donnes en lien, skywatcher a résolu le sien avec.

Ce n'est pas toujours facile de faire de bons offsets avec ces caméras car le niveau du noir est proche de 0, en tout cas à gain faible.

Share this post


Link to post
Share on other sites
jpg, comme je m'y attendais, la génération d'une image grise sous IRIS ne donne pas ce phénomène. ( Depuis le temps que je manipule des images sur PC, ce truc m'aurait déja sauté aux yeux.)

je viens de faire des offsets (0.065s dans le noir) avec firecapture. J'ai utilisé le stack en prétraitement --> image de la somme de 100 offsets : un effet de moiré est visible (dans la visionneuse windows p. ex.)

je vais reprendre des traitements avec offset, pour voir

est-ce que le traitement "image - dark" peut se passer d'offset ?
car ça revient à : (image - offset) - (dark - offset)
et en développant : image - dark - offset + offset = image - dark

Share this post


Link to post
Share on other sites
Je déconne et merci aux intervenants

j'ai trouvé une combinaison qui semble aller :
(sujet - dark) / (flat - dark)
la plupart des cacas disparaissent. c'est juste un peu plus long et faut pas oublier le dark

Glob

Share this post


Link to post
Share on other sites
C'est marrant que tu soustrais le Dark au Flat. En principe c'est l'Offset qui est soustrait au Flat -> http://www.astrosurf.com/~buil/iris/tutorial2/doc8_fr.htm
As tu fait l'essai (Image-Dark)/(Flat-Offset) ? [te connaissant je pense que Oui ]
Mais bon, si cela donne de bons résultats alors tant mieux.

Rethicus

[Ce message a été modifié par RETHICUS (Édité le 01-02-2014).]

Share this post


Link to post
Share on other sites
De toute façon avec des temps de pose très courts le signal du noir doit être quasi nul.
Sinon c'est exactement ce que je faisais avec la QHY5 ... sauf que la trame se déplaçait sans prévenir. Du coup ça la renforçait au lieu de l'atténuer.

Enfin bien content que ça marche pour toi.

Share this post


Link to post
Share on other sites
Rethicus,
j'ai aussi testé avec l'offset et c'est moins bon.
d'ailleurs la page de buil confirme la soustraction du dark au flat.
je laisse tomber l'offset pour la raison que j'ai citée plus haut.
Glob

Share this post


Link to post
Share on other sites
ou la la, moi qui pensait acheter cette cam, interessante avec ses petits pixels,et sa vitesse,pour la lune et le soleil en continum,
je vais peut être voir pour autre chose.

J y comprends pas grand chose dans les offsets et darks, donc je vais pas m aventurer la dedans

je cherche des petits pixels 3.75, cadence au moins 30 à 60 Fps
la taille du capteur au moins comme la DMK31, il n y a pas grand chose,
la basler j peux pas, mon pc n 'est pas assez rapide,5700 tm/ dommage que la DMK 31 n a pas de petits pixels.
reste la PLBMX ou Plma , mais les inovas ont un logiciel de capture pas très soft avec les windows, je tourne en rond.


il y a aussi la PLBMX 2 mais c'est le même capteur que la ASI 120 mm
CMOS.Mais la aussi, il y aura des probleme de trames.

bruno

Share this post


Link to post
Share on other sites
Je connais des PC qui encaissent une Basler 1300-30 avec un disque a 5400tr/mn récent. Tu as fait tourner un benchmark pour voir? Essais crystaldiskmark.
Et puis toutes les cameras 1,3mpixels qui débité 30i/s en 12 bits ont le même débit. Sauf que cela n'est pas possible en usb2.

Share this post


Link to post
Share on other sites
"d'ailleurs la page de buil confirme la soustraction du dark au flat."
Autant pour moi (le pire c'est que je donne le lien, et je n'ai pas tilté du tout quand à mon erreur).
Faut que je change mes lunettes ou que je réduise ma conso de bières

Rethicus

Share this post


Link to post
Share on other sites
J'avoue avoir lu un peu en diagonale.

Voici le comportement correct d'une ASI120MM également correcte.

- pas de motif en damier et ceci quelque soit le réglage
- un effet de trame de lecture si l'on pousse à fond le Gain
(aucune gène en planétaire toutefois)
- en ciel (un peu) profond, je recommande de travailler et 16 bits et de procéder à la soustraction d'un dark
- pour le flat c'est possible aussi mais optionnel avec une si faible taille de capteur.

Dans la pratique, en planétaire, il n'y a absolument pas besoin de faire un dark.

Certains trouvent ce capteur un peu bruité;
c'est sûr que si l'on pousse le Gain à fond, le bruit se voit beaucoup.
Une caméra ciel profond est à gain fixe (disons 100 ISO) alors que l'ASI120MM a un gain réglable disons de 100 à 3200ISO !

Sauf application particulière (Uranus...) je dirais que l'optimum de Gain, en lunaire/planétaire c'est entre 60 et 75 avec un histogramme entre les 2/3 et les 95%.

Je ne sais pas si tout ceci peut t'aider...

Lucien

Share this post


Link to post
Share on other sites
Pardon, j'oubliais :

FD = 20 c'est en gros l'optimum pour exploiter toute la résolution de l'instrument, si le but c'est la haute résolution.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this