Sign in to follow this  
michelR

Problème avec AS2

Recommended Posts

Bonsoir,

J'ai fais une série d'images lunaires avec mon APN que j'ai transformé en AVI
avec PIPP.

Quand je passe à AS2 tout se passe bien jusqu'au moment ou je lance le stack, arrivé au moment de stacker les images il se bloque et n'avance plus.

Copie d'écran.

Quand je faisais ce genre de manip avec des images de mon Canon 350D j'ai
jamais eu de problème, ça ne me fait ça que depuis que j'utilise un 80D.

Y a un truc qui m'échappe mais je vois pas quoi à moins que la taille des images
joue un rôle.

Si certain d'entre vous ont la solution, je suis preneur!

Share this post


Link to post
Share on other sites
Advertising
By registering on Astrosurf,
this type of ad will no longer be displayed.
Planetary Astronomy
Observing, imaging and studying the planets
A comprehensive book about observing, imaging, and studying planets. It has been written by seven authors, all being skillful amateur observers in their respective domains.
More information on www.planetary-astronomy.com

J'ai eu le même problème avec AS!2 et mes films issus de mon IMX 178, le traitement s'arrêtait à 90% sur tout mes SER. La solution a été justement de passer par pIPP avec une sélection des 1000 meilleures images (sachant que généralement je dépasse rarement 200 sous AS!2) puis de passer le nouveau fichier réduit dans AS!2. Gérard Thérin m'avait aidé sur le forum d'en face mais nous n'avions jamais pu trouver la solution, pourtant il n'avait pas été avare de bons conseils. J'ai donc appliqué ce procédé de réduction de fichier (PIPP fait aussi bien le tri qu'AS!2), je dois remercier notre ami Luc Cathala pour m'avoir donné ce tuyau. Par contre pourquoi ne pas essayer avec du SER plutôt que de l'avi, juste pour voir ?

Share this post


Link to post
Share on other sites
En voyant ton image je me dis qu'il suffit de la cropper pour supprimer le noir...

Je fais ça avec PIPP...

Tu crope avec PIPP, les images sont moins grosses, ça passe...


S

Share this post


Link to post
Share on other sites
Merci pour vos réponses.

Wilexpel, j'ai essayé en faisant un SER à la place d'un AVI, le traitement
allait un peu plus loin mais s'arrêtait avec un message genre "AS2 halted, out off memory".

Je suis un tanche en info mais je pense qu'AS2 doit peut-être utiliser de la
mémoire RAM pour stocker son travail et que celle de mon ordi est peut-être trop petite
(en fait c'est une idée que j'avance un peu dans le vent).

La solution que j'ai trouvé c'est de réduire la taille des images en faisant
un traitement par lots sous Thoshop et là pas de soucis.

Share this post


Link to post
Share on other sites
Non ce n'est pas la mémoire, quand j'avais ce problème (réglé depuis puisque je n'ai plus la 178) mon PC avec 32 GO de RAM donc on peut oublier ce problème. De mon côté et je ne peux l'expliquer, il me semble que c'était la taille du capteur qui créait des soucis ou alors, comme c'était un prototype, la caméra n'était peut être pas finalisée et les SER mal enregistrés perturbaient AS!2 !

La réduction de mon SER original grâce à la sélection des 1000 meilleures images par AS!2 a été ma solution finale !

[Ce message a été modifié par wilexpel (Édité le 11-09-2016).]

Share this post


Link to post
Share on other sites
Bonjour,

Les limitations qui peuvent gêner :

- Un windOwS 32bits n'exploitera jamais pus de 3,5 Go de mémoire (un 64 bits est moins contraint (Tera?).

- un container AVI est limité à 2 Go (voir 4 pour certains logiciels avec une astuce).

SER permet de contourner les pbs de l'avi
Le crop des images et leur présélection peuvent réduire ET la taille du fichier ET la taille mémoire nécessaire
Un OS 64 bits avec de la mémoire Physique (8,16,32 Go) règle le pb de la taille de mémoire nécessaire

Share this post


Link to post
Share on other sites
Bonjour
Avez vous augmenter la taille des images à traiter dans le dossier AutoStakkert.ini ?
maxWidth=8000
maxHeight=6000
Bonne journée.
Luc

Share this post


Link to post
Share on other sites
CATLUC, j'avais eu un souci avec la taille de images sur AS2, mais en fait il
traitait l'image mais ne l'affichait pas en entier, là il se bloque si j'utilise les images en format natif soit 24 mégapixels.

C'est vrai qu'au départ je pense que ce truc est fait pour traiter des images de
caméras planétaires avec des capteurs contenant peu de pixels, c'est peut-être la raison du plantage.

[Ce message a été modifié par michelR (Édité le 11-09-2016).]

Share this post


Link to post
Share on other sites
Salut à tous,
Si la manip de Luc ne marche pas, alors le problème est du côté de la limitation de mémoire dans AS2. En effet, AS2 est un appli 32 bits.
Emil a prévu de passer prochainement AS2 en 64 bits ce qui devrait résoudre ce genre de problème.

Share this post


Link to post
Share on other sites
Bonjour,

J'ai eu le pb ce matin lors d'un test en voulant garder toutes les images, hors le graph après analyse était moisi, comme si une ou plusieurs images n'étaient pas éligibles pour le stack.
Comme pour toi ça calait en cours de route.
Je vois que tu as choisi 100% et que ton graph comporte une brisure nette, essaye voir un pourcentage ou un nombre d'images plus faibles ?...
Chez moi le process a pu aller jusqu'au bout de cette façon, ceci dit ce n'était pas avec un APN mais une 224, donc mon intervention ne te sera peut-être pas utile...

Gilles

[Ce message a été modifié par MEIER (Édité le 18-09-2016).]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this