Nicolas Durand

Member
  • Content count

    11
  • Joined

  • Last visited

  • Country

    France

Community Reputation

3 Neutral

About Nicolas Durand

  • Rank
    Inactive member

Personal Information

  • Hobbies
    Astronomie, Spectroscopie
  1. Wavelength Off With Demetra Profile

    Hi, In addition: 1)I tried the calibration image (vega 2_Calibration_120s_20200729_162339-1.fit) with the calibration tool and the result is OK. This differs from the "calibration.pdf" screenshot you sent. I only replaced the calibration image from the Vega observation from the setup with your image (after removing the first line and column to make the image size identical to the other image of the Vega observation) I didn't changed any process parameter (-> geometry correction is not perfect) -> The screenshot that may provide other useful informations is this same screen but after clicking on "Detection" radio button near Identification : it allow to see which lines has been detected and first theoretical line that are look. (or better : share me a wetransfer link with the observation export archive) 2) I don't think you can check the calibration quality using the target star (Vega) while you change the spectroscope configuration between calibration images acquisition and target star acquisition: -> Applying the detected calibration polynomial function onto the target (star) spectrum image in these condition is not valid. You have to don't change anything on the physical device for it can work. What you are doing here is something "coarse" that can help you for a first try and to help you to understand, learn and go on your learning progress path. But you really need to make the guiding module works to be able to check calibration using the star spectrum. Nicolas
  2. Wavelength Off With Demetra Profile

    I forgot to post the link about calibration that may help you :
  3. Wavelength Off With Demetra Profile

    Hello Dick According to your screen, the automatic calibration fail to find all the calibration lines it is looking for. -> The spectrum may not be "clear" enough (too short exposure, bad focus, ......) -> The spectrum may not contains the calibration lines that the process is looking for (do you uses the Alpy calibration module ?) To understand what is going wrong, go to the "Calibration" step and click on "Calibrate..." then "run" then check the "Detection" radio button (under the "run" button on the right side) -> You will see all detected lines in your spectrum (vertical lines on the spectrum), and you will see the lines list that the process is looking for. Each of theses last lines must be found by the process. -> Can you post a picture of this screen ? Nicolas
  4. Problem With Demetra

    Hello, sorry for the delay, - It really look like you created an "eShel" observation and not an alpy one. Can you check the observation process type ? (go to "Definition" tab -> "Context" tab then "Process XXXX" information ? If so, you have to go to session parameters and select "Alpy 600" process then create a new observation. - Processing calibration step require previous step (stacking) to be already successfully ran. (But if the observation is "eShel", it require the "blaze correction" results, for the selected order, which is impossible in your case (Alpy module)) Is the "stacking" process step successful ? - About exposures, Demetra considers that every image from the same image basket has the same exposure. It can lead to errors if you merge different exposures images inside the same basket. (I'm not sure to understand "I kept acquired calibration at differents exposures"). If you want to try different exposures, simply copy the observation you made for one exposure and change the image basket for which you want to try another exposure. - If you are still stuck, can you share me your observation export (right click on the observation -> "export") using something like wetransfert ? Nicolas
  5. Problem With Demetra

    Hello, "eShelCalibX" should be an error reported for eShel process, which is still a Demetra beta version. Can you check if the software process is set to Alpy ? ("Manage observation -> Session parameters -> Context Process" must be Alpy 600) Can you tell more about what you have done before the error showed up ? Nicolas
  6. Demetra_onglet Exploitation

    Bonjour Frédéric, 1) Tu peux "écraser" Demetra sans problème avec les différents setup existants. 2) Ton fichier comporte des caractères non standard pour du FITS (les 'é' de ton prénom, codé par '233' (probablement lié à un encodage de type "Latin1" (qui est une table ASCII modifiée)) : tu peux le vérifier avec l'outil de la NASA pour vérifier la conformité des fichiers FITS : https://fits.gsfc.nasa.gov/fits_verify.html - Demetra ne le lit pas pour une question de compatibilité avec des "vieux" fichiers FITS non conforme, qu'une vieille version de Demetra générait lorsque de tels caractères étaient présents. Cela engendrait un décalage d'octet à rattraper. Rattrapage qui ici, engendre une erreur... - Je vais modifier Demetra pour qu'il lise quand même ton fichier. Les caractères non conforme seront remplacées par des '?'. - La prochaine release devrait être disponible dans une semaine ou 2, suivant comment se passe la phase de validation dans laquelle nous sommes actuellement. - En attendant, pour faire fonctionner Demetra, tu n'as pas d'autres choix que d'utiliser des images FITS strictement conformes (sans ces caractères accentués.) Pour info, le format FITS spécifie une restriction des caractères selon la table ASCII : Nicolas
  7. Demetra_onglet Exploitation

    Bonjour Frédéric, La lecture échoue sur le fichier que tu indiques. Cela commence par une tentative de décodage d'un mot clé FITS vide... il y a déjà probablement un décalage d'octet à ce moment là, le reste n'est qu'une suite de message découlant de cette première erreur. Il n'y a rien à configurer dans Demetra pour faire fonctionner les fichiers FITS venant de Prism ou d'ailleurs, et je teste parfois le process Demetra à partir d'images d'utilisateurs acquises avec Prism. Il n'y a pas ce genre d'erreur. - C'est juste certains fichiers ? as-tu essayé de supprimer seulement le fichier offset-28 du panier des offsets ? - Quelle version de Demetra utilises-tu ? - Peux-tu partager un lien https://fromsmash.com/ (ou wetransfer, ou framadrop....) avec ton fichier "C:\Users\LENOVO\Desktop\2020-05-21 Reduction Demetra\offset-28.fits" ? Merçi Nicolas
  8. Demetra_onglet Exploitation

    Bonjour Vincent, Oui, c'est un bug côté Demetra que j'ai corrigé hier et qui apparait quand certains mots-clés ne sont pas présents dans l'entête Fits des images acquises. En attendant un nouveau setup, la seule façon d'activer l'onglet "exploitation" est d'enlever manuellement le 'T' au milieu de la date/heure du nom du fichier résultat du process. ex : "Vega_20200320T225830.fit" -> "Vega_20200320225830.fit" Nicolas
  9. Bonjour Pierre, Merçi pour la confirmation. Attention cependant, la suppression complète de ce répertoire supprime aussi la base de référence spectrale qui n'est installé que par le setup. Si tu as effacé le répertoire complet, il te faut relancer le setup (pas besoin de désinstaller avant) pour la remettre. Je prépare une nouvelle version corrigeant l'anomalie sous peu. Nicolas
  10. Bonjour, Je suis le développeur de Demetra, et à l'exemple de vos message, j'ai beaucoup de retour de problème de lancement avec cette version. Il semble qu'il y ait un problème de lecture du fichier "C:/ProgramData/Demetra/CalibrationParams.xml" pendant le lancement du programme. En attendant une correction dans le setup, vous pouvez essayer d'effacer ce fichier et de relancer Demetra. (attention, c:\programdata est un répertoire caché). Il sera recréé et devrait s'ouvrir correctement. Edit: J'ai pu reproduire et corriger l'erreur. Elle apparait si on a préalablement installé une version 4.2.2.0 ou antérieure. Un nouveau setup 5.1.2.0 est prêt. On termine une passe de validation avant de le mettre en ligne. Nicolas
  11. Bonjour Alain, Non, il n'est pas nécessaire de désinstaller l'ancienne version. Ce problème apparaît lors de l'installation ou lors du lancement de Demetra après installation ? Essaye de renommer le répertoire "c:\ProgramData\Demetra" et relancer Demetra. C'est un répertoire caché par défaut du système d'exploitation. Nicolas