Gribol

Windows - Journal Système - Niveau Critique - Kernel-Power

Recommended Posts

Bonsoir,

 

J'ai un mini-PC (VORKE V2 PLUS) depuis Juin 2018 qui pilote mon matériel astro, le tout sous Windows 10 Pro.

Tout allait bien jusqu'à présent.

Sauf que depuis Décembre 2019, j'ai de temps en temps un arrêt brutal du mini-PC (je prends la main à distance avec le bureau à distance de Windows).

Dans l'observateur d'évènements, j'ai dans le journal Système un évènement critique: Kernel-Power (Évènement 41);

 

Citation

Le système a redémarré sans s’arrêter correctement au préalable. Cette erreur peut survenir si le système ne répond plus, s’est bloqué ou n’est plus alimenté de façon inattendue.

 

- System 

  - Provider 

   [ Name]  Microsoft-Windows-Kernel-Power 
   [ Guid]  {331c3b3a-2005-44c2-ac5e-77220c37d6b4} 
 
   EventID 41 
 
   Version 6 
 
   Level 1 
 
   Task 63 
 
   Opcode 0 
 
   Keywords 0x8000400000000002 
 
  - TimeCreated 

   [ SystemTime]  2020-07-08T20:23:04.995358500Z 
 
   EventRecordID 9100 
 
   Correlation 
 
  - Execution 

   [ ProcessID]  4 
   [ ThreadID]  8 
 
   Channel System 
 
   Computer BOXASTRO 
 
  - Security 

   [ UserID]  S-1-5-18 
 

- EventData 

  BugcheckCode 0 
  BugcheckParameter1 0x0 
  BugcheckParameter2 0x0 
  BugcheckParameter3 0x0 
  BugcheckParameter4 0x0 
  SleepInProgress 0 
  PowerButtonTimestamp 0 
  BootAppStatus 0 
  Checkpoint 0 
  ConnectedStandbyInProgress false 
  SystemSleepTransitionsToOn 0 
  CsEntryScenarioInstanceId 0 
  BugcheckInfoFromEFI false 
  CheckpointStatus 0 

J'ai eu le problème:

  • 1 fois en Décembre 2019
  • 1 fois en Avril 2020
  • 2 fois sur 2 jours consécutifs en Mai 2020
  • 1 fois en Juin 2020
  • 3 fois hier 07/07
  • 1 fois aujourd'hui 08/07

 

Pour un mini-PC en service depuis Juin 2018. Donc RAS pendant 1,5 ans. Le mini-PC tourne toute la nuit pour une session d'observation automatique. Il est arrêté ensuite la journée. Je l'allume manuellement (en appuyant sur son bouton power).

Au niveau drivers, j'ai du mettre à jour le driver de la monture fin Décembre 2019, c'est le seul truc de changé récemment et qui colle avec l'apparition du premier plantage.

Il y a ensuite les mises à jour régulières de Windows que j'applique aussi.

Mais bon, un problème drivers, je m'attendrai plutôt à un truc du genre "blue screen".

 

Quand le problème apparait, le bureau à distance se fige puis indique la perte de connexion. La reconnexion est impossible car en fait le mini-PC n'est plus allumé.

Donc c'est une erreur violente avec arrêt du mini-PC.

 

Le mini-PC est alimenté avec son câble d'alimentation fourni avec, en parfait état (c'est un convertisseur 220V => 19V avec 1 ou 2 ampères, je ne l'ai pas sous les yeux là). Bon c'est un truc made in China, mais je ne vois pas trop ce qui pourrait merder.

Il est branché sur un onduleur et le tout sur une alimentation secteur.

Ce n'est pas un problème électrique car seul le mini-PC est éteint, par exemple la CCD continue de tourner avec son refroidissement actif.

 

Pour le moment, je n'ai rien trouvé de concluant sur le Net.

Il faudrait que j'essaye une autre alimentation pour le mini-PC, mais bon, je n'y crois pas trop.

Je pensais aussi à la chaleur, mais les aérations du mini-PC ne sont pas du tout obstruées et le mini-PC chauffe un peu mais sans plus. Le mini-PC est dans une grande boite plastique avec l'onduleur et les autres alimentations des autres équipements, dont le couvercle est ouvert en été pour une meilleure circulation de l'air.

 

Si quelqu'un a une idée sur le problème.

Merci.


Marc

Share this post


Link to post
Share on other sites
Publicité
En vous inscrivant sur Astrosurf,
ce type d'annonce ne sera plus affiché.
Photographier la Lune
Guide complet pour la photographier de la Lune.
Information et commande sur www.photographierlalune.com
Guest

Salut à toi

Cela me fait furieusement penser au processeur qui chauffe trop, fait tu le ménage de temps en temps, il faut parfois changer la pâte thermique de celui ci, j'ai déjà rencontré ce genre de problème, j'ai changé la pâte thermique des processeurs dont celle de la carte graphique et tout est revenue dans l'ordre, par contre moi je suis GNU/linux.Donc regarde de ce côté va savoir c'est peut être ça!!!!

Share this post


Link to post
Share on other sites

nettoyage de boitier avec un sèche cheveux ( très efficace pour enlever la poussiere) et changement de la pâte thermique par une artic silver .

Share this post


Link to post
Share on other sites

Je regarderais aussi l'intérieur: surchauffes si ventilo (et/ou pâte thermique) vieillissant(es) ? poussière? (conductrice ou à l'origine de surchauffes aussi) insectes? (ben oui, un "bug" quoi...) ou toiles d'araignées (probleme de web :D )? Je crois qu'il va falloir regarder oui... (tout ceci étant du vécu pour ma part. Pas tout ensemble ;) )

Share this post


Link to post
Share on other sites
Guest
Posted (edited)

Salut le monde

Raphael j'ai bien regardé ton lien ,effectivement c'est un problème bizarre , de plus il ne donne même pas de solutions!super!!!! mais bon déjà faire un bon nettoyage s'impose car d'après je ce que j'ai comprit le pc tourne longuement.

Ensuite voir si le problème persiste, ben sinon changer de système, de toute manière win 10 est le pire des systèmes win............... pour rien au monde je ne reviendrais sur ce système là!!!

En résumé espérons pour toi que c'est juste une histoire de nettoyage de printemps  :}

Edited by

Share this post


Link to post
Share on other sites

Bonsoir,

 

Merci pour vos retours.

 

Je ne crois pas trop à l'origine d'un problème de chauffe.

Le CPU est un Intel Core i7-8550U, cela ne chauffe pas beaucoup.

En plus la première panne est arrivée en plein Décembre, ...

J'ouvrirai le bestiot pour vérifier la poussière.

 

Un truc assez étrange est que tous les plantages ont eu lieu lorsque j'étais connecté à distance via le bureau à distance de Windows.

Le mini-PC tourne en moyenne 10h par nuit, plus en hiver. Donc le plantage intervient toujours en début de session dans les premières heures.

Après je me déconnecte du bureau à distance et je dors. Et je n'ai jamais eu de plantage du moment que j'étais déconnecté. Alors la cause liée à la chauffe et/ou la poussière, je n'y crois pas trop.

Aucun problème pendant plus de 120 nuits.

 

J'aime bien le Windows bashing, mais cela ne va pas faire avancer le schmilblick.

Il faut que je fasse des essais en collant un moniteur au mini-PC et faire des tests avec le bureau à distance.

Cela m'occupera les soirées de mauvais temps.

 

Merci.
Marc

 

Share this post


Link to post
Share on other sites

Bonjour

 

L'EventID 41 est  enregistré après le redémarrage du PC

Il sert à tenter de renseigner sur les causes (système, applicative,...) de l'arrêt inopiné.,

Mais ....

 

BugcheckCode 0

BugcheckParameter1 0x0

etc...

 

 ici le code d'erreur et ses paramètres reste est 0,  le système n'a pas pu détecter l'erreur ou bien n'a pas eu le temps de récupérer un quelconque code d'erreur.

Le plus probable est que c'est à priori bien une coupure d'alimentation du PC qui se produit.

 

Mon avis et pistes d'exploration :

Soit un composant défaillant du microPC provoque la disjonction et l'arrêt du PC

(convertisseur 19V vers tensions interne du PC par exemple, le processeur lui-même, ...)

(S'il avait une surchauffe mémoire il y aurait d'autre erreurs applicatives détectables (plantage, erreurs de données,...) et seraient visibles avant la coupure  à priori.)

 

Soit une surcharge de consommation est détectée, et là je suppose que tu pilotes peut-être ta monture via les ports USB ?

Une surconsommation au niveau des ports USB du fait de la monture pourrait être détectée et  provoquerait la coupure du PC ?

(Si c'est le cas ce serait plutôt rassurant car le PC serait alors bien conçu pour empêcher une perte des port USB).

 

La modification du pilote que tu évoque est peut-être à l'origine d'une surexploitation des ports USB, ou bien accompagnait-elle une modification du setup avec câblage supplémentaire ?

Ta monture est-elle autonome pour alimenter l'électronique de pilotage ? Ou bien  a-t-elle besoin de tirer sont énergie du miniPC ?

 

Sinon autre piste d'exploration :

Le lien proposé par Raphael_OD propose d'explorer le journal des évènements pour remonter au premier eventID 41 et d'analyser les messages enregistrés juste avant la première coupure pour éventuellement détecter une source possible d'erreur.

 

L'autre exploration possible est de revisiter tout les eventID 41 et vérifier si l'un d'entre eux s'accompagne d'un BuckcheckCode différent de zéro.

 

En espérant que cela puisse t'aider.

Pascal

 

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

Salut Pascal,

 

Tous les events 41 sont avec:

BugcheckCode 0

BugcheckParameter1 0x0

...

 

J'ai revérifié l'historique, j'ai mis à jour le driver de la monture après le premier plantage (Kernel-Power), donc pas de causalité a priori.

La monture et tous les autres équipements ont leurs propres sources électriques à l'exception d'une caméra DMK31 qui est en USB et qui est alimentée via l'USB.

Je ne vois rien en amont des plantages Kernel-Power.

 

C'est peut-être un problème de chauffe. Mais en ouvrant le mini-PC, RAS pas de poussière et le ventilateur au-dessus d'une plaque de cuivre, fonctionne bien.

vorke-v2-plus-minipc-hardware-1024x448.j

 

J'ai installé le soft Core Temp pour monitorer un peu la température. En moyenne cela tourne autour de 59 à 60°C avec une puissance de 12W. Il y a une valeur max à 91°C sur le Cœur #0.

 

Je vais essayer de creuser la piste de la surchauffe même si je ne pige pas pourquoi cela plante tout le temps en début de nuit et jamais en cours de nuit.

 

J'ai désactivé le démarrage rapide de Windows 10. A voir si cela aura un impact.

 

Merci à tous pour vos retours.

A suivre.

Marc

 

 

 

Edited by Gribol

Share this post


Link to post
Share on other sites

Bonjour, la récurrence du problème  et la durée de fonctionnement limitée mais relativement identique en début de nuit et non par la suite, résonne avec le post ci-dessous :

Résumé : s'assurer que le ventilateur démarre lors de l'allumage du miniPC, sinon chauffage avec courbe et durée similaire  à chaque fois que le ventilateur ne démarre pas et ce jusqu'à disjonction par le CPU.

 

https://forums.commentcamarche.net/forum/affich-5843136-bizarre-pc-qui-s-eteint-seul-a-heure-fixe

 

(Lire 1/23 puis 8,9 et 10/23)

 

Pascal

  • Thanks 1

Share this post


Link to post
Share on other sites

Merci Pascal,

 

Le ventilateur qui ne démarrerait pas, c'est une bonne piste.

Connais-tu un soft permettant de savoir si le ventilateur fonctionne ou pas ?

 

Marc

Share this post


Link to post
Share on other sites
Posted (edited)

Celui-ci fait partie des plus souvent recommandés : http://www.almico.com/sfdownload.php

A bien fonctionné sur mon appareil Sony Windows 7 pro mais n'a pas marché sur mon Lenovo Windows 10 family.

 

Il existe une version Windows Store pour Windows 10 qui s'appelle "Fan Speed Setting", mais n'ai pas supporté sur mon Lenovo.

Essaye le sur ton miniPC Windows 10 Pro, avec un peut de chance cela marchera peut-être.

 

Sinon voici un comparatif : https://www.pcerror-fix.com/pc-fan-controller-software

Mis à part Fan Speed Conrtrol (sous mon Windows 7 Sony) et Thinkpad Fan Controller (TPFanControl) sous mon Windows 10 Lenovo), parmi les autres les 2, 4, 6, 7 essayés sans succès.

Edited by Pascal Tamburini
  • Thanks 1

Share this post


Link to post
Share on other sites

Salut Pascal,

 

J'ai essayé plusieurs softs (SpeedFan, Open Hardware Monitor, HW Monitor, Thinkpad Fan Controller), tous permettent de voir la température des CPU mais rien pour le ventilateur.

J'ai ouvert le mini-PC pour voir un peu comment se comportait le ventilateur. A la toute première mise sous tension, le ventilo est à l'arrêt et après quelques secondes il se met en marche.

Si je fais un arrêt/marche ensuite, le ventilo démarre tout de suite.

Donc à ce niveau là cela semble OK.

 

Je verrai dans les prochaines nuits ce qu'il va se passer.

Merci.

 

Marc

Share this post


Link to post
Share on other sites

Pourquoi faut-il un onduleur?

Est-il recommandé de placer à forte proximité l'un de l'autre des appareils électroniques?

Share this post


Link to post
Share on other sites

L'onduleur, comme je suis sur le 220V de la maison, c'est au cas où d'une coupure électrique.

Pour ce qui est des placements des appareils électroniques, il y a l'échauffement auquel il faut prêter attention, sinon je ne vois pas d'autres contre-indications.

 

Marc

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now