lepithec

M42 au 6D : vignettage ou problème de Flats ?

Recommended Posts

Bonjour,

 

Je n'ai pas eu beaucoup d'occasions de tester cette configuration, c'est chose faite avec les derniers soirs où l'on peut encore profiter d'Orion.

On m'avait prévenu que la Taka FS-60 et son correcteur 6,2 n'illuminaient pas de manière optimale le champ d'un capteur plein format, ce n'est d'ailleurs pas un hasard s'il existe des formules optiques bien plus optimisées pour cela (les FSQ ou les Epsilon par exemple).

 

Voici mon test avec 50 poses de 30 secondes à 800 ISO.

DOF : 15 darks de 30s à 800 ISO, 35 offset au 1/60e à 800 ISO et 23 flats au 1/60e à 800 ISO.

Prétraitement dans Siril (je précise que le retrait du gradient a complètement foiré).

Pas de filtre, boitier non défiltré, pollution lumineuse moyenne (ceci explique aussi cela).

 

J'ai pris soin de régler le temps de pose des flats avec l'histogramme aux 2/3 sur le LiveView (je fais mes flats avec une tablette lumineuse A4 pour dessin).

Au traitement je suis aperçu que c'était faux, ils sont trop lumineux ! L'histogramme dans LR ou PS ne correspond pas du tout à celui visionné au LiveView, quelle est donc cette sorcellerie ?!

 

En relisant des trucs sur les flats et les offset on découvre plusieurs méthodes :

- il faut les faire à 100 ISO OU BIEN il faut les faire au même ISO que les ligths

- il faut faire des offset avec le temps de pose le plus court possible (1/4000e le plus souvent) OU BIEN  il faut faire des offset avec le même temps de pose que les flats (= darks de flat)

 

Je pense qu'il y a déjà eu beaucoup de débats à ce sujet mais j'avoue en avoir perdu mon latin. Personnellement il me semble bien plus logique de faire des flats qui ressemblent à des fonds gris neutres, afin de mieux montrer les poussières et le vignettage, après il y a sûrement des contraintes mathématiques pour le traitement qui m'échappent. Dans ce cas il y a forcément une méthode optimale et meilleure qu'une autre. Je n'ai pas trop de problème avec mes flats sur le 1100D, mais le capteur étant plus petit, ça vignette forcément moins. Là avec un 6D tout est plus critique j'ai l'impression...

 

Et ici d'après vous, est-ce un problème de flat ou un chemin optique pas optimisée Full Frame ?

 

m42-fs60-6d-siril-web.jpg

Edited by lepithec
  • Like 3

Share this post


Link to post
Share on other sites
Advertising
By registering on Astrosurf,
this type of ad will no longer be displayed.
Planetary Astronomy
Observing, imaging and studying the planets
A comprehensive book about observing, imaging, and studying planets. It has been written by seven authors, all being skillful amateur observers in their respective domains.
More information on www.planetary-astronomy.com

Bonjour. :)

 

 

il y a 36 minutes, lepithec a dit :

J'ai pris soin de régler le temps de pose des flats avec l'histogramme aux 2/3 ...

 

Les "2/3" sont un ordre de grandeur : ne pas hésiter à effectuer des tests avec plusieurs séries "en dessous / au dessus" de 2/3 histoire de déterminer laquelle donne le meilleur résultat.

 

 

 

il y a 38 minutes, lepithec a dit :

Personnellement il me semble bien plus logique de faire des flats qui ressemblent à des fonds gris neutres ...

 

+1 : mes Flats sont effectués en N&B, de manière à éviter un problème de chromatisme.

 

 

 

il y a 36 minutes, lepithec a dit :

Et ici d'après vous, est-ce un problème de flat ou un chemin optique pas optimisée Full Frame ?

 

Si tu pouvais poster une "brute", ce serait cool. ^^

 

Edited by fljb67

Share this post


Link to post
Share on other sites
il y a 32 minutes, fljb67 a dit :

+1 : mes Flats sont effectués en N&B, de manière à éviter un problème de chromatisme.

Avec un APN en raw  l'image est de toute façon enregistrée  en couleur ;)

  • Like 1

Share this post


Link to post
Share on other sites
il y a 12 minutes, SLO a dit :

Avec un APN en raw  l'image est de toute façon enregistrée  en couleur ;)

 

Ah, ça, je ne savais pas. ¬¬

 

Merci à toi pour cette info. ^^

 

Après, il est certainement possible de convertir par après en N&B avec un logiciel de traitement d'images. :)

 

Edited by fljb67

Share this post


Link to post
Share on other sites
Il y a 2 heures, fljb67 a dit :

 

Après, il est certainement possible de convertir par après en N&B avec un logiciel de traitement d'images. :)

Non mais c'est surtout l'inverse: on applique les flat avant debayerisation donc ya pas vraiment de sujet sur la couleur. Et de toute façon si tu as du chromatisme sur tes flats causé par l'optique je pense qu'il faut le conserver car il sera aussi sur tes  brutes! Si tu convertis en N&B tu changes le signal d'un côté mais pas de l'autre et ça c'est pas bon ça va fausser l'opération.

Edited by LucaR

Share this post


Link to post
Share on other sites

Merci pour vos conseils !

 

J'ai refait une série de flats à 100 ISO et des dark-flats à 100 ISO, le traitement me semble mieux sous Siril mais toujours impossible d'enlever le gradient, il doit être trop fort. Ce ne serait pas étonnant car M42 était basse, j'ai des lampadaires sous le balcon et ce boitier n'a pas de filtre anti-pollution. Après c'est peut-être possible d'enlever le gradient ou de faire mieux, mais je ne sais pas faire avec les réglages de base.

 

Sinon quand j'exporte en TIF pour faire le post-traitement sous Lightroom, curieusement l'image devient toute claire, comme si l'histogramme avait été déréglé : ci-dessous, capture de l'image dans Siril, puis la visualisation dans LR. Il faut appliquer un réglage pour garder les mêmes valeurs ?

 

 

m42-fs60-6d-siril-v2-screenSR.jpg

m42-fs60-6d-siril-v2-screenLR.jpg

Share this post


Link to post
Share on other sites
il y a 7 minutes, LucaR a dit :

si tu as du chromatisme sur tes flats causé par l'optique je pense qu'il faut le conserver car il sera aussi sur tes  brutes!Si tu convertis en N&B tu changes le signal d'un côté mais pas de l'autre et ça c'est pas bon ça va fausser l'opération.

 

Salut. :)

 

Avec mon téléobjectif de 400 mm de focale ( ouvert à 5. 6 ), j'ai justement eu des problèmes en ayant empilé avec des Flats "couleur" : un genre d'auréoles pas très sympa ... phénomène qui n'a pas eu lieu avec des Flats "N&B".

 

Depuis lors : Flats en N&B e mon côté, même avec mon Mak 127.

 

Après, je fais peut-être fausse route. ¬¬

Share this post


Link to post
Share on other sites
il y a 11 minutes, lepithec a dit :

M42 était basse, j'ai des lampadaires sous le balcon ...

 

Ceci pourrait expliquer le problème en 24x36, surtout avec une lunette de  ~ 370 mm de focale.

 

Edited by fljb67

Share this post


Link to post
Share on other sites
il y a 8 minutes, lepithec a dit :

mais toujours impossible d'enlever le gradient, il doit être trop fort

T'as essayé le retrait de gradient sur la séquence avant empilement ? En général ça me donne de bons résultats. Il reste parfois un peu de gradient après empilement mais bien plus facile à retirer.

 

Pour ton souci de tif: tu sauvegarde bien en tif 16bits? Adobe ne gère pas encore correctement le 32bits.

Share this post


Link to post
Share on other sites
Il y a 4 heures, lepithec a dit :

Et ici d'après vous, est-ce un problème de flat ou un chemin optique pas optimisée Full Frame ?

Bonjour,

Pour moi, ni l'un ni l'autre.

Par rapport à ta première image tu as surtout un gradient de luminosité sur le fond du ciel en direction de l'horizon (sud ouest en bas à droite).(normal)

C'est corrigible par un retrait du gradient.

J'ai fait un essai rapide de retrait de gradient sous IRIS, ça donne ça:

 

606f24d05a225_Sanstitre-4.jpg.7682f9436739df2a082c46ea68528458.jpg

 

C'est pas parfait mais mieux quand même.

Jean-Paul

Edited by JP42
  • Like 5

Share this post


Link to post
Share on other sites
il y a 8 minutes, fljb67 a dit :

un genre d'auréoles pas très sympa ... phénomène qui n'a pas eu lieu avec des Flats "N&B".

 

Bizarre. Faudrait voir comment tu avais pris ces flats. Moi j'ai jamais eu ce genre de souci et t'es le premier que j'entend parler de flats noirs et blancs donc je pense que c'est pas normal :-)

Edited by LucaR

Share this post


Link to post
Share on other sites
il y a 11 minutes, LucaR a dit :

Bizarre.

 

Possible qu'il y ait eu à ce moment là un autre problème, genre buée sur la lentille frontale.

 

... et je ne le saurais malheureusement jamais.  ¬¬

 

Bon , j 'essayerais à l'occasion un test "Flats N&B" vs "Flats couleur" histoire de voir ce que cela donnera. :)

 

Edited by fljb67
  • Like 1

Share this post


Link to post
Share on other sites

Bonsoir,

Effectivement un gros souci sur ton image dont la cause m'échappe.

 

Ceci étant j'avoue ne pas bien saisir certaines pratiques :)

Avec un APN, on prend tout en RAW, images et DOF.

Le prétraitement des images par les DOF se fait sur les images brutes en RAW.

Ce n'est qu'après ça qu'on débayérise les images pour la suite du traitement ( registration, addition etc )

Bonne soirée,

AG

  • Like 2

Share this post


Link to post
Share on other sites
Il y a 5 heures, LucaR a dit :

T'as essayé le retrait de gradient sur la séquence avant empilement ? En général ça me donne de bons résultats.

 

Non, j'ai lu qu'on pouvait faire ça mais j'utilise les scripts de base sur Siril donc je ne sais pas faire dans cet ordre ! :)

J'essaie de suivre le tuto de Colmic sur Siril qui est très bien fait, mais certaines pratiques plus poussées m'échappent, forcément.

 

Il y a 5 heures, LucaR a dit :

Pour ton souci de tif: tu sauvegarde bien en tif 16bits? Adobe ne gère pas encore correctement le 32bits.

 

Bonne remarque, c'est probablement la source de ce problème. Je vais essayer en 16 bits. ;)

 

Merci beaucoup pour vos conseils et vos très belles versions de mon image !

Share this post


Link to post
Share on other sites

Nouvelle version avec une extraction du gradient mieux corrigée (en jouant avec les curseurs du panneau de contrôle dans Siril).

L'export en 16 bits est en effet obligatoire, le post-traitement sur LR fonctionne beaucoup mieux.

 

Instrument : Taka FS-60 + correcteur 6,2 sur monture EM200

Canon EOS 6D non modifié

50 poses de 30 secondes à 800 ISO + DOF

Traitement sous Siril + Ligthroom

 

m42-fs60-6d-siril-gradient.jpg

  • Like 4
  • Love 1

Share this post


Link to post
Share on other sites
Il y a 10 heures, lepithec a dit :

L'histogramme dans LR ou PS ne correspond pas du tout à celui visionné au LiveView, quelle est donc cette sorcellerie ?!

Là dessus: j'ai remarqué ce genre de chose aussi. Selon les logiciels ou matériel les histos ne sont pas les même. Le problème c'est que la plupart des visionneurs opèrent un stretching à leur sauce, et nous donnent l'histo après traitement, ce qui ne veut donc plus rien dire!

 

Si tu commande tes prises de vue par ordi certains logiciels proposent des outils pour mesurer le bon temps de pose. Bon, j'ai jamais réussi à en faire marche un :-D (J'ai testé ceux de Nina et Ekos). Mais du coup je me suis penché sur la question et j'en ai déduit ma méthode de prise de flat actuelle, qui marche bien mieux qu'avant désormais!

 

Donc je fais mes prises de flat par Ekos. Je place soit mon écran blanc, soit le t-shirt en visant le ciel diurne selon que je fais ça la nuit ou le lendemain matin. Puis je règle Ekos pour qu'il prenne des photos en .FIT au lieu du RAW natif,  parce que le viewer de FIT de Ekos affiche des valeurs exprimés en ADU, ce qui est plus proche du physique que ce qui est donné pour des RAW (valeurs de pixels) et m'inspire donc bien plus confiance. Il donne 4 valeurs: l'ADU minimum de l'image, l'ADU maximum de l'image, la moyenne des ADU et leur valeur médiane.

 

Au préalable, j'avais mesuré l'ADU maximum possible (saturation) de mon capteur en photographiant quelque chose de très lumineux pendant longtemps - ça m'a donné une valeur proche de 16000 ADU, ce qui était attendu (2 exposant 14 bits, c'est la valeur théorique)

 

Donc je fais des essais manuellement sous Ekos en prenant plusieurs prises de vues en FIT à la suite en faisant varier le temps de pose. Ce que je vise est que la moyenne et la médiane soient un peu plus grandes que la moitié de mon ADU max (donc ici, entre 8000 et 10000) et qu'il y ait une bonne marge entre 0 et le l'ADU minimum d'un côté (en général j'arrive dans les 3000 ou 4000) ainsi qu'entre l'ADU maximum de l'image et l'ADU de saturation (en général j'arrive à un peu plus de 13000). Quand j'arrive à ça je sais que c'est le bon temps de pose, puisque je sais que tout le signal est bien dedans avec une marge suffisante, donc aucun risque de clipping!

 

Et du coup je rétablis le réglage des prises de vues en RAW natif et je prends 40 photo avec ce temps de pose là. 

 

Je reste au même ISO de prises de vue car ça marche bien, et ça m'évite d'avoir à prendre des dark de flat - les offsets de ma bibliothèque suffisent. Quand je fais mes flat le matin de toute façon c'est compliqué de faire des darkflat en plein jour... J'ai testé des flats à ISO 100 avec des darkflat (avec la même méthode que décrit ci-dessus), c'est vrai que théoriquement c'est mieux car la courbe sera plus étendue, mais dans les faits j'ai testé et comparé sur les mêmes bruts des flats à iso800+offset et des flats à iso100+darkflat mais je n'ai pas tellement vu de différence... Du coup j'en reste à mes flat iso 800.

 

 

Edited by LucaR
  • Like 1

Share this post


Link to post
Share on other sites
Il y a 22 heures, baroche a dit :

Belle image sans le gradient ;) ...

 

Il y a 19 heures, lepithec a dit :

Nouvelle version avec une extraction du gradient mieux corrigée

 

Très bien joué à vous deux. ^^

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now